X
Tap here to go to the mobile version of the site.

Support Forum

Domain suggestion in URL bar

Posted

This new feature in version 43, as shown in the picture, is not very useful to me, as I am more often than not visiting a particular page on a site, rather the the domain of the site itself. Whereas before I would just have to type a letter and hit enter, I now have to hit the arrow down and hit enter. I know it's not a great deal of work but these little things annoy me. Is there an about:config change to get rid of this new behaviour?

This new feature in version 43, as shown in the picture, is not very useful to me, as I am more often than not visiting a particular page on a site, rather the the domain of the site itself. Whereas before I would just have to type a letter and hit enter, I now have to hit the arrow down and hit enter. I know it's not a great deal of work but these little things annoy me. Is there an about:config change to get rid of this new behaviour?
Attached screenshots

Modified by DanielJG

Chosen solution

Hmm, interesting. The first item on the list, which for me is pre-selected, seems to provide information about what will happen if you press Enter or click the Go button. For example, if you have URL bar autofill enabled (which is the default), a matching site is shown. If you disable autofill, then you may get an indication that Firefox will search for the characters you typed. I have attached contrasting screen shots for reference.

I think if you want to use an item from the list, you still need to press the down arrow the same number of times as before.

If you do not want this visual cue, it can be removed by disabling a preference, but this preference may have other important aspects that would also be disabled, so be on the lookout for unexpected changes in the bar's behavior and let us know if there are problems.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.unifiedcomplete preference to switch it from true to false

Does that help?

Alternately, you probably could use a custom style rule to hide the explanatory entry, but I haven't dug into that yet.

Read this answer in context 3

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Chosen Solution

Hmm, interesting. The first item on the list, which for me is pre-selected, seems to provide information about what will happen if you press Enter or click the Go button. For example, if you have URL bar autofill enabled (which is the default), a matching site is shown. If you disable autofill, then you may get an indication that Firefox will search for the characters you typed. I have attached contrasting screen shots for reference.

I think if you want to use an item from the list, you still need to press the down arrow the same number of times as before.

If you do not want this visual cue, it can be removed by disabling a preference, but this preference may have other important aspects that would also be disabled, so be on the lookout for unexpected changes in the bar's behavior and let us know if there are problems.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.unifiedcomplete preference to switch it from true to false

Does that help?

Alternately, you probably could use a custom style rule to hide the explanatory entry, but I haven't dug into that yet.

Hmm, interesting. The first item on the list, which for me is pre-selected, seems to provide information about what will happen if you press Enter or click the Go button. For example, if you have URL bar autofill enabled (which is the default), a matching site is shown. If you disable autofill, then you may get an indication that Firefox will search for the characters you typed. I have attached contrasting screen shots for reference. I think if you want to use an item from the list, you still need to press the down arrow the same number of times as before. If you do not want this visual cue, it can be removed by disabling a preference, but this preference may have other important aspects that would also be disabled, so be on the lookout for unexpected changes in the bar's behavior and let us know if there are problems. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.unifiedcomplete''' preference to switch it from true to false Does that help? Alternately, you probably could use a custom style rule to hide the explanatory entry, but I haven't dug into that yet.

Question owner

That seems to have restored it to it's previous behaviour, or at least looks like it. I'll keep an eye on things. Thanks for your help!

That seems to have restored it to it's previous behaviour, or at least looks like it. I'll keep an eye on things. Thanks for your help!