Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 42 noticeable lag when I visit a particular site

  • 3 replies
  • 1 has this problem
  • 56 views
  • Last reply by FredMcD

more options

Firefox 42 noticeable lag when I visit a particular site.

Hi Mozilla, This is the site http://www.deccanherald.com/. When I open 8 or more tabs on this site Firefox gets laggy. I right click on a link and choose open a new tab there is a delay of a few seconds before the right click menu appears and then another delay to open in a new tab. when I'm scrolling down there are more delays and when I move from tab to tab still more delays.

When I visit this same site in Internet Explorer 11 I don't experience any issue it works fine. My specs Alienware M14XR2 i7-3630QM, 8 GB RAM, NVIDIA Geforce GT 650M, Windows 7 Home Premium Service Pack 1 64 Bit .

Chosen solution

I don't see any problem. I've called the big guys to help you. Good luck.

Read this answer in context 👍 0

All Replies (3)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


Are there a lot of video players on that site?

This is not a cure, but should let the web page load without crashing.

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

more options

Hi, So I tried all your suggestions deleted cookies, cleared my web cache, disabled hardware acceleration, disabled auto scroll. It didn't work still experiencing lag. There are some videos on the main page but they don't start playing until you click on them. There is a photo gallery that auto scrolls. The headlines scroll by and then pause and start scrolling again. I refreshed firefox but that doesn't solve the problem either. I tried it in safe mode too. Anyway as long as mozilla knows about it maybe they will check it out fix it. Does the website work for you? Thanks.

more options

Chosen Solution

I don't see any problem. I've called the big guys to help you. Good luck.