Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't install extensions that require browser restart

  • 20 replies
  • 7 have this problem
  • Last reply by cor-el

more options


FF 42.0 / Windows 7 64-bit

I have a problem with installing any extension that requires browser restart (for example Web Developer Toolbar). Addons that do not require browser restart (like firebug, adblock plus) are installed with no issues. When I go to about:addons search for addon, click install, it gets installed with no error messages but after I restart the browser it's simply not installed. By the way this problem has every windows workstation I checked in my company (Thomson-Reuters, Gdynia) and there is always the same problem even after fresh FF installation so it's not related to my specific laptop. I checked with local IT but they have no idea what the reason of that problem could be. This is not officially supported browser so it's not their duty to troubleshoot it. They just checked if the problem reoccurs when addon is installed with antivirus disabled and yes - with disabled antivirus software the problem still exists. I checked but none of the cases from above-mentioned KBs seem to be relevant to my problem. I'm not power Firefox user so I would like kindly ask for advice how the problem could be troubleshooted: -are there any specific settings in about:config I should look into? -are there any certificates that could have been replaced on a corporate machine and are required for addon installation? -any specific entries in configuration files that I should check before and after the browser restart? -anything else..

Regards, Rafał

All Replies (20)

more options

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete possible addons.json and addons.sqlite files.

You can also check for problems with preferences.

more options

Deleting extensions.* files is one of the suggestions on the support page and I have tried it already. I have also created completely new profile (firefox.exe -ProfileManager). I even tried adding new local user in Windows OS but there is still the same issue. As I mentioned already this problem exists on every corporate windows machine in my company I tried (and I tried around 5 different ones) so if it's related to corrupted profile there must be something that makes these profiles corrupted every time.

I'm not sure if this is related to my issue but I have attached BrowserConsole logs after installing extension and restarting browser. I just replaced my username with XXXXX string.

Could not read chrome manifest 'file:///C:/Program%20Files%20(x86)/Mozilla%20Firefox/chrome.manifest'. 1449954964446 addons.xpi ERROR Unable to read add-on manifest from C:\Users\XXXXX\AppData\Roaming\Mozilla\Firefox\Profiles\ntec2z2d.Default User\extensions\staged\{c45c406e-ab73-11d8-be73-000a95be3b12}.xpi: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line 228" data: no] Stack trace: XPCU_serviceLambda()@resource://gre/modules/XPCOMUtils.jsm:228 < XPCU_defineLazyGetter/<.get()@resource://gre/modules/XPCOMUtils.jsm:196 < defineSyncGUID()@resource://gre/modules/addons/XPIProvider.jsm:1101 < loadManifestFromZipReader()@resource://gre/modules/addons/XPIProvider.jsm:1251 < next()@self-hosted:624 < TaskImpl_run()@resource://gre/modules/Task.jsm:314 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813 < this.PromiseWalker.scheduleWalkerLoop/<()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747 < syncLoadManifestFromFile()@resource://gre/modules/addons/XPIProvider.jsm:1312 < XPI_processPendingFileChanges/<()@resource://gre/modules/addons/XPIProvider.jsm:2873 < forEach()@self-hosted:211 < XPI_processPendingFileChanges()@resource://gre/modules/addons/XPIProvider.jsm:2783 < XPI_checkForChanges()@resource://gre/modules/addons/XPIProvider.jsm:3837 < XPI_startup()@resource://gre/modules/addons/XPIProvider.jsm:2413 < callProvider()@resource://gre/modules/AddonManager.jsm:221 < _startProvider()@resource://gre/modules/AddonManager.jsm:828 < AMI_startup()@resource://gre/modules/AddonManager.jsm:999 < AMP_startup()@resource://gre/modules/AddonManager.jsm:2672 < AMC_observe()@resource://gre/components/addonManager.js:58 < <file:unknown> Log.jsm:749:0 While creating services from category 'profile-after-change', service for entry 'Sapi Speech Synth', contract ID ';1' does not implement nsIObserver. Get a connection to permissions.sqlite. Expected color but found 'none'. Error in parsing value for 'border-color'. Declaration dropped. browserOverlay.css:143:18 mutating the Prototype of an object will cause your code to run very slowly; instead create the object with the correct initial Prototype value using Object.create repair:8:4049 1449954977595 Services.HealthReport.HealthReporter WARN Error during initialization: TypeError: is undefined (resource://gre/modules/Sqlite.jsm:917:5) JS Stack trace: openConnection/<@Sqlite.jsm:917:5 < openConnection@Sqlite.jsm:910:1 < initTask@HealthReport.jsm:2433:1 1449954977595 Services.HealthReport.HealthReporter WARN Initialization had error. Shutting down immediately. 1449954977595 Services.HealthReport.HealthReporter WARN Initiating main shutdown procedure. 1449954977596 Services.HealthReport.HealthReporter WARN Shutdown complete. 1449954977600 Services.HealthReport.HealthReporter WARN Not initialized. Sending report with only error info. 1449954977602 Services.HealthReport.HealthReporter WARN Recording new remote ID: 319e427f-3443-436b-9e38-6ae7508fdd12 1449954978334 Services.HealthReport.HealthReporter WARN Marking upload as successful. 1449954978334 Services.HealthReport.HealthReporter WARN Removing documents from remote ID list: f4b48a19-0d79-4cda-bee2-73fee74c0a57 A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'? See

Date: Sat Dec 12 2015 22:16:17 GMT+0100 (Central European Standard Time) Full Message: TypeError: is undefined Full Stack: openConnection/<@resource://gre/modules/Sqlite.jsm:917:5 openConnection@resource://gre/modules/Sqlite.jsm:910:1 initTask@resource://gre/modules/HealthReport.jsm:2433:1 TaskImpl_run@resource://gre/modules/Task.jsm:330:41 TaskImpl@resource://gre/modules/Task.jsm:275:3 createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:249:14 Task_spawn@resource://gre/modules/Task.jsm:164:12 this.MetricsStorageBackend@resource://gre/modules/HealthReport.jsm:2432:1 AbstractHealthReporter.prototype<.init/<@resource://gre/modules/HealthReport.jsm:4371:29 TaskImpl_run@resource://gre/modules/Task.jsm:314:40 Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934:23 this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813:7 this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747:1

more options

What other extensions are installed?

Does this also happen with no extensions installed when you try to install and extension that requires a restart?

Did you try to install the extension in Safe Mode?

more options

At the moment I have installed Adblock Plus, Firebug and some plugins listed in system details next to my initial post. As I mentioned before the problem exists also on a fresh FF installation on the OS build we have in my company. I tried to install Web Developer Toolbar in Safe Mode and I have to say it was installed to some extent but the installation seems to be incomplete/corrupted:

  • there is no extension icon (see attached screenshot)
  • options button does not work (clicking on it 'blocks' browser window, so you can't access any link or menu)
more options

Type chrome://mozapps/content/extensions/extensions.xul?<enter> in the address bar. Does this show the missing add-ons? Or anything else?

more options

It navigates me to about:addons. It shows currently installed extensions (Adblock Plus and Firebug).

more options

Start your Computer in safe mode with networking. Then start Firefox.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Now try one of those add-ons. Is the problem still there?

more options

I tried already to do it even in safe mode without networking and install extension from saved xpi file. In both cases (safe mode with or without networking) issue still exists.

more options

I've called the big guys to help you. Good luck.

more options

FredMcD said

I've called the big guys to help you. Good luck.

Hi FredMcD,

Has there been any progress on this issue?

Thank you!

more options

Sorry. I placed another call for help.

more options

Try to delete the "extensions\staged\" folder in the Firefox profile folder if this folder exists.

  • Help > Troubleshooting Information > Profile Directory:
    Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

If deleting the extensions files didn't help then delete add-ons.json and possibly prefs.js in case there is a problem with preferences.

more options

Sorry if this is not too cheeky but if I stated already:

  • I created completely new Firefox profile using profile manager
  • I tried creating new windows user
  • I tried fresh FF install on five different hosts on the same windows built
  • I tried installing extension in windows safe mode with or without networking

and none of these actions helped then what innovative is in your advice?

more options

The extensions folder is completely empty after installing an extension and there is also no staged folder, so it looks that the download is failing.

Did you try to copy the staged folder from a working profile to a not working profile to check if that at least works?

more options

I just tried copying the staged folder, but it seems to get nuked when I start firefox back up again.

I also tried copying a profile from the working system to the Windows 7 system, and for some reason, it completely nukes Greasemonkey (within the extensions directory, extensions.ini, and extensions.json) when I start Firefox.

more options

Did you remove all extensions files and compatibility.ini in the main profile folder after copying the extensions or staged folder?

Modified by cor-el

more options

No, I will try that next.

In the mean time, is there a command line option to have Firefox dump logging information regarding extension installation to the command prompt?

more options

Good idea! There is a extensions.logging.enabled pref in about:config. Try setting that to true. That may help you get more info about this. extensions.logging.enabled = true. This will send more detailed information about installation and update problems to the Error Console. (Note that the extension manager automatically restarts the application at startup sometimes, which may mean you won't have time to see the messages logged before the automatic restart happens. To see them, prevent the automatic restart by setting the environment NO_EM_RESTART to 1 before starting the application.)

Note: The Error Console is disabled by default starting in Gecko 2.0. You can re-enable it by changing the devtools.errorconsole.enabled preference to true and restarting the browser. With this, javascript.options.showInConsole is also set to true by default.

If the Error Console doesn't appear after that, please check the Browser console next:

more options

Thank you, Noah_SUMO! That seems to reveal the location of the error:

1458920525129 addons.xpi ERROR Unable to read add-on manifest from C:\Users\OTC\AppData\Roaming\Mozilla\Firefox\Profiles\0mysoetl.rra\extensions\staged\{e4a8a97b-f2ed-450b-b12d-ee082ba24781}.xpi: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line 230" data: no] Stack trace: XPCU_serviceLambda()@resource://gre/modules/XPCOMUtils.jsm:230 < XPCU_defineLazyGetter/<.get()@resource://gre/modules/XPCOMUtils.jsm:198 < defineSyncGUID()@resource://gre/modules/addons/XPIProvider.jsm:1254 < loadManifestFromZipReader<()@resource://gre/modules/addons/XPIProvider.jsm:1433 < TaskImpl_run()@resource://gre/modules/Task.jsm:315 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:933 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:812 < this.PromiseWalker.scheduleWalkerLoop/<()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:746 < syncLoadManifestFromFile()@resource://gre/modules/addons/XPIProvider.jsm:1489 < this.XPIProvider.processPendingFileChanges()@resource://gre/modules/addons/XPIProvider.jsm:3279 < this.XPIProvider.checkForChanges()@resource://gre/modules/addons/XPIProvider.jsm:3568 < this.XPIProvider.startup()@resource://gre/modules/addons/XPIProvider.jsm:2657 < callProvider()@resource://gre/modules/AddonManager.jsm:227 < _startProvider()@resource://gre/modules/AddonManager.jsm:833 < AddonManagerInternal.startup()@resource://gre/modules/AddonManager.jsm:1016 < this.AddonManagerPrivate.startup()@resource://gre/modules/AddonManager.jsm:2782 < amManager.prototype.observe()@resource://gre/components/addonManager.js:58 Log.jsm:751:0

The full results are in this zipball:

I also tried cor-el's suggestions. One time it installed Greasemonkey as a disabled addon and it was possible to enable it. I tried again (many times), but could not get it to work again. Worse yet, I forgot to back up that directory after the success! Doh!!!

more options

Did you try to install an extension in Firefox Safe Mode?