X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Lately whenever I open a new window, my last used websites load even though I didn't want that option

Posted

When I open a new window my last used websites load. In the 'Options' section, I have it as 'Show My Home Page'. No matter how I change it, the websites still show up when I open a new window. Why does this happen?

When I open a new window my last used websites load. In the 'Options' section, I have it as 'Show My Home Page'. No matter how I change it, the websites still show up when I open a new window. Why does this happen?

Chosen solution

You may have corrupt sessionstore file(s).

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate thesessionstore file(s). Then rename or delete them. Restart Firefox.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.15
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

More Information

logglog 1 solutions 10 answers

Under the Show MY Home Page, you need to type what homepage you want to open eg. https://www.duckduckgo.com/ or https://www.google.com/

Under the Show MY Home Page, you need to type what homepage you want to open eg. https://www.duckduckgo.com/ or https://www.google.com/
FredMcD
  • Top 10 Contributor
4387 solutions 61566 answers

Chosen Solution

You may have corrupt sessionstore file(s).

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate thesessionstore file(s). Then rename or delete them. Restart Firefox.

You may have corrupt '''sessionstore''' file(s). Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the'''sessionstore''' file(s). Then rename or delete them. Restart Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17849 solutions 161544 answers

Firefox opens the home pages in a new window, so you may have set multiple pages as the home page(s).

You can check the home page setting to see if multiple pages separated by a vertical bar (|) are present.

Note that this can happen if you click "Use Current Page(s)" to set the home page. To set a single page as the home page you can drag the globe/padlock to the toolbar Home button.

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

Firefox opens the home pages in a new window, so you may have set multiple pages as the home page(s). You can check the home page setting to see if multiple pages separated by a vertical bar (|) are present. Note that this can happen if you click "Use Current Page(s)" to set the home page. To set a single page as the home page you can drag the globe/padlock to the toolbar Home button. You can check the home page setting: *Tools > Options > General > Startup: Home page *https://support.mozilla.org/kb/How+to+set+the+home+page Firefox supports multiple home pages separated by '|' (pipe) symbols.