Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do my changes in about:config to make KTorrent accept magnets reset each time I restart Firefox?

  • 12 replies
  • 5 have this problem
  • 824 views
  • Last reply by cor-el

more options

I have Ubuntu 15.10, Firefox 42 and KTorrent 4.3.1 For some reason the magnet links quit working a couple of months ago. So I went on this page : http://ubuntuguide.org/wiki/KTorrent and found that the line "network.protocol-handler.expose.magnet" was missing. So I created it, setting it to false as per instructions. Magnets worked! But then I restarted Firefox and the line dissapeared! So I re-created it. It did it every time I restarted Firefox except yesterday : It was there after restart but the value had changed to True!!! And today, the line has again dissapeared! Any suggestion? Should I call GhostBusters? :-) Thanks! SPC

Chosen solution

network.protocol-handler.expose.magnet = false (not be opened in FF) network.protocol-handler.external.magnet = true (allow external app) network.protocol-handler.app.magnet = path to KTorrent

Read this answer in context 👍 1

All Replies (12)

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Does that protocol stop working?

You should see a network.protocol-handler.app.magnet pref once you have set the application.

See:

more options

FredMcD Thanks but I don't have those softwares.

cor-el Thanks but I tried this and first time I restarted, the value changed to True again and the second time the line disappeared! Again!

Gremlins? Ghosts? .... HAHAHA!

Guess I'll have to keep retyping!

Thanks for your help!

more options

So, you do not see: network.protocol-handler.app.magnet ? Nothing comes up when you search to magnet on the about:config page?

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

cor-el Tough Gremlins!!! LOL

So I deleted the file. First restart, the value changes to True, second restart, line is gone! Tried it a few times, disabled a few plugins, just in case, still does the same.

Guess the only thing left are resetting all settings or re-installing Firefox. I just hate having to re-install my plugins and re-configuring all to my taste. Oh well! That's the price to pay to have Linux! I also have Windows on this machine, but it's much slower than Linux. Easier, but slower. Haven't used it for about a year! Afraid to boot in Windows for it might spend a couple of hours downloading updates! LOL

Well thanks for your efforts. I might come back once I find the courage to try re-installing! Also need the time... ;-)

Thanks again!

more options

spaulcote said

FredMcD Thanks but I don't have those softwares.

Did you check the link I posted?

FredMcD said

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save
more options

FredMcD Hi and thanks,

I did read it. Thing is, I also added the "network.protocol-handler.app.magnet" pref that cor-el mentioned and this line does not disappear.

And the funny thing is the first time I restart Firefox, the "network.protocol-handler.expose.magnet" line remains, but the value changes from False to True. The I restart a second time and the whole line is gone! Yet, my other change, "network.protocol-handler.app.magnet" remains unchanged. So the file must not be "locked".

Wich is why I think I need to "reset" all settings by deleting my main prefs file. It's just that I kinda get comfortable once I have my settings the way I like it and I have this "thing" about getting out of my comfort zone! LOL Oh well! I've seen worst. Just getting old, I guess. Old dogs like their old carpets! :-)

Thanks again both of you. Thank you for taking the time to help.

Gremlins, hmmmm, oh yes! Shove them in the microwave! Nope! Microwave too small. My PC won't fit! :-)

more options

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences

more options

FredMcD Nice! Thanks!

I already installed them, but I'll try them tomorrow. Done enough mischiefs for today. Time to watch a bit of TV before Morpheusleads me to the land of dreams... ;-)

Take care!

more options

Do you have a network.protocol-handler.app.magnet pref that point to the correct application?

See also:

network.protocol-handler.expose.<protocol> = false (not be opened in FF)
network.protocol-handler.external.<protocol> = true (allow external app)

Note that you need a 64 application that can handle the magnet protocol.

more options

cor-el Hi and thanks for your answer.

I did add the network.protocol-handler.app.magnet pref the first time you mentioned it and it points to KTorrent.

I went to read your last page suggestions and tried it all and it didn't change anything. First restart, the magnet value changed to True (KTorrent doesn't start) then on second restart the line disappears.

So, I figured if I'm to erase my prefs file, I might as well try a few things.

The first line "network.protocol-handler.expose" (nothing after expose) was set to False. So I reversed the value to true.

I did not add the magnet line. I just went and tried a magnet link and it opened a new, empty tab in Firefox, but it also asked me wich application to use (showed KTorrent as choice) and opened my KTorrent!!!

So I restarted Firefox a couple of time and it still opens an empty tab for nothing but at least, it opens Ktorrent! Weird! But it works! Just hope it doesn't affect another app!

Don't know why the network.protocol-handler.expose pref was set to False. I didn't touch it. It just happens to be the first line in the "expose" series so it was the first one I tried changing the value!

I guess the network.protocol-handler.app.magnet pref that you made me add works better than the "magnet pref" the KTorrent page made me add and that keeps disappearing!

Bloody Gremlins! We beat them just the same! LOL

So finally, I won't have to spend a lot of time backing up, resetting my prefs and so on! I'll just have to live with the tab that opens for nothing. Not a big thing! My magnet links work and that all I wanted.

Thanks to both of you for your help. I really appreciate you taking time to educate me (and others). Even old dogs like me can learn new tricks! LOL!

Now I can go back to my old carpet. ;-)

more options

Chosen Solution

network.protocol-handler.expose.magnet = false (not be opened in FF) network.protocol-handler.external.magnet = true (allow external app) network.protocol-handler.app.magnet = path to KTorrent