Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Howto enable Adobe pdf-plugin and add langugate packs for all users

  • 1 reply
  • 1 has this problem
  • 56 views
  • Last reply by cor-el

more options

I have firefox installations on many terminalservers and my users are bugged every day with a prompt to enable Adobe PDF plug-in to view PDF-files within the browser.

We are using a group policy object to override diffrent settings on default homepage and disabled the built-in PDF reader.

How do I activate plug-ins for all users? How do i install langugate packs and dictionary for all users for norwegian?

I have firefox installations on many terminalservers and my users are bugged every day with a prompt to enable Adobe PDF plug-in to view PDF-files within the browser. We are using a group policy object to override diffrent settings on default homepage and disabled the built-in PDF reader. How do I activate plug-ins for all users? How do i install langugate packs and dictionary for all users for norwegian?

Chosen solution

Unfortunately you can no longer install extensions including language pack via the distribution/bundles folder in the Firefox program folder.

  • Bug 1144127 - Remove support for distribution/bundles (39+)

For the language packs, see:

A mozilla.cfg file in the Firefox program folder can be used to lock prefs or specify new (default) values.

A local-settings.js file needs to be placed in the "defaults/pref" folder where also the channel-prefs.js file is located to specify using mozilla.cfg.

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0);

These functions can be used in the mozilla.cfg file:

defaultPref();	// set new default value
pref();		// set pref, allow changes in current session
lockPref();	// lock pref, disallow changes

See Configuration:

See also:

You can try this in the mozilla.cfg file:

//
pref("plugin.state.nppdf", 2);
Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Unfortunately you can no longer install extensions including language pack via the distribution/bundles folder in the Firefox program folder.

  • Bug 1144127 - Remove support for distribution/bundles (39+)

For the language packs, see:

A mozilla.cfg file in the Firefox program folder can be used to lock prefs or specify new (default) values.

A local-settings.js file needs to be placed in the "defaults/pref" folder where also the channel-prefs.js file is located to specify using mozilla.cfg.

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0);

These functions can be used in the mozilla.cfg file:

defaultPref();	// set new default value
pref();		// set pref, allow changes in current session
lockPref();	// lock pref, disallow changes

See Configuration:

See also:

You can try this in the mozilla.cfg file:

//
pref("plugin.state.nppdf", 2);

Modified by cor-el