Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox considers Add-ons link and all links untrusted

  • 5 replies
  • 1 has this problem
  • 24 views
  • Last reply by edspyhill09

more options

Firefox considers Add-ons link and all links untrusted. I can't even connect to disable add-ons. I reinstalled firefox and it was working then it stopped all my connections as untrusted. Guys, you have a problem here. I'm not the only one. Is this a Firefox/Lastpass issue?

All Replies (5)

more options
more options

You are correct that you're not the only one. I don't know whether you found any of the earlier threads helpful, but I'll repeat my usual spiel:

When you get untrusted connection errors for pretty much all secure sites, the problem usually is one of the following:

(1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem.

(2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, ESET, and Kaspersky; AVG has a Search Shield feature which can cause this error on search sites.

(3) On Windows 10, Firefox not being set up to work with the parental control software Microsoft Family Safety. (To test by turning it off, see: http://windows.microsoft.com/en-us/wi.../turn-off-microsoft-family-settings)

(4) Malware on your system intercepting secure connections.

So... which is it?

If you have any of those specific security products, that would be the first thing to check. We might be able to assist with specific next steps based on what you have if you tell us.


To gather further information, you could inspect a sample certificate to see whether that points to the culprit. If you want to try that now, here's how I suggest starting:

Load my test page at: https://jeffersonscher.com/res/jstest.php

You likely will get an error page. Expand the "I understand the risks" section and look for an Add Exception button.

Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, and the certificate exception dialog should open.

Click the View button. If View is not enabled, try the Get Certificate button first.

This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

more options

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

more options

FredMcD said

What is yout computer system and Firefox? http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message http://kb.mozillazine.org/Error_loading_websites This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

My computer clock is automatically updated. If this is a problem then Firefox is "too secure", that is, unusable.

Thank you,

Ed

more options

cor-el said

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:
  • chrome://pippki/content/exceptionDialog.xul
In the location field of this window type or paste the URL of the website.
  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer
You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

I uninstalled Firefox and deleted a Firefox subdirectory. I probably didn't get all existing files/directories. I then rebooted the PC.

I reinstalled Firefox. I disabled HTTPS Everywhere. I left the Lastpass add-on active.

I'll have to use it to see if the problem returns.

I also submitted a question to Malwarebytes to see if there are any conflicts.

Ed