X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashes when I play youtube or flash in the background

Posted

Hello everyone Starting last month with the newest firefox update I've run into an annoying crashes whenever I play youtube or any thing using flash for firefox it will crash a few minutes later. So I read through mozilla support to fix the problem myself and did the following options: turned off hardware acceleration both for firefox and adobe, scanned for viruses, updated my drivers, and even did memtest86. All to no avail finally I decided to simply wait for the newest update to fix this bug. So the good news is it fixed the nvwgf2um.dll error but not msmpeg2vdec.dll.

Here are my last five bug reports bp-1a0705e8-cd44-43a3-9750-755f32151101

bp-a0910808-96fc-4fe0-84ff-4e6082151101

bp-8b259b02-e800-436c-9797-100f72151101

bp-58d49e9e-6aba-468c-97e3-4ef312151030

bp-0142b586-36b4-46d7-8b52-0d59a2151030

Hello everyone Starting last month with the newest firefox update I've run into an annoying crashes whenever I play youtube or any thing using flash for firefox it will crash a few minutes later. So I read through mozilla support to fix the problem myself and did the following options: turned off hardware acceleration both for firefox and adobe, scanned for viruses, updated my drivers, and even did memtest86. All to no avail finally I decided to simply wait for the newest update to fix this bug. So the good news is it fixed the nvwgf2um.dll error but not msmpeg2vdec.dll. Here are my last five bug reports bp-1a0705e8-cd44-43a3-9750-755f32151101 bp-a0910808-96fc-4fe0-84ff-4e6082151101 bp-8b259b02-e800-436c-9797-100f72151101 bp-58d49e9e-6aba-468c-97e3-4ef312151030 bp-0142b586-36b4-46d7-8b52-0d59a2151030

Modified by triedeverything

Chosen solution

Sorry to hear about the crashes. You wrote:

triedeverything said

All to no avail finally I decided to simply wait for the newest update to fix this bug. So the good news is it fixed the nvwgf2um.dll error but not msmpeg2vdec.dll.

Hmm, I wouldn't have thought the external video decoding components were the heart of the problem. The "crashing thread" in the reports doesn't "die" in a video decoding function. The four most recent crashed in either "garbage collection" or "cycle collector" functions, dealing with memory. I personally find such crash reports hard to understand.

As a partial workaround, you could use an extension that forces Flash on YouTube, such as one of the following:

Alternately you could try disabling MPEG decoding, but some sites may not be able to "fall back" to another format or to Flash and will just error out (e.g., Twitter videos):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) Double-click the media.directshow.enabled preference to switch it from true to false

(4) Double-click the media.mediasource.mp4.enabled preference to switch it from true to false

(5) Double-click the media.mediasource.webm.enabled preference to switch it from false to true

(6) Double-click the media.windows-media-foundation.enabled preference to switch it from true to false

The effect of that all that should be to block MP4/h.264 decoding and switch YouTube to the latest WebM (VP9) format. You could check the result on this page, although that might not all show until after you exit Firefox and start it up again:

https://www.youtube.com/html5 (both h.264 should be red)

This isn't so practical for other video sites, but I'm curious whether it helps on YouTube or has the same issues.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.11 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • NoScript 2.6.9.39 ({73a6fe31-595d-460b-a920-fcc0f8843232})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 950
  • adapterDescription2:
  • adapterDeviceID: 0x1402
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 29593842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.17999
  • driverDate: 10-12-2015
  • driverDate2:
  • driverVersion: 10.18.13.5859
  • driverVersion2:
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 950 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8838 solutions 72243 answers

Chosen Solution

Sorry to hear about the crashes. You wrote:

triedeverything said

All to no avail finally I decided to simply wait for the newest update to fix this bug. So the good news is it fixed the nvwgf2um.dll error but not msmpeg2vdec.dll.

Hmm, I wouldn't have thought the external video decoding components were the heart of the problem. The "crashing thread" in the reports doesn't "die" in a video decoding function. The four most recent crashed in either "garbage collection" or "cycle collector" functions, dealing with memory. I personally find such crash reports hard to understand.

As a partial workaround, you could use an extension that forces Flash on YouTube, such as one of the following:

Alternately you could try disabling MPEG decoding, but some sites may not be able to "fall back" to another format or to Flash and will just error out (e.g., Twitter videos):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) Double-click the media.directshow.enabled preference to switch it from true to false

(4) Double-click the media.mediasource.mp4.enabled preference to switch it from true to false

(5) Double-click the media.mediasource.webm.enabled preference to switch it from false to true

(6) Double-click the media.windows-media-foundation.enabled preference to switch it from true to false

The effect of that all that should be to block MP4/h.264 decoding and switch YouTube to the latest WebM (VP9) format. You could check the result on this page, although that might not all show until after you exit Firefox and start it up again:

https://www.youtube.com/html5 (both h.264 should be red)

This isn't so practical for other video sites, but I'm curious whether it helps on YouTube or has the same issues.

Sorry to hear about the crashes. You wrote: ''triedeverything [[#question-1091602|said]]'' <blockquote> All to no avail finally I decided to simply wait for the newest update to fix this bug. So the good news is it fixed the nvwgf2um.dll error but not msmpeg2vdec.dll. </blockquote> Hmm, I wouldn't have thought the external video decoding components were the heart of the problem. The "crashing thread" in the reports doesn't "die" in a video decoding function. The four most recent crashed in either "garbage collection" or "cycle collector" functions, dealing with memory. I personally find such crash reports hard to understand. As a partial workaround, you could use an extension that forces Flash on YouTube, such as one of the following: * https://addons.mozilla.org/firefox/addon/youtube-flash-player/ * https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ Alternately you could try disabling MPEG decoding, but some sites may not be able to "fall back" to another format or to Flash and will just error out (e.g., Twitter videos): (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media.''' and pause while the list is filtered (3) Double-click the '''media.directshow.enabled''' preference to switch it from true to false (4) Double-click the '''media.mediasource.mp4.enabled''' preference to switch it from true to false (5) Double-click the '''media.mediasource.webm.enabled''' preference to switch it from false to true (6) Double-click the '''media.windows-media-foundation.enabled''' preference to switch it from true to false The effect of that all that should be to block MP4/h.264 decoding and switch YouTube to the latest WebM (VP9) format. You could check the result on this page, although that might not all show until after you exit Firefox and start it up again: https://www.youtube.com/html5 (both h.264 should be red) This isn't so practical for other video sites, but I'm curious whether it helps on YouTube or has the same issues.
cor-el
  • Top 10 Contributor
  • Moderator
17694 solutions 160091 answers

Are you using the Firefox 42.0 RC2 version or an older beta version?

Make sure to update to the latest version via "Help >About".

Are you using the Firefox 42.0 RC2 version or an older beta version? Make sure to update to the latest version via "Help >About".

Modified by cor-el

Question owner

thank you for replying jscher. In the about:config section I did almost everything you instructed but I was unable to find media.windows-media-foundation.enabled . I'll check and see if it works.

Hey cor-el I'm using the most recent firefox update of firefox 42.0

thank you for replying jscher. In the about:config section I did almost everything you instructed but I was unable to find '''media.windows-media-foundation.enabled '''. I'll check and see if it works. Hey cor-el I'm using the most recent firefox update of firefox 42.0

Question owner

alright i think jscher and cor-el managed to fix my msmpeg2vdec.dll problem unfortunately I am still crashing due to icudt55.dll any idea what it is? Good news is I no longer crash every few minutes now its every hour. bp-1ed72501-aabf-4756-87e8-568ea2151101

bp-1ed72501-aabf-4756-87e8-568ea2151101

alright i think jscher and cor-el managed to fix my msmpeg2vdec.dll problem unfortunately I am still crashing due to icudt55.dll any idea what it is? Good news is I no longer crash every few minutes now its every hour. bp-1ed72501-aabf-4756-87e8-568ea2151101 bp-1ed72501-aabf-4756-87e8-568ea2151101

Modified by triedeverything

Question owner

I'm sorry but is it possible to open this question up again? The problem seems to have returned although it no longer says that msmpeg2vdec.dll is to blame it still seems to crash whenever I play youtube or a flash. I checked the bug reports but I don't see anything wrong.

bp-b0db7b60-bc1f-4c39-bb4f-864582151102

bp-c0b2997b-15f4-455e-bb2b-e0d322151102

bp-786a48fb-3dd9-40ed-a84d-7b6122151102

bp-41cd1d76-1118-4d30-8a25-042742151102

bp-120d6db6-cda1-4703-82b1-8c9612151102

I'm sorry but is it possible to open this question up again? The problem seems to have returned although it no longer says that msmpeg2vdec.dll is to blame it still seems to crash whenever I play youtube or a flash. I checked the bug reports but I don't see anything wrong. bp-b0db7b60-bc1f-4c39-bb4f-864582151102 bp-c0b2997b-15f4-455e-bb2b-e0d322151102 bp-786a48fb-3dd9-40ed-a84d-7b6122151102 bp-41cd1d76-1118-4d30-8a25-042742151102 bp-120d6db6-cda1-4703-82b1-8c9612151102

Modified by triedeverything

cor-el
  • Top 10 Contributor
  • Moderator
17694 solutions 160091 answers

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Maybe check for font issues and try a different default font.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 Maybe check for font issues and try a different default font.

Helpful Reply

Might be a problem with my computer ram or graphics card getting it checked gone for few days.

Might be a problem with my computer ram or graphics card getting it checked gone for few days.