Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-On Classic Theme Restorer Changes New Tab Page Layout Automatically. How do I change it back with this add-on?

  • 3 replies
  • 1 has this problem
  • 3 views
  • Last reply by cor-el

more options

I have no clue. After upgrading from Firefox 38 to the latest Firefox 41.0.2 with the add-on "Classic Theme Restorer" enabled, the new tab page changes automatically from the default 2 Rows 8 Tiles, into 1 Row 4 Tiles. How do I change it back with this add-on enabled if anybody here haves it, or is using it onto their own firefox? I know that it is coming from Classic Theme Restorer because disabling it will restore the New Tab page back to normal. I have tried that before, and that did happen.

For those who don't know, the add-on that I am talking about is none other then: https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/

Is there something that I have to look at in Classic Theme Restorer's options?

If anybody can help me with this, and that you know about this, I would appreciate that.

Thank you.

- TCT101

All Replies (3)

more options

I admit I'm not personally familiar with what CTR does to the page, but did installing CTR reduce the height of the content area at all? The number of tiles on the page is sensitive to the vertical space available.

What do you think about using zoom to fit more in the page, albeit with smaller captions? Hold down the Ctrl key and tap - once or twice to see whether that suits you.

Firefox may fail to remember your preferred zoom level on the new tab page when preloading is enabled. If you find that Firefox cannot remember the zoom level, here's how you disable preloading:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.preload preference to switch its value from true to false

After the change, if you have any "new tab" pages open, close them, and open a new one, change the zoom setting, and now it should be remembered.


If you do not want to reduce the zoom level, the following extension has a rich set of options for styling the page: https://addons.mozilla.org/firefox/addon/new-tab-tools/

more options

Hello,

Thank you for your suggestion. I'll try to keep that in mind as a reference.

Apparently, this was fixed after I upgraded from Firefox 41.0.2 to Firefox 42.0 that was released. However, if this happens again, I'll reply back and let you know, and other users that know and would like to help.

Thank you.

- TCT101

Modified by TCT101

more options

The Classic Theme Restorer extension has a setting for the about:newtab page:

  • General UI (1): New tab page (about:newtab): alternative appearance