X
Tap here to go to the mobile version of the site.

Support Forum

"show all bookmarks" opens full screen and cannot be closed again

Posted

Since yesterday (October 3) Firefox’s “show all bookmarks” (Shift+⌘+B) only opens in full-screen. I can edit the bookmarks but cannot exit the full-screen mode, close that window, access apple’s menu bar or any of the firefox controls. I have to quit Firefox (and can only do so with ⌘+Q) to get out of there. How do I solve this problem? Thanks!

Since yesterday (October 3) Firefox’s “show all bookmarks” (Shift+⌘+B) only opens in full-screen. I can edit the bookmarks but cannot exit the full-screen mode, close that window, access apple’s menu bar or any of the firefox controls. I have to quit Firefox (and can only do so with ⌘+Q) to get out of there. How do I solve this problem? Thanks!

Chosen solution

You should be able to close the about:preferences window via Command+W.

In a lot of cases deleting xulstore.json has been reported to recover. Make sure that you have closed the Firefox application before deleting the file. Closing open windows isn't sufficient, so make sure to use "File > Quit" to close the menu bar.

You can use this button to go to the current Firefox profile folder:

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 15.008.20082
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Coupons Inc., Coupon Printing Plugin
  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Octoshape Streaming Services web integration browser plug-in
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • Watch and download full length videos from your browser
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

abhishek713213 0 solutions 1 answers

hello,

you can try command+ctrl+J

hello, you can try command+ctrl+J

Question owner

Nope. Still stuck in full screen.

Nope. Still stuck in full screen.
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Try to rename (or delete) the xulstore.json file in the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

Try to rename (or delete) the xulstore.json file in the Firefox profile folder. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

Nope. Still stuck :(

Nope. Still stuck :(
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Can you confirm that you see the Bookmarks Manager (Library)?

Make sure that you do not run Firefox in Full Screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

Does the bookmarks sidebar work normally?

  • View > Sidebars > Bookmarks

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Can you confirm that you see the Bookmarks Manager (Library)? Make sure that you do not run Firefox in Full Screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F). *https://support.mozilla.org/kb/how-to-use-full-screen Does the bookmarks sidebar work normally? * View > Sidebars > Bookmarks ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Problem still there. All extensions disabled. No default theme to disable. Bookmarks sidebar works normally. I do not run Firefox in full screen mode. I’m not sure what you mean with if I can see the Bookmarks Manager (Library). I only have “show all bookmarks” and once I hit that, it opens and all my bookmarks appear and I can edit them. I do not have a specific button/folder called “Library” or “Bookmarks Manager” Once all bookmarks window is open, I don’t even see the red, green and yellow buttons on the upper left corner to close, minimize etc the window. No menu bar - neither Firefox nor apple. I can zoom to mission control and put other open apps in the front and work with them but the “show all bookmarks” window stays open in the back.

Problem still there. All extensions disabled. No default theme to disable. Bookmarks sidebar works normally. I do not run Firefox in full screen mode. I’m not sure what you mean with if I can see the Bookmarks Manager (Library). I only have “show all bookmarks” and once I hit that, it opens and all my bookmarks appear and I can edit them. I do not have a specific button/folder called “Library” or “Bookmarks Manager” Once all bookmarks window is open, I don’t even see the red, green and yellow buttons on the upper left corner to close, minimize etc the window. No menu bar - neither Firefox nor apple. I can zoom to mission control and put other open apps in the front and work with them but the “show all bookmarks” window stays open in the back.

Modified by pdhb

Question owner

Knock, knock. Did you forget about me or is this problem not severe enough?

Knock, knock. Did you forget about me or is this problem not severe enough?

Modified by pdhb

anbound 0 solutions 2 answers

I'm having this issue too - glad it's not just me - thought I was going mad or just very stupid.

Would love to see a resolution to this...

I'm having this issue too - glad it's not just me - thought I was going mad or just very stupid. Would love to see a resolution to this...

Question owner

Thanks for leaving a reply! I found another user (skx0221) posting about this shortly after I did (link: https://support.mozilla.org/en-US/questions/1089478?fpa=1). Maybe removing the xulstore.json file works for you. It did not for me bc show all history/bookmarks window is still stuck in full screen after I installed El Capitan on a new hard drive without adding any other files or software other than mozilla. If you find a solution, could you leave a reply here? I'll do the same. Thanks!

Thanks for leaving a reply! I found another user (skx0221) posting about this shortly after I did (link: https://support.mozilla.org/en-US/questions/1089478?fpa=1). Maybe removing the xulstore.json file works for you. It did not for me bc show all history/bookmarks window is still stuck in full screen after I installed El Capitan on a new hard drive without adding any other files or software other than mozilla. If you find a solution, could you leave a reply here? I'll do the same. Thanks!

Modified by pdhb

cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Chosen Solution

You should be able to close the about:preferences window via Command+W.

In a lot of cases deleting xulstore.json has been reported to recover. Make sure that you have closed the Firefox application before deleting the file. Closing open windows isn't sufficient, so make sure to use "File > Quit" to close the menu bar.

You can use this button to go to the current Firefox profile folder:

You should be able to close the about:preferences window via Command+W. In a lot of cases deleting xulstore.json has been reported to recover. Make sure that you have closed the Firefox application before deleting the file. Closing open windows isn't sufficient, so make sure to use "File > Quit" to close the menu bar. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

As a temporary workaround, you could paste this internal address for the Library dialog into the address bar and press Return to load it in the current tab:

chrome://browser/content/places/places.xul

You can bookmark that, then launch it in a new tab or window as follows:

  • New tab: Cmd+Shift+click the bookmark
  • New background tab: Cmd+click the bookmark
  • New window: Shift+click the bookmark

Hopefully the new tab/window will be "normal sized"

As a temporary workaround, you could paste this internal address for the Library dialog into the address bar and press Return to load it in the current tab: chrome://browser/content/places/places.xul You can bookmark that, then launch it in a new tab or window as follows: * New tab: Cmd+Shift+click the bookmark * New background tab: Cmd+click the bookmark * New window: Shift+click the bookmark Hopefully the new tab/window will be "normal sized"

Question owner

cor-el, can't believe it, after trying it over and over again, deleting xulstore.json finally worked! Thank you!

cor-el, can't believe it, after trying it over and over again, deleting xulstore.json finally worked! Thank you!
anbound 0 solutions 2 answers

Thank You cor-el - worked beautifully first time!!

Thank You cor-el - worked beautifully first time!!
SDSholkoff 0 solutions 1 answers

Helpful Reply

Thank you. Found xulstore and deleted it and problem solved. Item recurred, but no longer a problem.

Thank you. Found xulstore and deleted it and problem solved. Item recurred, but no longer a problem.