X
Tap here to go to the mobile version of the site.

Support Forum

Running XP (SP3) - Not able to read some fonts on some websites

Posted

Fonts used on some pages become symbols, random letters and punctuation marks. (Ex: Yahoo.com)

When cut and past into another program they are readable.

Have tried refreshing Have removed and reinstalled Firefox

No problem with IE or Chrome

Fonts used on some pages become symbols, random letters and punctuation marks. (Ex: Yahoo.com) When cut and past into another program they are readable. Have tried refreshing Have removed and reinstalled Firefox No problem with IE or Chrome

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • Citrix Online App Detector Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • 4.0.60831.0
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Application

  • Firefox 41.0.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0
  • Support URL: https://support.mozilla.org/1/firefox/41.0.1/WINNT/en-US/

Extensions

  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: 256MB ATI RADEON X600
  • adapterDescription2:
  • adapterDeviceID: 0x5b62
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 0b021002
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'9.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 5-31-2005
  • driverDate2:
  • driverVersion: 6.14.10.6542
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158573 answers

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. If you have a font installed that covers this Unicode range then you may see a real (CJK) character and not the little box with the CSS code.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value to true).

Firefox 41 will allow icon fonts that use PUA code points to work with the font setting in "Options/Preferences > Content > Colors" disabled. When unsupported code points are used then you see the little boxes with the hex code.

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. If you have a font installed that covers this Unicode range then you may see a real (CJK) character and not the little box with the CSS code. Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" You can check the <b>gfx.downloadable_fonts.enabled</b> pref on the <b>about:config</b> page and make sure that it is set to true (if necessary double-click the line to toggle its value to true). Firefox 41 will allow icon fonts that use PUA code points to work with the font setting in "Options/Preferences > Content > Colors" disabled. When unsupported code points are used then you see the little boxes with the hex code. *http://www.ghacks.net/2015/07/21/firefox-41-mozilla-modifies-how-icon-fonts-are-handled-by-the-browser/