X
Tap here to go to the mobile version of the site.

Support Forum

Closing tabs creates a gap between tabs.

Posted

Hello. I'm try to customize the look and feel of FF by editing the userChrome.css.

I almost got it, but there is one problem which i can't resolve.

After closing a tab with a number greater that 40 ,there are always unfilled place left between tabs. Pls. see the image.

This is what i added to userChrome.css. Please help me to resolve the issue.

  DISABLE FIREFOX DEFAULT BACKGROUND  

#TabsToolbar:not(:-moz-lwtheme)::after {
	display: none;
}


/*===============================================
  INACTIVE TABS  
  ===============================================*/
#TabsToolbar .tabbrowser-tab {
	text-align: left!important;
	-moz-border-top-colors: none !important;
	-moz-border-left-colors: none !important;
	-moz-border-right-colors: none !important;
	-moz-border-bottom-colors: none !important;
	background: #BAB9A8 !important;
	border-top: 1px solid #4F4E47!important;
	border-bottom: 1px solid #4F4E47!important;
	border-left: 1px solid #4F4E47!important;
	border-right: 1px solid #4F4E47!important;
	border-radius: 3px 3px 0px 0px !important;
	color: #000000 !important;
	/*margin: 0px 3px 0px 2px !important;*/
	font-family: "Ubuntu",Helvetica,Arial,sans-serif;
	font-size: 11px;
        max-width: 43px !important;
        min-width: 40px !important;
}

/*===============================================
  ACTIVE TABS  
  ===============================================*/
#TabsToolbar .tabbrowser-tab[selected] {
	font-weight: normal !important;
	border-top: 1px solid #000!important;
	border-left: 1px solid #000!important;
	border-right: 1px solid #000!important;
	border-radius: 3px 3px 0px 0px !important;
	background: #F0E68C !important;
	color: #000000 !important;
}

/*===============================================
  DISABLE AUSTRALIS TAB  
  ===============================================*/
#TabsToolbar .tab-background {
	margin: 0;
	background: transparent;
}

#TabsToolbar .tab-background-start,  #TabsToolbar .tab-background-end {
	display: none !important;
}

#TabsToolbar .tab-background-middle {
	background: transparent !important;
}

#TabsToolbar .tabbrowser-tab:after,  #TabsToolbar .tabbrowser-tab:before {
	display: none !important;
}
Hello. I'm try to customize the look and feel of FF by editing the userChrome.css. I almost got it, but there is one problem which i can't resolve. After closing a tab with a number greater that 40 ,there are always unfilled place left between tabs. Pls. see the image. This is what i added to userChrome.css. Please help me to resolve the issue. <pre><nowiki> DISABLE FIREFOX DEFAULT BACKGROUND #TabsToolbar:not(:-moz-lwtheme)::after { display: none; } /*=============================================== INACTIVE TABS ===============================================*/ #TabsToolbar .tabbrowser-tab { text-align: left!important; -moz-border-top-colors: none !important; -moz-border-left-colors: none !important; -moz-border-right-colors: none !important; -moz-border-bottom-colors: none !important; background: #BAB9A8 !important; border-top: 1px solid #4F4E47!important; border-bottom: 1px solid #4F4E47!important; border-left: 1px solid #4F4E47!important; border-right: 1px solid #4F4E47!important; border-radius: 3px 3px 0px 0px !important; color: #000000 !important; /*margin: 0px 3px 0px 2px !important;*/ font-family: "Ubuntu",Helvetica,Arial,sans-serif; font-size: 11px; max-width: 43px !important; min-width: 40px !important; } /*=============================================== ACTIVE TABS ===============================================*/ #TabsToolbar .tabbrowser-tab[selected] { font-weight: normal !important; border-top: 1px solid #000!important; border-left: 1px solid #000!important; border-right: 1px solid #000!important; border-radius: 3px 3px 0px 0px !important; background: #F0E68C !important; color: #000000 !important; } /*=============================================== DISABLE AUSTRALIS TAB ===============================================*/ #TabsToolbar .tab-background { margin: 0; background: transparent; } #TabsToolbar .tab-background-start, #TabsToolbar .tab-background-end { display: none !important; } #TabsToolbar .tab-background-middle { background: transparent !important; } #TabsToolbar .tabbrowser-tab:after, #TabsToolbar .tabbrowser-tab:before { display: none !important; } </nowiki></pre>
Attached screenshots

Modified by snoRNA

Chosen solution

Maybe try the Classic Theme Restorer to see if that works and check the CSS code that this extension uses. The styling of the Tab bar is quite complicated and may also not be stable across releases.

Read this answer in context 3

Additional System Details

Application

  • Firefox 41.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.122 Safari/537.36 OPR/25.0.1614.71
  • Support URL: https://support.mozilla.org/1/firefox/41.0.1/Linux/en-US/

Extensions

  • BetterPrivacy 1.68.1-signed ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • Cookie Whitelist, With Buttons 3.0.1-signed (cwwb@dietrich.cx)
  • Disconnect 3.15.3.1-signed (2.0@disconnect.me)
  • Download Status Bar 12.3.0.1-signed ({6c28e999-e900-4635-a39d-b1ec90ba0c0f})
  • Firebug 2.0.12 (firebug@software.joehewitt.com)
  • FireGestures 1.10.2 (firegestures@xuldev.org)
  • FlashGot 1.5.6.12.1-signed ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Google Privacy 0.2.4.1-signed ({ea61041c-1e22-4400-99a0-aea461e69d04})
  • HTTPS-Everywhere 5.1.1 (https-everywhere-eff@eff.org)
  • mpv-youtube-dl-binding 0.1.alpha2.1-signed (jid1-6NrUw49Z9jFVxg@jetpack)
  • NoScript 2.6.9.37 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Random Agent Spoofer 0.9.5.2 (jid1-AVgCeF1zoVzMjA@jetpack)
  • Roomy Bookmarks Toolbar 1.4.10 (ALone-live@ya.ru)
  • Russian Hunspell spellchecking dictionary 1.0.20131101 (hunspell-ru@dictionaries.addons.mozilla.org)
  • Self-Destructing Cookies 0.4.7.1-signed (jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack)
  • Stylish 2.0.2.1-signed ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • The Addon Bar (restored) 3.2.1-signed (the-addon-bar@GeekInTraining-GiT)
  • uBlock Origin 1.1.1 (uBlock0@raymondhill.net)
  • Vimperator 3.10.1 (vimperator@mozdev.org)
  • VKontakte.ru Downloader 0.3.8.1.1-signed (vk@sergeykolosov.mp)
  • Pentadactyl hg7226 (pentadactyl@dactyl.googlecode.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: X.Org -- Gallium 0.4 on AMD CAPE VERDE (DRM 2.43.0, LLVM 3.7.0)
  • adapterDeviceID: Gallium 0.4 on AMD CAPE VERDE (DRM 2.43.0, LLVM 3.7.0)
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • driverDate:
  • driverVersion: 3.0 Mesa 11.0.2
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: X.Org -- Gallium 0.4 on AMD CAPE VERDE (DRM 2.43.0, LLVM 3.7.0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4257 solutions 59608 answers

Helpful Reply

I've called the big guys to help you. Good luck.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

I've called the big guys to help you. Good luck. Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?

Question owner

Thanks! There is no problem in safe mode, because the userChrome.css doesn't get populated in safe mode. However if i delete all the extensions(also if i do "refresh firefox") the problem doesn't go away. As soon as i add the userChtome.css the problem is back. Therefore my userChrome.css is not correct, but i don't know there and why.

Thanks! There is no problem in safe mode, because the userChrome.css doesn't get populated in safe mode. However if i delete all the extensions(also if i do "refresh firefox") the problem doesn't go away. As soon as i add the userChtome.css the problem is back. Therefore my userChrome.css is not correct, but i don't know there and why.
cor-el
  • Top 10 Contributor
  • Moderator
17534 solutions 158534 answers

Chosen Solution

Maybe try the Classic Theme Restorer to see if that works and check the CSS code that this extension uses. The styling of the Tab bar is quite complicated and may also not be stable across releases.

Maybe try the Classic Theme Restorer to see if that works and check the CSS code that this extension uses. The styling of the Tab bar is quite complicated and may also not be stable across releases.