X
Tap here to go to the mobile version of the site.

Support Forum

Adobe Flash Player freezes Firefox 41.0.1

Posted

Hello, I have a problem where Flash freezes on Firefox 41.0.1. It's utterly annoying. I already have hardware acceleration disabled. I need help fast.

Hello, I have a problem where Flash freezes on Firefox 41.0.1. It's utterly annoying. I already have hardware acceleration disabled. I need help fast.

Additional System Details

Installed Plug-ins

  • npsitesafety
  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • GEPlugin
  • Google Update
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NPWLPG
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.7.157
  • Unity Player 4.3.5f1
  • WildTangent Games App V2 Presence Detector
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17568 solutions 158896 answers

You can check for problems with current Shockwave Flash plugin versions and try this:

See also:

You can check for problems with current Shockwave Flash plugin versions and try this: *make sure you have the latest Flash version:<br>http://www.adobe.com/special/products/flashplayer/fp_distribution3.html *check for updates for your graphics drive drivers<br>https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration *disable protected mode in the Flash plugin (Windows Vista and later)<br>https://support.mozilla.org/kb/adobe-flash-protected-mode-firefox *disable hardware acceleration in the Flash plugin<br>https://helpx.adobe.com/flash-player/kb/video-playback-issues.html *disable hardware acceleration in Firefox<br />https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration See also: *http://kb.mozillazine.org/Flash#Troubleshooting

Modified by cor-el

Question owner

Hello cor-el, I have done that all, but Firefox still freezes on me. Didn't seem to have this problem before.

Hello cor-el, I have done that all, but Firefox still freezes on me. Didn't seem to have this problem before.
philipp
  • Top 25 Contributor
  • Moderator
5320 solutions 23501 answers

hi, do you have a particular page where this happens or steps to reproduce this problem?

hi, do you have a particular page where this happens or steps to reproduce this problem?

Question owner

philipp, I also encountered this problem here: http://totaljerkface.com/happy_wheels.tjf

philipp, I also encountered this problem here: http://totaljerkface.com/happy_wheels.tjf

Question owner

cor-el said

You can check for problems with current Shockwave Flash plugin versions and try this: See also:

cor-el, I have tried what you and philipp told me, but with no luck. Try sending this to Firefox staff and creators for a fix on Firefox 41.0.2. It says this problem was fixed on Firefox 41.0.1, but it really wasn't. I even tried Safe Mode and refreshing Firefox.

''cor-el [[#answer-788391|said]]'' <blockquote> You can check for problems with current Shockwave Flash plugin versions and try this: *make sure you have the latest Flash version:<br>http://www.adobe.com/special/products/flashplayer/fp_distribution3.html *check for updates for your graphics drive drivers<br>https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration *disable protected mode in the Flash plugin (Windows Vista and later)<br>https://support.mozilla.org/kb/adobe-flash-protected-mode-firefox *disable hardware acceleration in the Flash plugin<br>https://helpx.adobe.com/flash-player/kb/video-playback-issues.html *disable hardware acceleration in Firefox<br />https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration See also: *http://kb.mozillazine.org/Flash#Troubleshooting </blockquote> cor-el, I have tried what you and philipp told me, but with no luck. Try sending this to Firefox staff and creators for a fix on Firefox 41.0.2. It says this problem was fixed on Firefox 41.0.1, but it really wasn't. I even tried Safe Mode and refreshing Firefox.
jscher2000
  • Top 10 Contributor
8785 solutions 71853 answers

This will not help on sites where Flash is essential, but to avoid unnecessary pain on other sites, you can set Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

This will not help on sites where Flash is essential, but to avoid unnecessary pain on other sites, you can set Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.) The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.
jscher2000
  • Top 10 Contributor
8785 solutions 71853 answers

Does it make any difference to access the problem sites in Firefox's Safe Mode? I think you may be familiar with this from past threads, but just in case:

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

Does it make any difference to access the problem sites in Firefox's Safe Mode? I think you may be familiar with this from past threads, but just in case: ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any difference?

Question owner

jscher2000 said

Does it make any difference to access the problem sites in Firefox's Safe Mode? I think you may be familiar with this from past threads, but just in case: If Firefox is not running: Hold down the Shift key when starting Firefox. If Firefox is running: You can restart Firefox in Safe Mode using either:
  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled
and OK the restart. Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh). Any difference?

Not really :(

''jscher2000 [[#answer-789259|said]]'' <blockquote> Does it make any difference to access the problem sites in Firefox's Safe Mode? I think you may be familiar with this from past threads, but just in case: ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any difference? </blockquote> Not really :(

Question owner

Hello everybody, let's keep this thread alive until this is fixed for Firefox 41.0.2.

Hello everybody, let's keep this thread alive until this is fixed for Firefox 41.0.2.

Question owner

jscher, I now copied some crash info: Signature hang | WaitForMultipleObjectsEx | MsgWaitForMultipleObjectsEx | MsgWaitForMultipleObjects | mozilla::ipc::MessageChannel::WaitForInterruptNotify() | mozilla::ipc::MessageChannel::Call(IPC::Message*, IPC::Message*) More Reports Search UUID ae3e443f-5205-460a-91a2-6acf42151006 Date Processed 2015-10-06 23:24:18.988492 Process Type plugin Shockwave Flash Version: 19.0.0.185 Filename: NPSWF32_19_0_0_185.dll Uptime 96 Install Age 510000 since version was first installed. Install Time 2015-10-01 01:43:41 Product Firefox Version 41.0.1 Build ID 20150929144111 Release Channel release OS Windows NT OS Version 10.0.10240 Build Architecture x86 Build Architecture Info GenuineIntel family 6 model 42 stepping 7 | 4 Crash Reason EXCEPTION_BREAKPOINT Crash Address 0x7712919c User Comments Shockwave Flash keeps crashing on me on Firefox 41.0.1. Can you fix this for 41.0.2? App Notes

AdapterVendorID: 0x8086, AdapterDeviceID: 0x0102, AdapterSubsysID: 05891025, AdapterDriverVersion: 9.17.10.4229

Processor Notes ip-172-31-22-14.1260:2015; MozillaProcessorAlgorithm2015; non-integer value of "SecondsSinceLastCrash" EMCheckCompatibility

True

Winsock LSP

MSAFD Tcpip [TCP/IP] : 2 : 1 : %SystemRoot%\system32\mswsock.dll

MSAFD Tcpip [UDP/IP] : 2 : 2 :  
MSAFD Tcpip [RAW/IP] : 2 : 3 : %SystemRoot%\system32\mswsock.dll 
MSAFD Tcpip [TCP/IPv6] : 2 : 1 :  
MSAFD Tcpip [UDP/IPv6] : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
MSAFD Tcpip [RAW/IPv6] : 2 : 3 :  
RSVP TCPv6 Service Provider : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
RSVP TCP Service Provider : 2 : 1 :  
RSVP UDPv6 Service Provider : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
RSVP UDP Service Provider : 2 : 2 :  
Hyper-V RAW : 2 : 1 : %SystemRoot%\system32\mswsock.dll

Adapter Vendor ID

0x8086

Adapter Device ID

0x0102

jscher, I now copied some crash info: Signature hang | WaitForMultipleObjectsEx | MsgWaitForMultipleObjectsEx | MsgWaitForMultipleObjects | mozilla::ipc::MessageChannel::WaitForInterruptNotify() | mozilla::ipc::MessageChannel::Call(IPC::Message*, IPC::Message*) More Reports Search UUID ae3e443f-5205-460a-91a2-6acf42151006 Date Processed 2015-10-06 23:24:18.988492 Process Type plugin Shockwave Flash Version: 19.0.0.185 Filename: NPSWF32_19_0_0_185.dll Uptime 96 Install Age 510000 since version was first installed. Install Time 2015-10-01 01:43:41 Product Firefox Version 41.0.1 Build ID 20150929144111 Release Channel release OS Windows NT OS Version 10.0.10240 Build Architecture x86 Build Architecture Info GenuineIntel family 6 model 42 stepping 7 | 4 Crash Reason EXCEPTION_BREAKPOINT Crash Address 0x7712919c User Comments Shockwave Flash keeps crashing on me on Firefox 41.0.1. Can you fix this for 41.0.2? App Notes AdapterVendorID: 0x8086, AdapterDeviceID: 0x0102, AdapterSubsysID: 05891025, AdapterDriverVersion: 9.17.10.4229 Processor Notes ip-172-31-22-14.1260:2015; MozillaProcessorAlgorithm2015; non-integer value of "SecondsSinceLastCrash" EMCheckCompatibility True Winsock LSP MSAFD Tcpip [TCP/IP] : 2 : 1 : %SystemRoot%\system32\mswsock.dll MSAFD Tcpip [UDP/IP] : 2 : 2 : MSAFD Tcpip [RAW/IP] : 2 : 3 : %SystemRoot%\system32\mswsock.dll MSAFD Tcpip [TCP/IPv6] : 2 : 1 : MSAFD Tcpip [UDP/IPv6] : 2 : 2 : %SystemRoot%\system32\mswsock.dll MSAFD Tcpip [RAW/IPv6] : 2 : 3 : RSVP TCPv6 Service Provider : 2 : 1 : %SystemRoot%\system32\mswsock.dll RSVP TCP Service Provider : 2 : 1 : RSVP UDPv6 Service Provider : 2 : 2 : %SystemRoot%\system32\mswsock.dll RSVP UDP Service Provider : 2 : 2 : Hyper-V RAW : 2 : 1 : %SystemRoot%\system32\mswsock.dll Adapter Vendor ID 0x8086 Adapter Device ID 0x0102
jscher2000
  • Top 10 Contributor
8785 solutions 71853 answers

Hi sabbath99, can you give a link to the crash report online? That page includes links to related "bugs", more detail about what Firefox might have been trying to do when Flash crashed/hung, and other helpful data.

Hi sabbath99, can you give a link to the crash report online? That page includes links to related "bugs", more detail about what Firefox might have been trying to do when Flash crashed/hung, and other helpful data.

Question owner

jscher, here: https://crash-stats.mozilla.com/report/index/ae3e443f-5205-460a-91a2-6acf42151006
jscher2000
  • Top 10 Contributor
8785 solutions 71853 answers

Hi sabbath99, when I click through the More Reports link near the top of the report, I see that this particular crash signature affects only Windows 10 users. That has to be some kind of clue.

The user comments mention both Flash and Silverlight, which is interesting. (They also are violent and profane, which is disturbing.)

Unfortunately, the crash report doesn't link to any existing bugs, so I don't have any good leads on what to try next.


If this came on with Flash 19, perhaps consider... the extended support release of Flash 18.

Adobe still offers Flash 18.0.0.241 as its extended support release further down on this page: https://www.adobe.com/products/flashplayer/distribution3.html

Not sure you can install that without first uninstalling Flash 19. This article has a link to the uninstaller: https://helpx.adobe.com/flash-player/.../uninstall-flash-player-windows.html.

Hi sabbath99, when I click through the More Reports link near the top of the report, I see that this particular crash signature affects only Windows 10 users. That has to be some kind of clue. The user comments mention both Flash and Silverlight, which is interesting. (They also are violent and profane, which is disturbing.) Unfortunately, the crash report doesn't link to any existing bugs, so I don't have any good leads on what to try next. ---- If this came on with Flash 19, perhaps consider... the extended support release of Flash 18. Adobe still offers Flash 18.0.0.241 as its extended support release further down on this page: https://www.adobe.com/products/flashplayer/distribution3.html Not sure you can install that without first uninstalling Flash 19. This article has a link to the uninstaller: [https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html].
FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.


Signature hang

Process Type plugin Shockwave Flash Version: 19.0.0.185


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

A post was flagged as '''Solved Problem.''' Please remove that flag. If you don’t, others that can help may not read this post. ---------------- Signature hang Process Type plugin Shockwave Flash Version: 19.0.0.185 -------------------- check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Question owner

FredMcD said

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.

Signature hang

Process Type plugin Shockwave Flash Version: 19.0.0.185


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

Hello FredMcD, I just updated to Firefox 41.0.2 and the crashing is still a problem. This really needs escalating.

''FredMcD [[#answer-790940|said]]'' <blockquote> A post was flagged as '''Solved Problem.''' Please remove that flag. If you don’t, others that can help may not read this post. ---------------- Signature hang Process Type plugin Shockwave Flash Version: 19.0.0.185 -------------------- check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' </blockquote> Hello FredMcD, I just updated to Firefox 41.0.2 and the crashing is still a problem. This really needs escalating.
FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

Did you follow the instructions I posted?

Did you follow the instructions I posted?

Question owner

sabbath99 said

FredMcD said
A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.

Signature hang

Process Type plugin Shockwave Flash Version: 19.0.0.185


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

Hello FredMcD, I just updated to Firefox 41.0.2 and the crashing is still a problem. This really needs escalating.

I believe so. This is happening on Windows 10 and I upgraded my graphics driver (Intel) in July of this year.

''sabbath99 [[#answer-794357|said]]'' <blockquote> ''FredMcD [[#answer-790940|said]]'' <blockquote> A post was flagged as '''Solved Problem.''' Please remove that flag. If you don’t, others that can help may not read this post. ---------------- Signature hang Process Type plugin Shockwave Flash Version: 19.0.0.185 -------------------- check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' </blockquote> Hello FredMcD, I just updated to Firefox 41.0.2 and the crashing is still a problem. This really needs escalating. </blockquote> I believe so. This is happening on Windows 10 and I upgraded my graphics driver (Intel) in July of this year.
FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

New Update; Flash Player Version 19.0.0.226
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Plugin-based browsers” installers.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


edit: fixed Flash version as it was previous and removed mention that you need to download activex version.

New Update; Flash Player '''Version 19.0.0.226<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' must download the “Plugin-based browsers” installers. Note: Edge on Win10 does not use ActiveX version but its own Flash. See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration edit: fixed Flash version as it was previous and removed mention that you need to download activex version.

Modified by James

Question owner

FredMcD, I installed it, and it still crashes.

FredMcD, I installed it, and it still crashes.
Big_Cube 0 solutions 8 answers

Just use any other browser, firefox is garbage now.

The last thing the end user should have to do is spend hours troubleshooting your crappy bloated software. Just use IE or chrome.

Just use any other browser, firefox is garbage now. The last thing the end user should have to do is spend hours troubleshooting your crappy bloated software. Just use IE or chrome.