Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to change language to German

  • 4 replies
  • 7 have this problem
  • 103 views
  • Last reply by Moinilein

more options

Hi,

I'm on Linux Mint 17.2, and yesterday I updated to the latest Firefox 41.0. I have the language pack for German installed via apt, version 41.0+build3-0ubuntu0.14.04.1 I have set 'use OS language' to 'false' in about:config, just in case it wasn't detected correctly (using German as system language, though). I have set the locale to de-DE in about:config.

I have restarted Firefox.

My menues are still in English - only in the Bookmark tab, the 'recently added as bookmark' is in German, and the web developer extension uses German, too.

I assume Firefox can't use the language pack? Or what might be the reason?

Regards,

Moinilein

Chosen solution

Hi cor-el,

you're right, installing a language pack directly into my profile folder is not how it works on Linux ;)

All programs live, as 'packages', in a big repository, think 'app store' (only free - in both meanings), and you install the packages you need. You can also use external repositories, or create your own, but it's usually safer (and more compatible) to use the packages from your distro's repos.

In the case of Linux Mint (and many other distros), the language packs are even installed automatically with their corresponding programs, depending on your system language choice.

I had everything I needed, but there was obviously an error in the Firefox / de-locale package for Linux Mint, that prevented FF from using the language pack.

It has been fixed over night :) - I have just updated, and my menues are in German again. Time to set back my changes to about:config .

Thank you very much for trying to help me, though!

Kind regards,

Moinilein
Read this answer in context 👍 0

All Replies (4)

more options

Do you see any error messages in the Browser Console (Firefox menu button or Tools > Web Developer)?

Try to set general.useragent.locale to 'de' instead of 'de-DE'

You can also try to install the German (de) Firefox version or the en-US version and the 'de' language pack.

You can find the full version of the current Firefox release (41.0) in all languages and all operating systems here:

more options

Hi cor-el,

Thank you for your answer.

The browser console didn't show any program errors for me (I'm not sure if it does this at all, actually - isn't it just for the contents of what you're browsing? Or maybe the log thing does this - I had them all activated, anyway). There were lots of other errors, but they were all related to extensions and their js / css.

Setting the locale to de instead of de-DE didn't change anything (after a restart of FF).

I also started FF from the terminal, and beside a few messages about icons and extensions, and the usual Glib warnings, there was nothing about language/locale.

I would not like to install a second Firefox beside the one provided by my distro. The language pack is installed, as stated above.

Does anyone have any other ideas? Does anyone else have this problem? Is it maybe Linux Mint specific?

I speak English fairly well, so the problem is small for me - but if this is a bug somewhere, there may be other people who might profit from this investigation.

Kind regards,

Moinilein
more options

When you install a language pack then you need to install this pack in the current profile folder and instaled languages would show as a Language tab in about:addons (Firefox menu button/Tools > Add-ons).

I don't know how this would work in your case where you install additional language via the software repository. You probably need to check that in your software management.

more options

Chosen Solution

Hi cor-el,

you're right, installing a language pack directly into my profile folder is not how it works on Linux ;)

All programs live, as 'packages', in a big repository, think 'app store' (only free - in both meanings), and you install the packages you need. You can also use external repositories, or create your own, but it's usually safer (and more compatible) to use the packages from your distro's repos.

In the case of Linux Mint (and many other distros), the language packs are even installed automatically with their corresponding programs, depending on your system language choice.

I had everything I needed, but there was obviously an error in the Firefox / de-locale package for Linux Mint, that prevented FF from using the language pack.

It has been fixed over night :) - I have just updated, and my menues are in German again. Time to set back my changes to about:config .

Thank you very much for trying to help me, though!

Kind regards,

Moinilein