X
Tap here to go to the mobile version of the site.

Support Forum

Somehow my search engine was changed to yahoo from google, and now I can't get google search to stay as search engine, how do I fix this?

Posted

I don't know how it happened, but cannot get google search to stay as my search engine. I am using the most current version of Firefox there is. I have deleted all the other search engines but it still goes back to yahoo. Do not like yahoo, I want my google back, lol. Please advise me how to fix this problem, thank you.

I don't know how it happened, but cannot get google search to stay as my search engine. I am using the most current version of Firefox there is. I have deleted all the other search engines but it still goes back to yahoo. Do not like yahoo, I want my google back, lol. Please advise me how to fix this problem, thank you.

Chosen solution

Unwanted add-ons can take control of your Firefox settings (search engine, home page, new tab page) and make it impossible for you to control them. Here's my suggested procedure for tracking down and cleaning up bad add-ons, hijackers, and ad injectors. I know it seems long, but it's not that bad.

(1) Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it. Take out as much trash as possible here.

(2) Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that all extensions are optional, none come with Firefox, and you can learn more about them by checking their reviews on the Add-ons site.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

(3) You can search for remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.

Success?

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Coupons, Inc. Coupon Printer 5.0.2.8
  • Shockwave Flash 18.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Remove yahoo '''Anything.''' Now do the same in the computers Programs Folder. '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. ------------------ After the problem is fixed, Bookmark and use this; Download the '''[https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Mozilla Search Reset]''' {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Chosen Solution

Unwanted add-ons can take control of your Firefox settings (search engine, home page, new tab page) and make it impossible for you to control them. Here's my suggested procedure for tracking down and cleaning up bad add-ons, hijackers, and ad injectors. I know it seems long, but it's not that bad.

(1) Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it. Take out as much trash as possible here.

(2) Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that all extensions are optional, none come with Firefox, and you can learn more about them by checking their reviews on the Add-ons site.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

(3) You can search for remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.

Success?

Unwanted add-ons can take control of your Firefox settings (search engine, home page, new tab page) and make it impossible for you to control them. Here's my suggested procedure for tracking down and cleaning up bad add-ons, hijackers, and ad injectors. I know it seems long, but it's not that bad. (1) Open the Windows '''Control Panel''', Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. ''Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it.'' Take out as much trash as possible here. (2) Open Firefox's '''Add-ons page''' using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons * in the Windows "Run" dialog, type or paste <br><code>firefox.exe "about:addons"</code> In the left column, click '''Plugins'''. Set nonessential and unrecognized plugins to "Never Activate". In the left column, click '''Extensions'''. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. ''Bear in mind that all extensions are optional, none come with Firefox, and you can learn more about them by checking their reviews on the Add-ons site.'' Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Any improvement? (3) You can search for remaining issues with the '''scanning/cleaning tools''' listed in our support article: [[Troubleshoot Firefox issues caused by malware]]. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case. Success?

Question owner

Thanks to both of you, between the 2 solutions, I finally have my google search back!

Thanks to both of you, between the 2 solutions, I finally have my google search back!
michaelg81 0 solutions 1 answers

I'm using FF42 for the first time on Debian/XFCE and connecting to the Linux Mint repository for to access a package-version of Firefox. I don't have this problem on Mac OS X.

The solutions in Mozilla's help pages do not work. My Restore Search Engines button is greyed out until one of the defaults is deleted. Clicking the Restore Search Engines button only restores the same ones as before.

I stumbled on this: Linux Mint is probably blocking Google. When searching outside of the Mozilla forums for a solution, I landed on a Google help page and guess what: the little green plus sign showed up on the magnifying glass icon in the search bar. It's a hit-or-miss proposition because I tried to go back to see what page I was on I couldn't get the Add Search Engine green plus sign.

After a little more digging, here's what to do:

  1. Go to the Search engines in Linux Mint page.
  2. Scroll down until the Commercial Engines section.
  3. Click the Google icon (just to the left of middle). The Google in Linux Mint page opens.
  4. Find the magnifying glass icon in the Search bar in the top right corner of Firefox. It should sport a small green circle with a plus sign.
  5. Click on the plus sign icon and select "Add Google" from the dialog that opens.
  6. Click the hamburger menu icon to the right of the Search bar and select Preferences.
  7. Click on Search in the left sidebar. Google should be displayed in the list of one-click search engines.
  8. In the dropdown under Default Search Engines, select 'Google'.
I'm using FF42 for the first time on Debian/XFCE and connecting to the Linux Mint repository for to access a package-version of Firefox. I don't have this problem on Mac OS X. The solutions in Mozilla's help pages do not work. My '''Restore Search Engines''' button is greyed out until one of the defaults is deleted. Clicking the '''Restore Search Engines''' button only restores the same ones as before. I stumbled on this: Linux Mint is probably blocking Google. When searching outside of the Mozilla forums for a solution, I landed on a Google help page and guess what: the little green plus sign showed up on the magnifying glass icon in the search bar. It's a hit-or-miss proposition because I tried to go back to see what page I was on I couldn't get the '''Add Search Engine''' green plus sign. After a little more digging, here's what to do: # Go to the [http://www.linuxmint.com/searchengines.php Search engines in Linux Mint] page. # Scroll down until the '''Commercial Engines''' section. # Click the Google icon (just to the left of middle). ''The '''Google in Linux Mint''' page opens.'' # Find the magnifying glass icon in the '''Search''' bar in the top right corner of Firefox. It should sport a small green circle with a plus sign. # Click on the plus sign icon and select "Add Google" from the dialog that opens. # Click the '''hamburger menu''' icon to the right of the '''Search''' bar and select '''Preferences'''. # Click on '''Search''' in the left sidebar. ''Google should be displayed in the list of one-click search engines.'' # In the dropdown under '''Default Search Engines,''' select 'Google'.