X
Tap here to go to the mobile version of the site.

Support Forum

Firefox freezes when playing YouTube videos

Posted

This just started happening yesterday. Whenever I go to play a YouTube video, the whole program will freeze and become unresponsive twice for about a minute each time. This only happens on YouTube. No other website that plays videos has this problem. Also, this only happens on Firefox, my default browser. No other browser installed on my PC has this issue. This issue also occurs when the page tries to load the comments on a YouTube video.

I've tried reinstalling both the Flash player and Firefox. I've turned off the hardware acceleration on both Firefox and the Flash player. I've turned off the Protected Mode in the Shockwave Plugin. I've tried opening Firefox in Safe Mode. YouTube plays in HTML5 by default. Is anyone else having this problem? There must be a way to resolve this.

This just started happening yesterday. Whenever I go to play a YouTube video, the whole program will freeze and become unresponsive twice for about a minute each time. This only happens on YouTube. No other website that plays videos has this problem. Also, this only happens on Firefox, my default browser. No other browser installed on my PC has this issue. This issue also occurs when the page tries to load the comments on a YouTube video. I've tried reinstalling both the Flash player and Firefox. I've turned off the hardware acceleration on both Firefox and the Flash player. I've turned off the Protected Mode in the Shockwave Plugin. I've tried opening Firefox in Safe Mode. YouTube plays in HTML5 by default. Is anyone else having this problem? There must be a way to resolve this.

Chosen solution

Well I found out that I can resolve the problem by LOGGING OUT OF MY YOUTUBE ACCOUNT. I'm going to have words with the people at Google.

Read this answer in context 18

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36

More Information

Question owner

I found this same problem happening on my Surface Pro 3. This is clearly a Firefox issue. Is there any attempt to resolve this problem?

I found this same problem happening on my Surface Pro 3. This is clearly a Firefox issue. Is there any attempt to resolve this problem?
l3v147h4n 0 solutions 11 answers

Can you monitor your RAM and CPU usage while streaming Youtube videos and see if there is anything weird?

Can you monitor your RAM and CPU usage while streaming Youtube videos and see if there is anything weird?

Question owner

l3v147h4n said

Can you monitor your RAM and CPU usage while streaming Youtube videos and see if there is anything weird?

I did. Nothing out of the ordinary that I can see. Is there some prohibitive process I should know about?

''l3v147h4n [[#answer-781785|said]]'' <blockquote> Can you monitor your RAM and CPU usage while streaming Youtube videos and see if there is anything weird? </blockquote> I did. Nothing out of the ordinary that I can see. Is there some prohibitive process I should know about?

Question owner

I think this started happening after I tried the Adobe Connect plugin on Firefox. Is there a way to uninstall or fix that plugin?

I think this started happening after I tried the Adobe Connect plugin on Firefox. Is there a way to uninstall or fix that plugin?
FredMcD
  • Top 10 Contributor
4113 solutions 57432 answers

check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Plugins.

check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' ------------------ Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac:<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.'''
cor-el
  • Top 10 Contributor
  • Moderator
17164 solutions 155161 answers

This extension allows to switch between the Flash player and the HTML5 media player on the YouTube website. YouTube Flash Video Player:

This extension allows to switch between the Flash player and the HTML5 media player on the YouTube website. YouTube Flash Video Player: *https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

Chosen Solution

Well I found out that I can resolve the problem by LOGGING OUT OF MY YOUTUBE ACCOUNT. I'm going to have words with the people at Google.

Well I found out that I can resolve the problem by LOGGING OUT OF MY YOUTUBE ACCOUNT. I'm going to have words with the people at Google.
FredMcD
  • Top 10 Contributor
4113 solutions 57432 answers

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' so others will know.
effgo 2 solutions 31 answers

SycrosD4 said

Well I found out that I can resolve the problem by LOGGING OUT OF MY YOUTUBE ACCOUNT. I'm going to have words with the people at Google.

Just because this workaround worked it doesn't mean the fault is not on the part of Firefox and you should still file a bug report. Could you submit a bug report, please?

''SycrosD4 [[#answer-782130|said]]'' <blockquote> Well I found out that I can resolve the problem by LOGGING OUT OF MY YOUTUBE ACCOUNT. I'm going to have words with the people at Google. </blockquote> Just because this workaround worked it doesn't mean the fault is not on the part of Firefox and you should still file a bug report. Could you submit a bug report, please?

Question owner

effgo said

SycrosD4 said
Well I found out that I can resolve the problem by LOGGING OUT OF MY YOUTUBE ACCOUNT. I'm going to have words with the people at Google.

Just because this workaround worked it doesn't mean the fault is not on the part of Firefox and you should still file a bug report. Could you submit a bug report, please?

Sure! Where do I do that?

''effgo [[#answer-783723|said]]'' <blockquote> ''SycrosD4 [[#answer-782130|said]]'' <blockquote> Well I found out that I can resolve the problem by LOGGING OUT OF MY YOUTUBE ACCOUNT. I'm going to have words with the people at Google. </blockquote> Just because this workaround worked it doesn't mean the fault is not on the part of Firefox and you should still file a bug report. Could you submit a bug report, please? </blockquote> Sure! Where do I do that?
effgo 2 solutions 31 answers

SycrosD4 said

Sure! Where do I do that?

https://support.mozilla.org/en-US/products/firefox/fix-problems/websites https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines https://bugzilla.mozilla.org/

And remember. Each time you file a bug report you are contributing. Not to mention you're doing a favor to all of those who suffer from the same problem.

''SycrosD4 [[#answer-783726|said]]'' <blockquote> Sure! Where do I do that? </blockquote> https://support.mozilla.org/en-US/products/firefox/fix-problems/websites https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines https://bugzilla.mozilla.org/ And remember. Each time you file a bug report you are contributing. Not to mention you're doing a favor to all of those who suffer from the same problem.
FredMcD
  • Top 10 Contributor
4113 solutions 57432 answers

If you want, I can file it for you. Other users have this problem also.

You should also contact Yahoo support.

If you want, I can file it for you. Other users have this problem also. You should also contact Yahoo support.
effgo 2 solutions 31 answers

Could anyone post a link to the bug report if it has been filed?

Could anyone post a link to the bug report if it has been filed?
lamiejang 1 solutions 6 answers

Helpful Reply

I had this exactly problem, for whatever reason the cause is the list populated in the sidebar of Youtube. It really doesn't appear that heavy duty - it's just a UL list with some thumbnails - but it causes me several delays of around 5 seconds every time a page is loaded. (I am subbed to around 250 channels). I tracked the lag using the Performance tab under F12 and could see 3 pauses block-waiting on Graphics.

The workaround I'm using is to install the addon "Stylish" to allow custom CSS, then use a rule to hide the long Subscriptions list from the sidebar to avoid the layout engine bothering rendering it.

This is my rule to use in Stylish:

@-moz-document domain("youtube.com") {

#guide-channels{
 display:none !important;

}

}

I now have no noticeable delay on any YT page.

I had this exactly problem, for whatever reason the cause is the list populated in the sidebar of Youtube. It really doesn't appear that heavy duty - it's just a UL list with some thumbnails - but it causes me several delays of around 5 seconds every time a page is loaded. (I am subbed to around 250 channels). I tracked the lag using the Performance tab under F12 and could see 3 pauses block-waiting on Graphics. The workaround I'm using is to install the addon "Stylish" to allow custom CSS, then use a rule to hide the long Subscriptions list from the sidebar to avoid the layout engine bothering rendering it. This is my rule to use in Stylish: @-moz-document domain("youtube.com") { #guide-channels{ display:none !important; } } I now have no noticeable delay on any YT page.

Modified by lamiejang

effgo 2 solutions 31 answers

lamiejang said

...

You seem to know a thing or two about web so could you file a bug report? The other guy didn't return with anything.

''lamiejang [[#answer-800543|said]]'' <blockquote>... </blockquote> You seem to know a thing or two about web so could you file a bug report? The other guy didn't return with anything.
lamiejang 1 solutions 6 answers

Okay I'll look at doing that, unsure I'll be able to make an example that replicates it in isolation though.

Okay I'll look at doing that, unsure I'll be able to make an example that replicates it in isolation though.
cor-el
  • Top 10 Contributor
  • Moderator
17164 solutions 155161 answers

Filing a bug report is only useful if there are steps to reproduce that allow someone else to replicate the problem. You should be able to reproduce the problem with a clean new profile without modification to make sure that this isn't a problem with your current profile. If the problem is with your YouTube account then try to create another YouTube account to see if that still has the problem or is caused by a setting in your current YouTube account.

Filing a bug report is only useful if there are steps to reproduce that allow someone else to replicate the problem. You should be able to reproduce the problem with a clean new profile without modification to make sure that this isn't a problem with your current profile. If the problem is with your YouTube account then try to create another YouTube account to see if that still has the problem or is caused by a setting in your current YouTube account.
lamiejang 1 solutions 6 answers

Well It's 100% reproducible for me by visiting any Youtube page with the sidebar containing that Subscription list of a certain size. There are several reports on here of people having the same problem over the course of months.

I don't know of any problem with my Youtube account and haven't seen anyone come up with another workaround. So I've detailed what I know about it in a bugzilla report, we'll see if they find anything.

https://bugzilla.mozilla.org/show_bug.cgi?id=1220502

Well It's 100% reproducible for me by visiting any Youtube page with the sidebar containing that Subscription list of a certain size. There are several reports on here of people having the same problem over the course of months. I don't know of any problem with my Youtube account and haven't seen anyone come up with another workaround. So I've detailed what I know about it in a bugzilla report, we'll see if they find anything. https://bugzilla.mozilla.org/show_bug.cgi?id=1220502
FredMcD
  • Top 10 Contributor
4113 solutions 57432 answers

rimbotede 2015-11-02 14:27:13 PST Confirmed on a clean profile.

rimbotede 2015-11-02 14:27:13 PST Confirmed on a clean profile.
Peter.T 0 solutions 1 answers

I had this same problem too.

After trying the posted solutions, none of them solved the problem. I disabled all my plugins and the problem went away.

I enabled the plugins one by one and it turns out that the "Web Developer" plugin by chrispederick was causing the issue. With this plugin disabled YouTube worked perfectly... no more freezing or unresponsiveness.

I had this same problem too. After trying the posted solutions, none of them solved the problem. I disabled all my plugins and the problem went away. I enabled the plugins one by one and it turns out that the "Web Developer" plugin by chrispederick was causing the issue. With this plugin disabled YouTube worked perfectly... no more freezing or unresponsiveness.