Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I check my hotmail account with firefox?

  • 22 replies
  • 6 have this problem
  • Last reply by FredMcD

more options

I hope something can help me, because I don’t’ know what to do.

I check my hotmail account with Firefox, never had any trouble. But, after UI changed with hotmail account a month or two back, I’ve been having trouble signing it with Firefox, sometimes it worked and sometimes it didn’t. During this time, sometimes it would let me in and sometimes it won’t let me check at all.

I just keep getting this error: "Something went wrong and we can't sign you in right now. Please try again later."

  • BTW: Server status for hotmail is always 'green, no problems detected' when I get this error, so that makes me more confused on what's going on.*

That’s in Firefox, I then tried Firefox in safe mode (add-ons disabled) still same error.

I then tried restarting my PC, clearing catch/cookies, nothing seamed to matter and I have latest version of Firefox.

But, oddly (or not) when I try to sign in with IE, it logs me in just fine.

  • I also tried Chrome, I can log into my hotmail account just fine also.*

Anyone else having trouble with there hotmail account + Firefox?

I haven’t added/removed any programs for a while, just updated flash player/adobe/etc, you know, the usual stuff.

All screenshots I took are attached, details of when are in file name.

  • add images feature on creating page, is not working for me, had to do this way, sorry*

1_b4 FiddlerCap (secure error).jpg 1_b4_FiddlerCap (secure error 2) 2_With FiddlerCap and Firefox (normal) 2_With FiddlerCap and Firefox (safemod)

I'm using latest version of Firefox v40.03 on my Windows 7 Home Premium 64-bit OS, no other sites I have this trouble, can someone please help me?

I did send a question to the tech people at Microsoft, but only got 3 replies from them: 1 - ‘Thank you for contacting us', 2 - ‘Can you install/run this program FiddlerCap and send us the results?’ 3 - ‘We are going to send you over to this other department instead, you’ll hear from them soon…'

That was ~5 days ago. Nothing so far from them.

  • I don’t’ know what FiddlerCap was, I think it’s something to test the https or something, but got these odd errors when running it*

I really love Firefox have been a fan since v3 (I think, long ago), if anyone has any idea please tell me, if you need any info or something , ask and I will get it!

I don’t know if it’s related but I also got once or twice, an odd secure connection error, but I only got it a few times, so I don’t know if it’s related to this or not.

Error I got: “…Secure Connection Failed

An error occurred during a connection to Cannot communicate securely with peer: no common encryption algorithm(s). (Error code: ssl_error_no_cypher_overlap)

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem…”

I tried changing the line “security.tls.version.fallback-limit” to 1 (originally was 3) instead, but restart PC/clear cookies, restart Firefox, nothing, no error, but still no hotmail access with Firefox.

Chosen solution

@ jscher2000: I did as you said, but your comment about cookies got me thinking, so while I was there, I looked at the cookie exception list and saw this:

O.o When was that added and why/how?! [I then removed that cookie so it wasn't auto-blocked]

I re-checked for updates for all my pc protection programs, all are up to date and disabling/re-enabling them didn’t add that cookie to be blocked again.

I then re-booted my PC, and launched my installed Firefox and can now get into my e-mail account with no troubles!

So it’s fixed now, as to how/where/why that was added as a blocked cookie I don’t know where to look, but I’m happy now.

Thank you everyone that has banged there head in frustration and helped me! [They haven’t contacted me back yet, but I guess I‘ll e-mail M$ and tell them about the cookie being blocked that caused the non descriptive/cause error to show up, for me anyway]

[I‘ll wait till tomorrow and click on one of the posts to mark as ‘answered‘, but it‘s so hard to do since everyone that asked/helped all contributed to finding the problem, hard to pick everyone ;)]

  • Thank you again, everyone!

--- Just talking to myself...ugg, why was the fix so simple!?

Read this answer in context 👍 0

All Replies (20)

more options

Please ensure that the date, time and timezone are correctly set on your system. Sometimes Firefox will treat a website as a security threat if your system time does not match the server time on a website.

If your date and time are correctly configured, then there is most likely an issue with the security certificate for the Outlook website. If this is the case, we want to Delete or Distrust the "problematic" certificates from the Authorities. To do so:

  1. Go to Firefox Menu > Options
  2. Go to Advanced tab >Certificates > View Certificates
  3. Go to Authorities tab on the Certificate Manager dialog and look for the Certificate Name
  4. Select all the "problematic" certificates (it might have more than one for the same site) and click on Delete or Distrust and confirm. Here is important to make sure no "problematic" certificate is left there.

Once you followed these steps, close the options dialogs and just access the site with untrusted certificates again and Add Exception to trust the self-signed certificate.

Please let us know if this fixes the issue.

more options

I use the Windows Live Mail program.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

Sorry, took a bit to do this.

@ Wesley Branton:

Thanks, I re-checked my date/time, they are correct. As for the Certificates, I looked threw the list twice, I can't find any 'outlook' or at all in there, I’m looking in the right place, right?

I noticed the 'security devices' list the Certificates are either, 'Builtin Object Token' or 'Software security device'

But after all that, I still can’t check my e-mail/hotmail account with Firefox.

@ 'FredMcD:

I have Firefox to auto-clear ‘Everything’: all cookies (logins and not), off-line data, and full catch on each close of the browser.

I tried what you suggested: Manually clearing all that didn’t do anything, even disabling ‘Use Hardware Acceleration‘ In safe-mod or normal mode.

I still get, “Something went wrong and we can't sign you in right now. Please try again later.” whenI try and check my e-mail/hotmail account in Firefox.

more options

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

If you have Avast then try to disable HTTPS scanning in Avast Web Shield.

more options

@ cor-el: I checked in Windows 7 (OS in safe mode with networking) no luck trying to use Firefox to check my e-mail, even restarted Firefox so it was also in safe mode, still no luck ;(

I then accidentally booted into XP [Home 32-bit] and decided to check something anyway, that's why so long a wait, sorry.

This is what I came up with, didn’t matter if Firefox was in normal or safe mode

Firefox v25 [was able to check my hotmail account just fine] Firefox v32.0.3 [was able to check my hotmail account just fine] ... Firefox v40.0.3 [Couldn‘t even get it to launch in XP, waited quite a while]

I then re-checked those versions in Windows 7, same result

But something bothered me, no idea what, so I decided to download/install a portable version of Firefox (Latest v40.0.3) and oddly, I CAN check my e-mail with that one…but my installed Firefox (with all my settings and add-ons) won’t at all!

Now the question is, how do I narrow it down to what is different WITHOUT factory re-setting my installed Firefox?

more options

Screen shots #1 and #2 show "ssl_error_no_cypher_overlap". Have you customized any ssl or tls settings in about:config?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste tls and pause while the list is filtered. Anything customized that you can try resetting (right-click > Reset)?

(3) In the search box above the list, type or paste security.ssl and pause while the list is filtered. Anything customized that you can try resetting?

If preferences are not the issue, could you check that Firefox is not using a proxy:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default of "Use system proxy setting" should piggyback on Windows' LAN settings; you also could try "No proxy" to see whether that makes any difference.

Regarding screen shots #3 and #4, if you enabled decrypting of HTTPS traffic in FiddlerCap, then this is a logical error to get. In order to intercept your secure communications, FiddlerCap needs to present "fake" site certificates to Firefox.

more options

@ jscher2000: To my knowledge, I haven’t customized/changed any ssl/tls settings.

Checking for, ‘tls’:

  • before changing, 3 of them I was able to re-set, interesting*

Checking for, ‘security.ssl’:

  • nothing could be reset*

I do have a Firefox plug-in called, ‘SSL Version Control’ But nothing in that list was re-settable.

As for the Firefox using a proxy, it’s set to ‘Use system proxy Settings’ at the moment, I never changed that, no idea why I would.

I did change it to ‘no proxy’ to check, but no difference, checked normal and safe mode, still can’t access my hotmail account with this installed Firefox ;(

more options

Thank you for the preference screen shots. Nothing strange there. You can disable these two obsolete ciphers to see whether that makes any difference:

security.ssl3.dhe_rsa_aes_128_sha security.ssl3.dhe_rsa_aes_256_sha

But since those most likely are not disabled by default in Firefox Portable, that probably isn't the issue.

It seems that is something of a waystation as I can't access that domain directly. But I assume you have the same error accessing (normally redirects to your particular server, or back to the login page if applicable)?

You might also checking these network-related preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste network. and pause while the list is filtered. Anything customized here? I wouldn't reset to default without discussion just in case some modification is important.

more options

@ jscher2000: I tried disabling those two ciphers, didn't do anything sadly.

To check my e-mail, I’ve always (since I first created it years ago), just typed ‘’ in the address bar and I’m auto/redirected to the sign-in page to check my e-mail, normally no troubles.

As for: about:config - >network That’s what I get, a long list, but organized by status so the non-default are at top, if need full list, just ask.

I’ll leave them that way for now, unless told otherwise.

more options

Are you using a bookmark or are you starting with the main (home) page of this website?

If you use a bookmark to open a specific page on the server then try to navigate to that page starting with the main page or the sign in page of the website in case this bookmark is currently broken.

more options

Hi John135, those preferences look fine.

I suspect there's a transparent proxy, but so far we don't have any clues as to what it is. If you inspect your connection to Live Mail in Chrome, can you learn more? Click the padlock icon in the address bar, then a bit down the panel, Connection. That should tell you the cipher in use; Firefox doesn't like RC4 ciphers.

You also can check the certificate for any tell-tale intermediares. I am attaching a sample of what you might see (for a different site, since Live Mail servers vary by region and I have no way of accessing a different one).

more options

@ cor-el: I’ve only manually typed in ‘’ each time to check my e-mail.

I just tried and sign in there, but still odd “Something went wrong and we can't sign you in right now. Please try again later.” error.

@ jscher2000: Clicking padlock Icon in address bar in Chrome, this is what shows up:

more options

Thanks for the screen shots. I don't see the source of the problem. SSL Labs shows that Firefox 39 can connect using the same cipher as Chrome: I'm not aware of a change in Firefox 40 that prevents that.

Are these the only sites your Firefox objects to?

Did you ever try disabling HTTPS scanning in Avast?

more options

@ jscher2000: Checking my hotmail account, trying to anyway, is the only site that my installed Firefox will not allow me access, oddly the fresh portable version can (Firefox/OS in safemod does nothing, still get error).

As for Avast, I tried disabling HTTPS scanning it in, restart my PC, still same odd error.

I just checked, still nothing from M$, I don’t think they will tell me what the, "Something went wrong and we can't sign you in right now. Please try again later." error really means anyway, or if they will ever get back to me.

I just used FEBE to do a full backup of my Firefox profile, so I guess I'm pre-pared for any more drastic measures if needed to fix this problem.

more options

I don't know whether you have a text file comparison tool, if not, WinMerge is handy:

It might be interesting to compare the prefs.js files between your regular installation and the portable folder.

To find the file in your regular installation, you can open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Scroll down and find prefs.js and copy it to a convenient location such as your Documents folder. Please do not double-click .js files, as they will be executed in the Windows Script interpreter with unpredictable consequences.

Note: Windows hides the .js file extension by default. You can set Windows to show all file extensions using the steps in this article:

I'm not sure where the prefs.js file is in a Portable installation, but probably if you drill down into its folder you can find the corresponding profile folder.

Do any differences stick out?

more options

@ jscher2000: WinMerge is an interesting/nice tool, there were 2 prefs.js in the portable Firefox I’m guessing the one in the folder ‘Profile’ is more useful then the one in the ’Default Data’ folder.

I made there own folders so I know where they came from, I then ran the program, it says 46 difference found:

How do I tell what lines are different? I’ll keep looking threw the options to try and figure out how to use the program.

Modified by John135

more options

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

more options

The differences are highlighted in color.

I'm alarmed by one preference in the left window, which modifies "app.update.url.override" to a strange site that appears to have no affiliation with Mozilla. You can use about:config to remove that (right-click > Reset that preference). However, it looks as though you have automatic updates disabled, so hopefully Firefox hasn't send anything to that site about your installation.

Otherwise, what's on that first screen shot doesn't seem related to problems with a particular website.

more options

I see, that makes it simpler then I though then.

I disabled updates after I found this problem, once it’s resolved and I know what went wrong and how to fix it, I will then re-enable auto-updates.

I reset the 'app.update.url.override' string, then tried to check my e-mail, sadly no go.

I noticed something, in the status bar when trying to sign in with either Firefox, though I’d post it.

When I use the portable Firefox, when I try to sign in, right away I get a Outlook icon with the words, 'starting...almost done' under it, but in the built in Firefox, I don't get any icon in the middle of the page, just a white page.

Oddly in the status bar of installed Firefox, after clicking, ‘sign-in’ I see these lines, in about this order (with Gadwin Printscreen help):

[Seams to jump from one to another, almost randomly, then odd can‘t check/get into e-mail error]

But I see these lines, in about this order, when I use Portable Firefox:

[special note, this is when the Outlook Icon shows up, under the icon says “Starting…Almost there…”]

[now I’m signed in and can look at my e-mail no troubles]

No idea if this info might help, but I’m starting to grasp at straws now.

more options

There are other differences that weren't in that screen shot. In the left column, there are thin yellow lines showing roughly where they are in the file. Some of the arrows on the WinMerge toolbar will scroll you down to the next difference or up to the previous.

The back-and-forth you're seeing between servers seems more characteristic of a cookie problem, but I know you mentioned clearing your cookies and usually you wouldn't get a sudden SSL error in the midst of it anyway.

But... along those lines, could you return to the network settings and reset two of them. I hadn't focused on those in your earlier screen shot as I didn't expect any connection to the error you're seeing, but what the heck.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste network. and pause while the list is filtered.

(3) Double-click the network.cookie.blockFutureCookies preference to restore the default value of false

(4) Right-click > Reset the network.cookie.cookieBehavior preference to restore the default value of 0 (accept all third party cookies)

Any difference?

  1. 1
  2. 2