X
Tap here to go to the mobile version of the site.

Support Forum

Firefox occasionally displays a black screen until minimized/maximized.

Posted

Firefox has been turning my pages black. It's not exactly a crash; all it takes to fix it is to minimize and re-maximize the browser. However it is incredibly annoying to have to continually do that while working. Screenshot image is added below.

This has been occurring ever since I upgraded to Windows 10. It only seems to occur on certain sites: namely facebook and SAS on demand (yay for the screen going black in the middle of coding!). Turning off hardware acceleration did not fix it, and I can reliably reproduce it by typing code into SAS on demand (or mousing around) or browsing Facebook. Any ideas? Thanks!

Firefox has been turning my pages black. It's not exactly a crash; all it takes to fix it is to minimize and re-maximize the browser. However it is incredibly annoying to have to continually do that while working. Screenshot image is added below. This has been occurring ever since I upgraded to Windows 10. It only seems to occur on certain sites: namely facebook and SAS on demand (yay for the screen going black in the middle of coding!). Turning off hardware acceleration did not fix it, and I can reliably reproduce it by typing code into SAS on demand (or mousing around) or browsing Facebook. Any ideas? Thanks!

Chosen solution

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • Unity Player 5.1.3f1

Application

  • Firefox 40.0.3
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon R9 200 Series
  • adapterDescription2: Intel(R) HD Graphics 4600
  • adapterDeviceID: 0x6810
  • adapterDeviceID2: 0x0412
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterRAM: 2048
  • adapterRAM2: Unknown
  • adapterSubsysID: 2336148c
  • adapterSubsysID2: 0000000c
  • adapterVendorID: 0x1002
  • adapterVendorID2: 0x8086
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 8-3-2015
  • driverDate2: 7-17-2015
  • driverVersion: 15.200.1062.1004
  • driverVersion2: 10.18.15.4256
  • failures: [u'[GFX1]: [D3D11] 2 CreateTexture2D failure Size(1912,868) Code: 0x887a0005', u'[GFX1]: Failed to create software bitmap: Size(640,360) Code: 0x8899000c', u'[GFX1]: Failed to create software bitmap: Size(640,360) Code: 0x8899000c', u'[GFX1]: Failed to create software bitmap: Size(640,360) Code: 0x8899000c', u'[GFX1]: Failed to create software bitmap: Size(64,64) Code: 0x8899000c', u'[GFX1]: Failed to create software bitmap: Size(9,5) Code: 0x8899000c']
  • indices: [0, 31, 32, 33, 34, 35]
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon R9 200 Series Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
Wesley Branton
  • Top 10 Contributor
577 solutions 4931 answers

Chosen Solution

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

'''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.