X
Tap here to go to the mobile version of the site.

Support Forum

Firefox Won't Start - Claims it is Already Open

Posted

Firefox will not start. It claims to be already running, but that doesn't seem to be the case.

I have tried creating a new user profile but when I try to open Firefox now, the "choose user profile" menu pops up. I have tried the new profile and they old one, and both give the same error message. "Firefox cannot use the profile "Default User" because it is in use. To continue, close the running instance of Firefox or choose a different profile."

There is an entry for firefox.exe in the "details" menu of my task manager, and nowhere else. When I try to end that task, I get the following error: "the operation could not be completed - Access is denied."

Due to some troubleshooting research, I've tried deleting the parent.lock file from my profile folder, but I get this error- "the action can't be completed because the file is open in Firefox."

I tried transferring my bookmarks and preferences from Firefox to Chrome, but I got a similar error suggesting that Firefox was already open and I would have to close it first.

I have also turned off my computer and uninstalled and reinstalled Firefox multiple times.

I'd really rather not lose all of my Firefox bookmarks, add-ons, and preferences. I also prefer using Firefox to Chrome, so if anyone can help me out I'd really appreciate it. I don't know what else to try.

My PC runs Windows 10, by the way.

Firefox will not start. It claims to be already running, but that doesn't seem to be the case. I have tried creating a new user profile but when I try to open Firefox now, the "choose user profile" menu pops up. I have tried the new profile and they old one, and both give the same error message. "Firefox cannot use the profile "Default User" because it is in use. To continue, close the running instance of Firefox or choose a different profile." There is an entry for firefox.exe in the "details" menu of my task manager, and nowhere else. When I try to end that task, I get the following error: "the operation could not be completed - Access is denied." Due to some troubleshooting research, I've tried deleting the parent.lock file from my profile folder, but I get this error- "the action can't be completed because the file is open in Firefox." I tried transferring my bookmarks and preferences from Firefox to Chrome, but I got a similar error suggesting that Firefox was already open and I would have to close it first. I have also turned off my computer and uninstalled and reinstalled Firefox multiple times. I'd really rather not lose all of my Firefox bookmarks, add-ons, and preferences. I also prefer using Firefox to Chrome, so if anyone can help me out I'd really appreciate it. I don't know what else to try. My PC runs Windows 10, by the way.

Chosen solution

Try to remove the parent.lock file in the Firefox profile folder.

See:

What security software do you have?


Try to create a new Firefox desktop shortcut and possibly reinstall Firefox via a clean reinstall (i.e. delete the Firefox program folder).

If you can't delete the Firefox program folder then try to rename this folder to "Mozilla Firefox.old".

  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"
  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4254 solutions 59579 answers

Do you have the Firefox icon on your quick launch? Right click on it, and select Open New Window. Sometimes this works. If it opens, close it by Menu > File > Exit.


This is not a cure but will make it easier if Firefox locks up in Windows. https://support.mozilla.org/questions/997866 {web link}

Do you have the Firefox icon on your quick launch? Right click on it, and select '''Open New Window.''' Sometimes this works. If it opens, close it by '''Menu > File > Exit.''' ------------------ This is not a cure but will make it easier if Firefox locks up in Windows. '''https://support.mozilla.org/questions/997866''' {web link}

Question owner

The above method did not work.

The above method did not work.
FredMcD
  • Top 10 Contributor
4254 solutions 59579 answers

Did you try the link I posted?


Sometimes when FF is closing, not all of it shuts down properly. On Windows, start the Task Manager. (Other systems may have different names and / or commands). Select Processes. Look down the list for Firefox. Right click and select End Task.

Did you try the link I posted? ------------------- Sometimes when FF is closing, not all of it shuts down properly. On Windows, start the '''Task Manager.''' (Other systems may have different names and / or commands). Select '''Processes'''. Look down the list for Firefox. Right click and select '''End Task'''.
FredMcD
  • Top 10 Contributor
4254 solutions 59579 answers

Once you have closed Firefox,

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox.

While still in Safe Mode,

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.


After the above, close Firefox. Any problem?

Once you have closed Firefox, Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. While still in Safe Mode, Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Then in the reply box at the bottom of this page, do a right click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.''' ------------------- After the above, close Firefox. Any problem?
cor-el
  • Top 10 Contributor
  • Moderator
17519 solutions 158412 answers

Chosen Solution

Try to remove the parent.lock file in the Firefox profile folder.

See:

What security software do you have?


Try to create a new Firefox desktop shortcut and possibly reinstall Firefox via a clean reinstall (i.e. delete the Firefox program folder).

If you can't delete the Firefox program folder then try to rename this folder to "Mozilla Firefox.old".

  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"
  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Try to remove the parent.lock file in the Firefox profile folder. *C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\Profiles\&lt;profile&gt;\ *http://kb.mozillazine.org/Profile_folder_-_Firefox See: *http://kb.mozillazine.org/Profile_in_use *https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding What security software do you have? ---- Try to create a new Firefox desktop shortcut and possibly reinstall Firefox via a clean reinstall (i.e. delete the Firefox program folder). If you can't delete the Firefox program folder then try to rename this folder to "Mozilla Firefox.old". *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

Question owner

FredMcD said

Did you try the link I posted?

Sometimes when FF is closing, not all of it shuts down properly. On Windows, start the Task Manager. (Other systems may have different names and / or commands). Select Processes. Look down the list for Firefox. Right click and select End Task.

I did try the link that you posted, and it did not work. FF is not listed in the "Processes" tab in Task manager, as I mentioned it is only listed on the "Details" tab.

FredMcD said

Once you have closed Firefox, Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. While still in Safe Mode, Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

After the above, close Firefox. Any problem?

FF will not start in safe mode, because it will not start.

cor-el said

Try to remove the parent.lock file in the Firefox profile folder. See: What security software do you have?

Try to create a new Firefox desktop shortcut and possibly reinstall Firefox via a clean reinstall (i.e. delete the Firefox program folder).

If you can't delete the Firefox program folder then try to rename this folder to "Mozilla Firefox.old".

  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"
  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

I've tried a clean install, but I cannot delete the FF program folder, even if I change it to "Mozilla Firefox.old." I'll try booting in safe mode and get back to you.

''FredMcD [[#answer-779677|said]]'' <blockquote> Did you try the link I posted? ------------------- Sometimes when FF is closing, not all of it shuts down properly. On Windows, start the '''Task Manager.''' (Other systems may have different names and / or commands). Select '''Processes'''. Look down the list for Firefox. Right click and select '''End Task'''. </blockquote> I did try the link that you posted, and it did not work. FF is not listed in the "Processes" tab in Task manager, as I mentioned it is only listed on the "Details" tab. ''FredMcD [[#answer-779680|said]]'' <blockquote> Once you have closed Firefox, Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. While still in Safe Mode, Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Then in the reply box at the bottom of this page, do a right click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.''' ------------------- After the above, close Firefox. Any problem? </blockquote> FF will not start in safe mode, because it will not start. ''cor-el [[#answer-779695|said]]'' <blockquote> Try to remove the parent.lock file in the Firefox profile folder. *C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\Profiles\&lt;profile&gt;\ *http://kb.mozillazine.org/Profile_folder_-_Firefox See: *http://kb.mozillazine.org/Profile_in_use *https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding What security software do you have? ---- Try to create a new Firefox desktop shortcut and possibly reinstall Firefox via a clean reinstall (i.e. delete the Firefox program folder). If you can't delete the Firefox program folder then try to rename this folder to "Mozilla Firefox.old". *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 </blockquote> I've tried a clean install, but I cannot delete the FF program folder, even if I change it to "Mozilla Firefox.old." I'll try booting in safe mode and get back to you.

Question owner

And we're up and running again. Booted in safe mode and was able to delete the FF folder. Once I restarted, I did a new install of FF and everything is working fine. Thank you for your help.

And we're up and running again. Booted in safe mode and was able to delete the FF folder. Once I restarted, I did a new install of FF and everything is working fine. Thank you for your help.
FredMcD
  • Top 10 Contributor
4254 solutions 59579 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
AliceWyman
  • Moderator
240 solutions 2597 answers

jimmyjkjr said

cor-el said
<snip> reinstall Firefox via a clean reinstall (i.e. delete the Firefox program folder). If you can't delete the Firefox program folder then try to rename this folder to "Mozilla Firefox.old".
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"
  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

I've tried a clean install, but I cannot delete the FF program folder, even if I change it to "Mozilla Firefox.old." I'll try booting in safe mode and get back to you.

jimmyjkjr said

And we're up and running again. Booted in safe mode and was able to delete the FF folder. Once I restarted, I did a new install of FF and everything is working fine. Thank you for your help.

Thanks for posting the outcome. I'll mark cor-el's answer as the solution.

''jimmyjkjr [[#answer-780088|said]]'' <blockquote> ''cor-el [[#answer-779695|said]]'' <blockquote> <snip> reinstall Firefox via a clean reinstall (i.e. delete the Firefox program folder). If you can't delete the Firefox program folder then try to rename this folder to "Mozilla Firefox.old". * (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" * (32 bit Windows) "C:\Program Files\Mozilla Firefox\" Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 </blockquote> I've tried a clean install, but I cannot delete the FF program folder, even if I change it to "Mozilla Firefox.old." I'll try booting in safe mode and get back to you. </blockquote> ''jimmyjkjr [[#answer-780094|said]]'' <blockquote> And we're up and running again. Booted in safe mode and was able to delete the FF folder. Once I restarted, I did a new install of FF and everything is working fine. Thank you for your help. </blockquote> Thanks for posting the outcome. I'll mark cor-el's answer as the solution.