X
Tap here to go to the mobile version of the site.

Support Forum

I'd like to change my download directory but the option is greyed out. Can I rectify this?

Posted

I have no trouble changing download directory in other browsers on my computer, e.g. Safari. I've attached a screen shot of the general tab of my Firefox preferences. I've just noticed in the "Troublshooting Information" attached to this question page that "lockedPreferences" includes "browser.download.useDownloadDir":false ... Please instead of pointing out that that is the problem (if it is), please help me in understanding why this is that way and how to change it.

I have no trouble changing download directory in other browsers on my computer, e.g. Safari. I've attached a screen shot of the general tab of my Firefox preferences. I've just noticed in the "Troublshooting Information" attached to this question page that "lockedPreferences" includes "browser.download.useDownloadDir":false ... Please instead of pointing out that that is the problem (if it is), please help me in understanding why this is that way and how to change it.

Chosen solution

Check if there is a mozilla.cfg file present in the Firefox application folder to initialize some prefs.

This also involves the presence of a .js (JScript) file, probably in "defaults/pref" folder, that specifies to process this mozilla.cfg file.

If there are .js files apart from the channel-prefs.js file, that sets app.update.channel, in the defaults/pref folder then open this file in an editor like Notepad (Mac: TextEdit) and please post its content. Also please post the content of the mozilla.cfg file.

There shouldn't be a mozilla.fcg file present in the main Firefox folder unless you've created it yourself to initialize some prefs.

If you have this mozilla.cfg file then best is to do a clean reinstall and move the Firefox application folder to the trash before reinstalling a fresh copy of Firefox.

You can find the full version of the current Firefox release (40.0.3) in all languages and all operating systems here:

See also:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.15
  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0

Application

  • Firefox 38.2.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.2.0/Darwin/en-US/

Extensions

  • Classic Theme Restorer 1.3.8 (ClassicThemeRestorer@ArisT2Noia4dev)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x d26
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel Iris Pro OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158598 answers

Chosen Solution

Check if there is a mozilla.cfg file present in the Firefox application folder to initialize some prefs.

This also involves the presence of a .js (JScript) file, probably in "defaults/pref" folder, that specifies to process this mozilla.cfg file.

If there are .js files apart from the channel-prefs.js file, that sets app.update.channel, in the defaults/pref folder then open this file in an editor like Notepad (Mac: TextEdit) and please post its content. Also please post the content of the mozilla.cfg file.

There shouldn't be a mozilla.fcg file present in the main Firefox folder unless you've created it yourself to initialize some prefs.

If you have this mozilla.cfg file then best is to do a clean reinstall and move the Firefox application folder to the trash before reinstalling a fresh copy of Firefox.

You can find the full version of the current Firefox release (40.0.3) in all languages and all operating systems here:

See also:

Check if there is a <b>mozilla.cfg</b> file present in the Firefox application folder to initialize some prefs. This also involves the presence of a .js (JScript) file, probably in "defaults/pref" folder, that specifies to process this mozilla.cfg file. If there are .js files apart from the channel-prefs.js file, that sets app.update.channel, in the defaults/pref folder then open this file in an editor like Notepad (Mac: TextEdit) and please post its content. Also please post the content of the mozilla.cfg file. There shouldn't be a mozilla.fcg file present in the main Firefox folder unless you've created it yourself to initialize some prefs. If you have this mozilla.cfg file then best is to do a clean reinstall and move the Firefox application folder to the trash before reinstalling a fresh copy of Firefox. *http://kb.mozillazine.org/Preferences_not_saved#Other_solutions You can find the full version of the current Firefox release (40.0.3) in all languages and all operating systems here: *https://www.mozilla.org/en-US/firefox/all/ See also: *http://kb.mozillazine.org/Locking_preferences

Question owner

Hi cor-el,

Thanks --- that pointed me to where my problem was. This is a new (personal) laptop I ordered via my work and it appears they pre-installed some "useful" (i.e. annoying) "security" (i.e. annoying) features. As per your request...

in defaults/pref/ there is a file autoconfig.js

This contains: pref("general.config.filename", "cck2.cfg"); pref("general.config.obscure_value", 0);

It appears that cck2.cfg is thus taking place of what would normally be mozilla.cfg (as this looks to be part of my work's security stuff I won't post its contents as requested---apologies). But indeed, this is the config file that is blocking my download directory with the line:

 "dontUseDownloadDir": true

I have root access so am able to change the cfg file. Changing "true" to "false" in that field fixed my problem.

I agree that removing the firefox directory and doing a clean install would have also fixed the issue.

Thanks again for the prompt and useful reply, xiggy

Hi cor-el, Thanks --- that pointed me to where my problem was. This is a new (personal) laptop I ordered via my work and it appears they pre-installed some "useful" (i.e. annoying) "security" (i.e. annoying) features. As per your request... in defaults/pref/ there is a file autoconfig.js This contains: pref("general.config.filename", "cck2.cfg"); pref("general.config.obscure_value", 0); It appears that cck2.cfg is thus taking place of what would normally be mozilla.cfg (as this looks to be part of my work's security stuff I won't post its contents as requested---apologies). But indeed, this is the config file that is blocking my download directory with the line: "dontUseDownloadDir": true I have root access so am able to change the cfg file. Changing "true" to "false" in that field fixed my problem. I agree that removing the firefox directory and doing a clean install would have also fixed the issue. Thanks again for the prompt and useful reply, xiggy
cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158598 answers

You're welcome

Looks that the CCK2 extension has been used to create the installer.

You're welcome Looks that the CCK2 extension has been used to create the installer. *CCK2 Wizard: https://addons.mozilla.org/firefox/addon/cck2wizard/