Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Local xpi Add-ons stopped installing

  • 13 replies
  • 15 have this problem
  • 6554 views
  • Last reply by jscher2000

more options

I have hundreds of Firefox addons that i have developed for my company to preform automated tasks in our information system. Firefox updated to 40.03 today and i can no longer install any of them in Firefox.

"firefox prevented this site from asking you to install software on you computer"

is there a setting in Firefox i can turn off to allow me to install the ad-dons i have developed? I don't really want to sign these. They are not hosted anyway but live on a local computer. They are all proprietary and we use them internally only.

All Replies (13)

more options

open new tab type "about:config" proceed enter " xpinstall.signatures.required" in search bar. modify value to "false" (just click on it).

restart firefox and try install extension again.

worked in FF 41beta 4 https://wiki.mozilla.org/Addons/Extension_Signing

Modified by _ika

more options

FF 4.03 Followed the suggestion. xpinstall.signatures.required is already false. so no dice.

installed developer edition. 42.0a2 (2015-08-28) followed instructions. restarted ff I get the same slightly different message "Firefox Developer Edition prevented this site from asking you to install software on you computer"

according to https://wiki.mozilla.org/Addons/Extension_Signing this should work on the developer edition?

more options

JoeTheBadger said

I have hundreds of Firefox addons that i have developed for my company to preform automated tasks in our information system. Firefox updated to 40.03 today and i can no longer install any of them in Firefox.

The long term solution is to submit each of them to Mozilla for signing. Mozilla has no problem with "signed" add-ons being private, and staying "self-hosted". Otherwise as of Firefox 43 [under the current timetable] changing the preference that was mentioned by _ika won't work. That pref will only be available for Firefox 42 and 43 versions on the Release and Beta channels.

The Aurora / Web Developer and Nightly channels have and will continue to have the xpinstall.signatures.required pref which is automatically enabled for those channels.

One other choice you have is to build your own "Firefox" 3rd party version from source. With "Builds" that pref can be disabled or that "signing" feature can be left out of the build process.

more options

Note - I was able to install one "verfied" addon from local disk, but when I tried to install an extension that I had modified and wasn't 'signed' it was blocked in Firefox 40 Release. I don't have any pre-release builds installed so I can't test this any further. Overall I am so thoroughly unhappy with Mozilla over the last year due to changes like this, that I no longer wish to spend any time helping even in a small way to further development or testing of features that are killing what I like best about Firefox. IMO, this "walled garden" Mozilla is erecting will surely 'kill' Firefox in the long run. This "Chrome-envy" has run its course and I'm having no more of it. I hear Vivaldi calling ...

more options

Looks like the Web Developer Option is/will be the solution. There is no way we are submitting hundreds of internal plugins full of proprietary code to a third party.

So if I have 42.0a2 (2015-08-28) and have set "xpinstall.signatures.required" to false why is it still giving me this message: "Firefox Developer Edition prevented this site from asking you to install software on you computer" when i try and install any of extensions?

Modified by JoeTheBadger

more options

You may look for Firefox ESR. Current Firefox ESR is based FF38, so he probably won't be affected by signing. FF ESR 38 will live till March 2016 (Then comes FF45 based ESR) ,so you have some little time.

more options

Hmm, what do you mean by "local"? Are you installing from a UNC path or an internal web server?

Here's a screenshot of what I see in Firefox 40.0.3 with an unsigned extension loading from the C drive: just a warning and then I can install. The actual blockage on unsigned extensions starts in Firefox 41.

From your original question, I think the problem is not related to the signing issue.

Normally the "Firefox prevented a site" message has an Allow button; for example, if you try to install the Yahoo! toolbar from here:

https://us.toolbar.yahoo.com/

You should see the panel in my second screen shot.

Are you not getting an Allow button now?

Or had you previously either saved an exception for your installation server, or turned off the feature of sites needing permission to install software? The checkbox for that setting and the Exceptions list dialog are on the Security panel of the Options page, either:

  • "3-bar" menu button (or Tools menu) > Options > Security
  • type or paste about:preferences#security in the address bar and press Enter
more options

Thanks jscher2000 I believe you solved my issue. You are correct this has nothing to do with the new signing. I am installing from the hardd rive. C:\Users\......\workspace\plugin150\extension\autocrawl.xpi

So file:///C:/......

I do not get that button when installing from harddrive. Strangely i do get the allow button when i use https://us.toolbar.yahoo.com/ .

Turns out there must be some sort of other change in 4.03. In 4.03 if i put the full path to the xpi file in the address bar i do not get a allow button (which is how i have been installing them for the last 7 or so years). If i drag the the xpi file onto the firefox window or navigate to the folder and then click on the xpi file i get the allow button.

Weirdness.

I do appreciate everyone help!
more options

JoeTheBadger said

if i put the full path to the xpi file in the address bar i do not get a allow button (which is how i have been installing them for the last 7 or so years). If i drag the the xpi file onto the firefox window or navigate to the folder and then click on the xpi file i get the allow button.

The two ways I tested were drag-and-drop and using the "gear" button on the Add-ons page to "Install Add-on from File..." So that would explain why I couldn't reproduce the problem.

There have been some changes under the hood to reduce the ease with which malware can install extensions, so perhaps the direct file:// URL method was a victim of that.

more options

Chosen Solution

more options

jscher2000 said

... Normally the "Firefox prevented a site" message has an Allow button; for example, if you try to install the Yahoo! toolbar from here: https://us.toolbar.yahoo.com/ You should see the panel in my second screen shot. Are you not getting an Allow button now? Or had you previously either saved an exception for your installation server, or turned off the feature of sites needing permission to install software? The checkbox for that setting and the Exceptions list dialog are on the Security panel of the Options page, either:
  • "3-bar" menu button (or Tools menu) > Options > Security
  • type or paste about:preferences#security in the address bar and press Enter

Actually, my "Allow" message (announcing blocking) features no Allow button at all-- see attached image, "Screenshot #1-- No Allow button.png".

Yes, I have experimented with the allowable site exceptions dialogue under Tools/Options/Security, entering the site URL and clicking on "Allow" beneath the load window, and then on "Save", but that attempt was blocked.

In addition, although my action greyed out the site "Exceptions" list button temporarily, I even unchecked the box to be notified if a site attempts to load an Addon, but an attempted installation afterward from the Firefox Addons/Extensions page still brought a blocking announcement.

The URL of the attempted load is-- https://addons.mozilla.org/firefox/downloads/file/256682/suspend_tab-0.2.2014050201-fx.xpi?src=search which indicates the origin is Mozilla, itself.

more options

If you do not see an 'Allow' button then it is possible that this part of the page is opened in an (i)frame. You can check that via the right-click context menu and use "This Frame > Open Frame in New Tab".

more options

Hi alphaa10000, judging from the title bar of your browser -- "Firefox 2015: Foxstart Edition" -- you have a customized version of Firefox that may have important differences from the official release. If the above reply doesn't help, please start a new question and supply full information about your browser configuration.