X
Tap here to go to the mobile version of the site.

Support Forum

Cannot get any search engines to work in ff

Posted

This comes up every time I do a search:

This Connection is Untrusted

You have asked Firefox to connect securely to www.google.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

This comes up every time I do a search: This Connection is Untrusted You have asked Firefox to connect securely to www.google.com, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Content Blocker Extension
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Online Banking Extension
  • Shockwave Flash 18.0 r0
  • Virtual Keyboard
  • Npdsplay dll
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 40.0.3
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

Extensions

  • Dangerous Websites Blocker 4.5.1.379 (content_blocker_663BE84DBCC949E88C7600F63CA7F098@kaspersky.com) (Inactive)
  • HP Smart Print 1.1.1.0 (quickprint@hp.com) (Inactive)
  • Safe Money 4.5.1.379 (online_banking_08806E753BE44495B44E90AA2513BDC5@kaspersky.com) (Inactive)
  • Virtual Keyboard 4.5.1.379 (virtual_keyboard_07402848C2F6470194F131B0F3DE025E@kaspersky.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 7025 / NVIDIA nForce 630a
  • adapterDescription2:
  • adapterDeviceID: 0x03d6
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 03d61849
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 6.14.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 7025 / NVIDIA nForce 630a Direct3D9 vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 9

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4300 solutions 60395 answers

Are you having problems with the search engines, or the connection?

Delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the search files. Then rename or delete them. Restart Firefox.


http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html

https://support.mozilla.org/en-US/kb/server-not-found-connection-problem

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

Are you having problems with the search engines, or the connection? Delete the '''search.json''' file and possible '''search-metadata.json''' and '''search.sqlite''' files in the Firefox profile folder to reset the search engines to the default. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the '''search''' files. Then rename or delete them. Restart Firefox. ---------------------- http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

It appears you use Kaspersky. A common reason for this problem would that Firefox is not set up to work with filtering of secure connections. In that process, Kaspersky needs to present fake site certificates to Firefox in order to intercept and decrypt the transmission. Normally Kaspersky's installer takes care of this automatically, but in some cases, manual intervention might be required.

Unfortunately, this problem can also be caused by malware, but let's try Kaspersky first.

I found these steps in a post on the Kaspersky forums and you will see that it refers to an older version of the program so the actual path on disk probably has changed a bit:


Open Firefox's Certificate Manager:

"3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab > View Certificates button

In the Certificate Manager dialog, click the "Authorities" mini-tab (not the Servers mini-tab)

If you see an existing "Kaspersky Anti-Virus Personal Root Certificate"

Select it and Click "Delete or Distrust"

Now click "Import..."

Proceed to "C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\" Note: The bolded part may be different for your product.

Select "(fake)Kaspersky Anti-Virus Personal Root Certificate.cer" and Open!


Does that work on your Firefox?

It appears you use Kaspersky. A common reason for this problem would that Firefox is not set up to work with filtering of secure connections. In that process, Kaspersky needs to present fake site certificates to Firefox in order to intercept and decrypt the transmission. Normally Kaspersky's installer takes care of this automatically, but in some cases, manual intervention might be required. Unfortunately, this problem can also be caused by malware, but let's try Kaspersky first. I found these steps in a post on the Kaspersky forums and you will see that it refers to an older version of the program so the actual path on disk probably has changed a bit: ---- Open Firefox's Certificate Manager: "3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab > View Certificates button In the Certificate Manager dialog, click the "Authorities" mini-tab (not the Servers mini-tab) ''If you see an existing "Kaspersky Anti-Virus Personal Root Certificate"'' ''Select it and Click "Delete or Distrust"'' Now click "Import..." Proceed to "C:\ProgramData\Kaspersky Lab\'''AVP15.0.1'''\Data\Cert\" ''Note: The bolded part may be different for your product.'' Select "(fake)Kaspersky Anti-Virus Personal Root Certificate.cer" and Open! ---- Does that work on your Firefox?