X
Tap here to go to the mobile version of the site.

Support Forum

web page not showing icons

Posted

Some websites are not showing icons or fonts correctly, only boxes with code. I tried the following recommendations: about:config - gfx.downloadable_fonts.enabled;true Checked = Allow pages to choose their own fonts, instead of my selections above Uninstalled Firefox, deleted folders, reinstalled & still get the same results. I have my personal laptop on the same network & it works fine. THe only difference between my work laptop & person laptop is the person laptop is running Windows 10 home.

Some websites are not showing icons or fonts correctly, only boxes with code. I tried the following recommendations: about:config - gfx.downloadable_fonts.enabled;true Checked = Allow pages to choose their own fonts, instead of my selections above Uninstalled Firefox, deleted folders, reinstalled & still get the same results. I have my personal laptop on the same network & it works fine. THe only difference between my work laptop & person laptop is the person laptop is running Windows 10 home.
Attached screenshots

Chosen solution

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Also make sure that your security software isn't blocking downloadable fonts. You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Also make sure that your security software isn't blocking downloadable fonts. You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

I was monitoring our Watchguard firewall for denials & nothing showed for my IP. Using the Network log in the Web Console, I found URL's being blocked. Added the URL's to the firewall exception list & now all is good.

Thanks cor-el for pointing me in the right direction!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Charter TV Player Plugin
  • Citrix Online App Detector Plugin
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • VMware Remote Console Plug-in

Application

  • Firefox 40.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.2/WINNT/en-US/

Extensions

  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 3000
  • adapterDescription2: NVIDIA Quadro 3000M
  • adapterDeviceID: 0x0126
  • adapterDeviceID2: 0x0e3a
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 04a41028
  • adapterSubsysID2: 14a41028
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • clearTypeParameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 5-27-2015
  • driverDate2: 7-22-2015
  • driverVersion: 9.17.10.4229
  • driverVersion2: 10.18.13.5362
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.'''
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157871 answers

Helpful Reply

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Also make sure that your security software isn't blocking downloadable fonts.

You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero).

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Also make sure that your security software isn't blocking downloadable fonts. You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). *https://developer.mozilla.org/Tools/Network_Monitor Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

Question owner

FredMcD said

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Tried this already & it did not resolve the issue.

''FredMcD [[#answer-773179|said]]'' <blockquote> Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' </blockquote> Tried this already & it did not resolve the issue.

Question owner

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Problem still exists in safe mode

''FredMcD [[#answer-773183|said]]'' <blockquote> Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? </blockquote> Problem still exists in safe mode

Chosen Solution

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Also make sure that your security software isn't blocking downloadable fonts. You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Also make sure that your security software isn't blocking downloadable fonts. You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

I was monitoring our Watchguard firewall for denials & nothing showed for my IP. Using the Network log in the Web Console, I found URL's being blocked. Added the URL's to the firewall exception list & now all is good.

Thanks cor-el for pointing me in the right direction!

''cor-el [[#answer-773189|said]]'' <blockquote> Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Also make sure that your security software isn't blocking downloadable fonts. You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). *https://developer.mozilla.org/Tools/Network_Monitor Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log. </blockquote> ''cor-el [[#answer-773189|said]]'' <blockquote> Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Also make sure that your security software isn't blocking downloadable fonts. You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). *https://developer.mozilla.org/Tools/Network_Monitor Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log. </blockquote> I was monitoring our Watchguard firewall for denials & nothing showed for my IP. Using the Network log in the Web Console, I found URL's being blocked. Added the URL's to the firewall exception list & now all is good. Thanks cor-el for pointing me in the right direction!
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157871 answers

You're welcome

You're welcome