X
Tap here to go to the mobile version of the site.

Support Forum

firefox cant play 1080 HD videos on youtube but other browsers can.

Posted

The specific problem i have is that playing HD videos online irrespective of the website is always choppy. but the video plays fine in lower formats like 360p and 480p. i don't think my computer is the problem because similar videos play fine on internet explorer. I use Toshiba computer that's pretty old and i use windows 7. But like i said earlier the same old system plays the HD videos on internet explorer so why not on firefox. am using the latest version of firefox. so i will appreciate any useful solution to this problem as am enjoying my firefox experience up until this point.

The specific problem i have is that playing HD videos online irrespective of the website is always choppy. but the video plays fine in lower formats like 360p and 480p. i don't think my computer is the problem because similar videos play fine on internet explorer. I use Toshiba computer that's pretty old and i use windows 7. But like i said earlier the same old system plays the HD videos on internet explorer so why not on firefox. am using the latest version of firefox. so i will appreciate any useful solution to this problem as am enjoying my firefox experience up until this point.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Hola VLC media player Web Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • BlackBerry WebSL Browser Plug-In
  • Shockwave Flash 18.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

FredMcD
  • Top 10 Contributor
4306 solutions 60469 answers

check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''