Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 40 failing to display all buttons (only shows framework for buttons) on MSN and Yahoo email sites. What will fix this?

  • 12 replies
  • 7 have this problem
  • 604 views
  • Last reply by cor-el

more options

When I navigate to MSN, Hotmail or Yahoo Mail, some of the buttons that link to several functions or other pages only display as a square with no information as to button function. This problem, along with a tendency to hang up and freeze sporadically, started after the last update to Firefox 40. The freezing occurs randomly with no set timing or on no particular website but tends to occur more often on websites with music or video streaming.

Chosen solution

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. If you have a font installed that covers this Unicode range then you may see a real (CJK) character and not the little box with the CSS code.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Read this answer in context 👍 1

All Replies (12)

more options

https://support.cdn.mozilla.net/media/uploads/images/2015-08-24-11-36-45-aed442.png

the associated tags for your post indicate that you're running FF 41 beta -- that might be the problem. apologies if the image is shown twice.

more options

Separate Issue; Your System Details shows;

Installed Plug-ins

Adobe Shockwave for Director Netscape plug-in, version 12.1.8.158 Adobe Shockwave for Director Netscape plug-in, version 12.1.7.157
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Shockwave Director: Shockwave Standalone Installer / Uninstaller{web link} Shockwave Director Version 12.1.9.159 http://get.adobe.com/shockwave/


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Chosen Solution

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. If you have a font installed that covers this Unicode range then you may see a real (CJK) character and not the little box with the CSS code.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Thanks for the reply, but this didn't help my problem. Everything was already set that way, so the problem is still not fixed.

more options

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options
more options

This is definitely a problem with a downloaded icon font.

Are you sure that you checked both settings?

Did you check the gfx.downloadable_fonts.enabled on the about:config page to make sure it is set to true?

  • Tools > Options > Content : Fonts & Colors > Advanced

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

The above didn't fix the problem, however there is a setting in Fonts and Colors under Advanced that is marked Fallback Text encoding. When i changed this to show Other(including Western European) the problem was resolved. The buttons now are correct on all websites.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

more options

The one problem is fixed, but the problem with Firefox freezing intermittently still remains. I've refreshed Firefox and started with addons disabled and it still freezes randomly no matter what. Flash and other such are the latest updates. The page will just randomly freeze when switching from one page to another or during streaming some data or video. The search bar will show the "loading" icon (spinning circle), but it will be frozen and the page will freeze wherever it is at the moment. The only way to fix the freeze is to force the page to close using the task bar right click or, in some cases, I have had to use Task Manager to close the browser. When the page freezes it will sometimes restore to that same page when restarted and work okay, then again it will restore to the page and freeze again. There doesn't seem to be any pattern as to website or content that causes this; and no other browser that I use does this. I do have Firefox 43 (Nightly) and it doesn't have this issue.

Modified by cmickler

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options