Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Enigmail loaded ok, but does not unlock and decrypt message

  • 4 replies
  • 5 have this problem
  • 41 views
  • Last reply by BOHICAMAN

more options

Followed all directions and Enigmail shows it loaded into Thunderbird properly. However, when I get an encrypted email, it shows a closed lock and the following block shows up when I click on "Details":

Enigmail Security Info

Part of the message encrypted Error - no matching private/secret key found to decrypt message

gpg: decryption failed: No secret key

Note: The message is encrypted for the following User ID's / Keys:

 0xC8FED7D95D4C54DD
Followed all directions and Enigmail shows it loaded into Thunderbird properly. However, when I get an encrypted email, it shows a closed lock and the following block shows up when I click on "Details": Enigmail Security Info Part of the message encrypted Error - no matching private/secret key found to decrypt message gpg: decryption failed: No secret key Note: The message is encrypted for the following User ID's / Keys: 0xC8FED7D95D4C54DD

Chosen solution

Appreciate the advise. I deleted everything I had done and started again from scratch. I have no idea what I did differently from the first time, but it worked this time around!

Read this answer in context 👍 0

All Replies (4)

more options

The message wasn't encrypted to your public key. The sender must encrypt the message to your key for you to be able to decrypt it. So you'll need to exchange keys with the sender first.

more options

That was done already. I have repeatedly tried using the new key pair option in the wizard. The slider bar fills with green and it says the new key was generated. However, the next and back radio buttons remain greyed out. Could the Norton firewall/anti virus software be blocking something?

This is occurring on a ASUS X99-A motherboard, i7 5820, 64bit, 16GB RAM Windows 10 system.

more options

I'd suggest you ask this in the Enigmail support forum. https://www.enigmail.net/support/index.php

more options

Chosen Solution

Appreciate the advise. I deleted everything I had done and started again from scratch. I have no idea what I did differently from the first time, but it worked this time around!