X
Tap here to go to the mobile version of the site.

Support Forum

Firefox on Linux is even slower with version 40

Posted

I was waiting for version 40 to fix the slowness issues on Linux thanks to the "off main thread compositing" but it actually is even slower :(

My machine is an 8 cores CPU with 16GB of RAM and an average GPU (with open source radeon drivers). I did try "Repare Firefox" in about:support but it changes nothing.

Examples of slowness:

  • When playing a video on youtube (HTML5, not Flash), I can have up to half a second of delay between image and sound and something like 5fps.
  • When scrolling on Google+, it's so slow, I don't even see the smooth scrolling.

In the previous version, it was already kind of slow, but here it's yet another level. Of course I did try with Chrome and both the cases above were working flawlessly.

Regards, Creak

I was waiting for version 40 to fix the slowness issues on Linux thanks to the "off main thread compositing" but it actually is even slower :( My machine is an 8 cores CPU with 16GB of RAM and an average GPU (with open source radeon drivers). I did try "Repare Firefox" in about:support but it changes nothing. Examples of slowness: * When playing a video on youtube (HTML5, not Flash), I can have up to half a second of delay between image and sound and something like 5fps. * When scrolling on Google+, it's so slow, I don't even see the smooth scrolling. In the previous version, it was already kind of slow, but here it's yet another level. Of course I did try with Chrome and both the cases above were working flawlessly. Regards, Creak

Chosen solution

I apparently fixed part of the problem by force enabling "offmainthreadcomposition":

In about:config, enable:

  • layers.offmainthreadcomposition.async-animations
  • layers.offmainthreadcomposition.enabled

I also installed quite everything related to vdpau and vaapi (already had some of the packages installed).

It's better, but not the best. Considering the machine it's running on, it should really not have any stuttering at all. I hope e10s will improve this situation.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • The Evince 3.16.1 plugin handles documents inside the browser window.
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • Version: 5.41.0.0
  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

Chosen Solution

I apparently fixed part of the problem by force enabling "offmainthreadcomposition":

In about:config, enable:

  • layers.offmainthreadcomposition.async-animations
  • layers.offmainthreadcomposition.enabled

I also installed quite everything related to vdpau and vaapi (already had some of the packages installed).

It's better, but not the best. Considering the machine it's running on, it should really not have any stuttering at all. I hope e10s will improve this situation.

I apparently fixed part of the problem by force enabling "offmainthreadcomposition": In about:config, enable: * layers.offmainthreadcomposition.async-animations * layers.offmainthreadcomposition.enabled I also installed quite everything related to vdpau and vaapi (already had some of the packages installed). It's better, but not the best. Considering the machine it's running on, it should really not have any stuttering at all. I hope e10s will improve this situation.