X
Tap here to go to the mobile version of the site.

Support Forum

Since update 40.0.2 on 8/19/15, firefox hangs. Have tried refresh, etc

Posted

Firefox updated on 8/19/15 to 40.0.2. Since then, firefox has been hanging on commercials when watching Xfiinity (many commercials, but not every one). Windows 7 home premium SP1 up to date (did not upgrade to Windows 10), have updated flash to most current version (18.0.0.232), cleared cache and all history, refreshed firefox. Nothing helps. Did not have these hangs (Firefox has stopped responding) problems before 8/19/15, and firefox is the only thing that has changed. I do not have the problem using Internet Explorer. I prefer using firefox for most browsing. I would really like to avoid having to uninstall and reinstall firefox, when the problem seems to have only started after this most recent update.

Firefox updated on 8/19/15 to 40.0.2. Since then, firefox has been hanging on commercials when watching Xfiinity (many commercials, but not every one). Windows 7 home premium SP1 up to date (did not upgrade to Windows 10), have updated flash to most current version (18.0.0.232), cleared cache and all history, refreshed firefox. Nothing helps. Did not have these hangs (Firefox has stopped responding) problems before 8/19/15, and firefox is the only thing that has changed. I do not have the problem using Internet Explorer. I prefer using firefox for most browsing. I would really like to avoid having to uninstall and reinstall firefox, when the problem seems to have only started after this most recent update.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0 18.0.0.232
  • 5.1.40416.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • Firefox 40.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.2/WINNT/en-US/

Extensions

  • Classic Theme Restorer 1.3.7.1 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Norton Toolbar 2015.5.2.24 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 04d71028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 7-19-2011
  • driverDate2:
  • driverVersion: 8.15.10.2455
  • driverVersion2:
  • failures: [u'[GFX1-]: OpenSharedResource failed for format 65']
  • indices: [0]
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4266 solutions 59808 answers

I looks like you have two players.
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac

Then reinstall the latest version.

Flash Player Version 18.0.0.232
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

I looks like you have two players. <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer. Flash: Grab the uninstaller from here: '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows]''' '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac]''' Then reinstall the latest version. Flash Player '''Version 18.0.0.232<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' must download the “Internet Explorer” '''and''' “Plugin-based browsers” installers. ------------- Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? --------------------- check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Helpful Reply

Thanks, Fred. My Windows is already set for automatic update installs, and all updates available have been installed.

I don't see the sense in making multiple changes in things that were not broken 2 days ago, and have worked well for at least 2 years, when the only thing that changed is firefox, and things that were working before the firefox update stopped working the same day as the firefox update happened.

It is just too much of a coincidence to think that 5 other things are suddenly broken, when the only change is the Firefox update.

What would be more useful is information on how to revert to the last version of Firefox, and set it to not update automatically.

Or I could just stop using Firefox.

Thanks, Fred. My Windows is already set for automatic update installs, and all updates available have been installed. I don't see the sense in making multiple changes in things that were not broken 2 days ago, and have worked well for at least 2 years, when the only thing that changed is firefox, and things that were working before the firefox update stopped working the same day as the firefox update happened. It is just too much of a coincidence to think that 5 other things are suddenly broken, when the only change is the Firefox update. What would be more useful is information on how to revert to the last version of Firefox, and set it to not update automatically. Or I could just stop using Firefox.