X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Using "unverified" add-ons

Posted

Mozilla at https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox?as=u says that I "can still install [an] unverified add-on at [my] own risk"--but it doesn't say how. How may I use an add-on that in version 40.0.2 Mozilla has disabled for being "unverified"?

Mozilla at https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox?as=u says that I "can still install [an] unverified add-on at [my] own risk"--but it doesn't say how. How may I use an add-on that in version 40.0.2 Mozilla has disabled for being "unverified"?

Chosen solution

Sounds like a glitch in the Add-ons page if the extension is actually enabled but shows as disabled. I have no idea what could cause that.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Citrix Online App Detector Plugin
  • Google Update
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

jscher2000
  • Top 10 Contributor
6065 solutions 49817 answers

I realize this is confusing.

In the future, Firefox will refuse to run unsigned extensions. In other words, if Mozilla has not signed the extension, Firefox will auto-disable it. This will start in Firefox 41.

The first step being taken in Firefox 40 is simply to warn you that you have some unsigned extensions so you can check for updates and/or inform the publisher about this impending problem. This does not stop the extensions from running.

If those extensions are disabled or broken, there probably is a different problem. Could you mention which extensions are not working?

I realize this is confusing. ''In the future, ''Firefox will refuse to run unsigned extensions. In other words, if Mozilla has not signed the extension, Firefox will auto-disable it. This will start in Firefox 41. The first step being taken in Firefox 40 is simply to warn you that you have some unsigned extensions so you can check for updates and/or inform the publisher about this impending problem. This does not stop the extensions from running. If those extensions are disabled or broken, there probably is a different problem. Could you mention which extensions are not working?

Question owner

Many thanks, jscher. Let me explain the very confusing situation, and perhaps you can shed some light on it.

Two of my extensions are currently marked, "could not be verified for use in Firefox and has been disabled." These are Roboform Toolbar and WordWeb.

There seems to be no issue with Roboform, as I never use its toolbar and its new version works just fine on Firefox without the toolbar. However, WordWeb, which is designed to work within the browser and elsewhere, also, strangely, works fine in Firefox, notwithstanding the error message stating it's been disabled.

I installed neither of the products as Firefox extensions. After installation they just appeared as Firefox extensions--and now, as I mentioned, Mozilla claims they are disabled.

It seems that RF works because I updated it. But I did not update WordWeb. My only guess is that perhaps it updated itself after Firefox disabled it. What do you think?

Many thanks, jscher. Let me explain the very confusing situation, and perhaps you can shed some light on it. Two of my extensions are currently marked, "could not be verified for use in Firefox and has been disabled." These are Roboform Toolbar and WordWeb. There seems to be no issue with Roboform, as I never use its toolbar and its new version works just fine on Firefox without the toolbar. However, WordWeb, which is designed to work within the browser and elsewhere, also, strangely, works fine in Firefox, notwithstanding the error message stating it's been disabled. I installed neither of the products as Firefox extensions. After installation they just appeared as Firefox extensions--and now, as I mentioned, Mozilla claims they are disabled. It seems that RF works because I updated it. But I did not update WordWeb. My only guess is that perhaps it updated itself after Firefox disabled it. What do you think?
jscher2000
  • Top 10 Contributor
6065 solutions 49817 answers

Disabled extensions should be grouped at the bottom, against a gray background, and not run at all. If the extensions are in the main list, not on a gray background, and show a "Disable" button, then they are still enabled. So that would explain why they function. In Firefox 40, the unverified warning is just a warning; in Firefox 41, it turns into a block.

I'm not familiar with WordWeb, but Firefox does check for extension updates from time to time so it certainly is possible that it was updated recently.

Disabled extensions should be grouped at the bottom, against a gray background, and not run at all. If the extensions are in the main list, not on a gray background, and show a "Disable" button, then they are still enabled. So that would explain why they function. In Firefox 40, the unverified warning is ''just a warning''; in Firefox 41, it turns into a block. I'm not familiar with WordWeb, but Firefox does check for extension updates from time to time so it certainly is possible that it was updated recently.

Question owner

Thanks again, jscher.

As you probably realize, I use Firefox ver. 40, not 41--yet the two extensions I mentioned have according to Mozilla now been disabled. I do not see anything that could be construed as only a warning. These two are shown only in the Disabled group (following the main group). None of my disabled add-ons (or any other add-ons) shows a gray background. These two show a pink background. The "disabled" add-ons, including these two, are distinguished by text in gray instead of black.

Thanks again, jscher. As you probably realize, I use Firefox ver. 40, not 41--yet the two extensions I mentioned have according to Mozilla now been disabled. I do not see anything that could be construed as only a warning. These two are shown only in the Disabled group (following the main group). None of my disabled add-ons (or any other add-ons) shows a gray background. These two show a pink background. The "disabled" add-ons, including these two, are distinguished by text in gray instead of black.
jscher2000
  • Top 10 Contributor
6065 solutions 49817 answers

I see what you mean about the background, I have diagonal stripes. I don't know why they are disabled. If you try the Enable button, can they be re-enabled?

I see what you mean about the background, I have diagonal stripes. I don't know why they are disabled. If you try the Enable button, can they be re-enabled?

Question owner

There is no Enable button for either of these two add-ons.

There is no Enable button for either of these two add-ons.
jscher2000
  • Top 10 Contributor
6065 solutions 49817 answers

Helpful Reply

That is not the default behavior...

Could you check to make sure the signature block has not been turned on?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste xpi and pause while the list is filtered

(3) If the xpinstall.signatures.required preference is bolded and user set to true, double-click it to switch it to false

If the preference indicates it is locked, we need to investigate an autoconfig file. If it changes back to true at the next startup, we need to investigate a possible user.js file.


If that preference is set to its default, the other reason to not see an Enable button would usually be that the extension is internally coded not to run in Firefox 40. Extension authors can set a maximum version number and if it is marked for strict enforcement or if the extension contains binary (compiled) components, then Firefox will disable the extension in versions newer than the specified max.

But in researching the RoboForm and WordWeb extensions, I do not think they limit the version number.

That is not the default behavior... Could you check to make sure the signature block has not been turned on? (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''xpi''' and pause while the list is filtered (3) If the '''xpinstall.signatures.required''' preference is bolded and user set to true, double-click it to switch it to false ''If the preference indicates it is locked, we need to investigate an autoconfig file. If it changes back to true at the next startup, we need to investigate a possible user.js file.'' ---- If that preference is set to its default, the other reason to not see an Enable button would usually be that the extension is internally coded not to run in Firefox 40. Extension authors can set a maximum version number and if it is marked for strict enforcement or if the extension contains binary (compiled) components, then Firefox will disable the extension in versions newer than the specified max. But in researching the RoboForm and WordWeb extensions, I do not think they limit the version number.

Question owner

This remains a mystery but it is not worth more time to explore--since (as mentioned) I'm fully able to use both programs even though "disabled" by Mozilla. I consider this issue closed although not solved.

This remains a mystery but it is not worth more time to explore--since (as mentioned) I'm fully able to use both programs even though "disabled" by Mozilla. I consider this issue closed although not solved.
jscher2000
  • Top 10 Contributor
6065 solutions 49817 answers

Chosen Solution

Sounds like a glitch in the Add-ons page if the extension is actually enabled but shows as disabled. I have no idea what could cause that.

Sounds like a glitch in the Add-ons page if the extension is actually enabled but shows as disabled. I have no idea what could cause that.
RemySecor 0 solutions 10 answers

Helpful Reply

Same problem when I tried to update from Firefox 33 to Firefox 40 but this is an even bigger problem for me.

I depend heavily on the addon Interclue, which hasn't been updated since 2011. I have no way to contact the developer and there is no equivalent addon.

Quite frankly, I'm willing to stay on Firefox33 forever if that's what I have to do to continue using this addon.

I think Mozilla should let users take the risk. If an addon doesn't work or crashes Firefox, all the user has to do is disable it or remove it. Firefox should NOT make the decision for us.

Same problem when I tried to update from Firefox 33 to Firefox 40 but this is an even bigger problem for me. I depend heavily on the addon Interclue, which hasn't been updated since 2011. I have no way to contact the developer and there is no equivalent addon. Quite frankly, I'm willing to stay on Firefox33 forever if that's what I have to do to continue using this addon. I think Mozilla should let users take the risk. If an addon doesn't work or crashes Firefox, all the user has to do is disable it or remove it. Firefox should NOT make the decision for us.
jscher2000
  • Top 10 Contributor
6065 solutions 49817 answers

Hi RemySecor, what is Firefox saying about "Interclue" on the Add-ons page? Verification should not be a problem if you have the version from the Add-ons site, it is signed: https://addons.mozilla.org/firefox/addon/interclue/

To compare your version, you can click the "More" link for the extension on the Add-ons page.

I installed the version from the Add-ons site and it seems to work on this page in Firefox 41. It's pretty incredible, actually. Sometimes the icon is missing (I just get a blue square); I don't know the reason for that.

If you have some other issue with Interclue not working, do you want to start a new thread about it? There's an "Ask a Question" link at the top of forum pages.

Hi RemySecor, what is Firefox saying about "Interclue" on the Add-ons page? Verification should not be a problem if you have the version from the Add-ons site, it is signed: https://addons.mozilla.org/firefox/addon/interclue/ To compare your version, you can click the "More" link for the extension on the Add-ons page. I installed the version from the Add-ons site and it seems to work on this page in Firefox 41. It's pretty incredible, actually. Sometimes the icon is missing (I just get a blue square); I don't know the reason for that. If you have some other issue with Interclue not working, do you want to start a new thread about it? There's an "Ask a Question" link at the top of forum pages.

Modified by jscher2000

RemySecor 0 solutions 10 answers

Thank you.

I think I know what may have happened. I test a new version of FIrefox by building a copy of my current profile and renaming it. But I forget to update all the addons before I did this.

I'll give 41R2 another try and start a new message if interclue still doesn't work.

Interclue and AutoCopy are so fundamental to my work that I don't upgrade unless I can confirm both will work. Interclue's default implementation (where you get the icon) didn't work in versions 34-36 and this is the first chance I've had to try a newer version.

If it still fails, I'll start a new thread. (The basic extension hasn't been updated since 2011 - and I've been unable to contact the developer - so there are always some links it won't work on, whether because of the Firefox version or a change in the web site design. But not having to load a whole new page on my bargain basement DSL has been a lifesaver.)

Thank you for responding so quickly.

Thank you. I think I know what may have happened. I test a new version of FIrefox by building a copy of my current profile and renaming it. But I forget to update all the addons before I did this. I'll give 41R2 another try and start a new message if interclue still doesn't work. Interclue and AutoCopy are so fundamental to my work that I don't upgrade unless I can confirm both will work. Interclue's default implementation (where you get the icon) didn't work in versions 34-36 and this is the first chance I've had to try a newer version. If it still fails, I'll start a new thread. (The basic extension hasn't been updated since 2011 - and I've been unable to contact the developer - so there are always some links it won't work on, whether because of the Firefox version or a change in the web site design. But not having to load a whole new page on my bargain basement DSL has been a lifesaver.) Thank you for responding so quickly.
RemySecor 0 solutions 10 answers

I was able to get rid of the "unverified" by updating the extension. But the lack of that little icon next to links is a major flaw. There's an option in Interclue that doesn't rely on the the icon but it is much less useful.

So, unfortunately, I'm stuck with Firefox 33 because Interclue doesn't work as it should in any version from Firefox 34 - 41.0.2.

I was able to get rid of the "unverified" by updating the extension. But the lack of that little icon next to links is a major flaw. There's an option in Interclue that doesn't rely on the the icon but it is much less useful. So, unfortunately, I'm stuck with Firefox 33 because Interclue doesn't work as it should in any version from Firefox 34 - 41.0.2.
jscher2000
  • Top 10 Contributor
6065 solutions 49817 answers

RemySecor said

But the lack of that little icon next to links is a major flaw. There's an option in Interclue that doesn't rely on the the icon but it is much less useful.

Which icon is missing for you? I have attached a couple screen shots with some examples of what I see.

''RemySecor [[#answer-799424|said]]'' <blockquote> But the lack of that little icon next to links is a major flaw. There's an option in Interclue that doesn't rely on the the icon but it is much less useful. </blockquote> Which icon is missing for you? I have attached a couple screen shots with some examples of what I see.
itanimulli 0 solutions 5 answers

Hi I have an unverified Add on, saying proceed with caution. I want to run it and did run it in the past. Why do you prevent this option? You should implement it for advanced users to decide to run or not an add on. I read the help page for add ons and updates does not solve the problem. Give a solution to run an unverified add on, please?

Hi I have an unverified Add on, saying proceed with caution. I want to run it and did run it in the past. Why do you prevent this option? You should implement it for advanced users to decide to run or not an add on. I read the help page for add ons and updates does not solve the problem. Give a solution to run an unverified add on, please?
the-edmeister
  • Moderator
5030 solutions 37073 answers

Yesmail Email Tracking is enabled in that screenshot. But unless that extension is updated soon, it will be disabled in Firefox 43 which is due to be released on Dec 15. There will be a override pref available for Firefox 43, but not beyond that version.

Beyond that advanced users will need to use an unbranded version of 'Firefox' to be able to use unverified extensions or use the Developer Edition version or the Nightly version.

Yesmail Email Tracking '''is''' enabled in that screenshot. But unless that extension is updated soon, it will be disabled in Firefox 43 which is due to be released on Dec 15. ''There will be a override pref available for Firefox 43, but not beyond that version.'' Beyond that advanced users will need to use an unbranded version of 'Firefox' to be able to use unverified extensions or use the Developer Edition version or the Nightly version.
itanimulli 0 solutions 5 answers

10x for the swift response. Anyhow I tried the developer's build .However the Add on does not work there. Walk me through the steps to enable it in the Developer's build, please?

10x for the swift response. Anyhow I tried the developer's build .However the Add on does not work there. Walk me through the steps to enable it in the Developer's build, please?

Modified by itanimulli

cor-el
  • Top 10 Contributor
  • Moderator
15018 solutions 136319 answers

Does the extension show as enabled?

If the extension is enabled, but doesn't work then the extension isn't compatible and its developer needs to update the extension.

You can check the Browser Console (Firefox menu button or Tools > Web Developer) immediately after startup to see if there are error messages related to this extension.

Does the extension show as enabled? If the extension is enabled, but doesn't work then the extension isn't compatible and its developer needs to update the extension. You can check the Browser Console (Firefox menu button or Tools > Web Developer) immediately after startup to see if there are error messages related to this extension. *https://developer.mozilla.org/Tools/Browser_Console
jscher2000
  • Top 10 Contributor
6065 solutions 49817 answers

Hi itanimulli, check this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste xpin and pause while the list is filtered

(3) If the xpinstall.signatures.required preference has a value of true then double-click it to switch it to false. If that preference does not exist, then it is not possible to run unsigned extensions in the version you're running.

Hi itanimulli, check this: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''xpin''' and pause while the list is filtered (3) If the '''xpinstall.signatures.required''' preference has a value of '''true''' then double-click it to switch it to false. If that preference does not exist, then it is not possible to run unsigned extensions in the version you're running.
cor-el
  • Top 10 Contributor
  • Moderator
15018 solutions 136319 answers

Note that any modification made to a signed extension will break this extension. Some security software may try to open XPI files for inspection and cause issues.

Note that any modification made to a signed extension will break this extension. Some security software may try to open XPI files for inspection and cause issues.