Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Skype click to call works in Chrome but not Firefox

  • 9 replies
  • 12 have this problem
  • 100 views
  • Last reply by bigjon000

more options

Skype v 7.7.103, C2C v 7.4.9058, FF v40 This question has been asked enough now for an answer to available. Time to dump FF and go to Chrome?

Chosen solution

What problems are you having with the Skype extension?

Just to run through the usual:

(1) Does it show on the Add-ons page and can it be enabled? You can open that using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then check the list on the right. Disabled extensions cluster at the bottom.

Note: It's normal in Firefox 40 to see a message that the extension is not verified.

(2) Does its button need to be added to the toolbar? You can use the Customize tab to check for it if it's not in the expected location. See: Customize Firefox controls, buttons and toolbars.

Are there other issues? I don't use this extension myself.

Read this answer in context 👍 1

All Replies (9)

more options

Chosen Solution

What problems are you having with the Skype extension?

Just to run through the usual:

(1) Does it show on the Add-ons page and can it be enabled? You can open that using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then check the list on the right. Disabled extensions cluster at the bottom.

Note: It's normal in Firefox 40 to see a message that the extension is not verified.

(2) Does its button need to be added to the toolbar? You can use the Customize tab to check for it if it's not in the expected location. See: Customize Firefox controls, buttons and toolbars.

Are there other issues? I don't use this extension myself.

more options

Hi jscher2000. Thank you for your reply, 1. Skype Click to Call 7.4.0.9058 shows in the extensions and is enabled. Turn number highlighting on is ticked. 2. Does a C2C button need to be added to the toolbar? I have visited a site in both FF and Chrome; the same c2c 'phone numbers are highlighted in Chrome but not FF. This is the problem. BTW, your advice that FF 40 cannot verify some programs concerns me especially as one of those programs is my security software.

more options

bigjon000 said

I have visited a site in both FF and Chrome; the same c2c 'phone numbers are highlighted in Chrome but not FF. This is the problem.

Well, that seems like a serious problem. If you right-click the number, has anything Skype-ish been added to the context menu?

Also, in case it's a settings issue: does your Firefox normally display highlighting, or does it seem to be missing a lot of background colors? That can occur with "high contrast" Windows themes and in that case you may need to switch a color setting here:

"3-bar" menu button (or Tools menu) > Options > Content > "Colors" button

Under "Override the colors specified by the page with my selections above" change the selector to "Never" and OK the change. Any difference?

more options

Regarding the not verified message, in the future, Firefox will refuse to run unsigned extensions. However, the first step being taken in Firefox 40 is to warn you that you have some so you can check for updates and/or inform the publisher about this impending problem.

I'm sure the companies that regularly update their security software are aware of this change. What they need to do is submit their add-ons to Mozilla for review and signing some time before Firefox 41 is released and presumably they will.

If they don't, please complain to them!

more options

I have set the 'override the colors specified by the page with my selections above' to 'never' but the results to c2c are the same. My FF, Skype and Click to Call are the latest versions. Do I assume that you do not have this issue?

more options

I am also using W10

more options

bigjon000 said

Do I assume that you do not have this issue?

I don't use Skype, so in that sense, I don't have this issue! Hopefully someone who has it installed can provide more hand-on feedback.

more options

Okay, I installed Skype Click to Call, same version as you, and it doesn't work for me on Firefox 40 + Windows 10.

When I looked inside the extension, I saw that it still used the widget module, which was removed in Firefox 40. That only relates to the options button on the toolbar, so at first it seemed irrelevant, but in case it was fatal I decided to try commenting out that part of the code. This was a multi-step process:

(1) Using 7-zip, unzip the extension file to a new "Skype-c2c" folder in Documents.

Extension file location and name:

C:\Program Files (x86)\Mozilla Firefox\browser\extensions

File: {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}.xpi

(2) In the editable location, drill down to main.js and open it in a text editor

C:\Users\username\Documents\Skype-c2c\resources\skype_ff_extension\lib

(3) Search for 'widget and make these edits:

Add // before line 14:

// var widgets = require("sdk/widget");

Add /* before and */ after lines 155-160

/*
var c2c_options_button = widgets.Widget({
  id: "c2c-options-button",
  label: "Skype Click to Call settings",
  contentURL: data.url("c2c_16x16.png"),
  panel: c2c_options_panel
});
*/

(4) Save the file, then zip up the contents of the "Skype-c2c" folder (not including the folder itself) into a "Skype-c2c.xpi" file.

The following steps required administrator approval:

(5) Copy the "Skype-c2c.xpi" file to C:\Program Files (x86)\Mozilla Firefox\browser\extensions folder

(6) Rename {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}.xpi to {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}.xpi.old

(7) Rename "Skype-c2c.xpi" to {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}.xpi

(8) Restart Firefox and test

Results shown in the attached screenshot. I think it's working now.

So Microsoft could fix this in less time than it took to write this post.

more options

Thank you jscher200, c2c in FF 40 now works a treat. Your instructions were full and clear and easy to follow. If I could find a kudos button I would click it. bigjon000