X
Tap here to go to the mobile version of the site.

Support Forum

One website appears as text only, not html, links do not work. No such problem with Chrome or Internet Explorer.

Posted

On two laptops running Firefox 39.0 I cannot access the website tripadvisor.com. I only get the same text screen all the time where no links work, not html. Screen shot enclosed. This problem does not occur with Chrome or Internet Explorer.

On two laptops running Firefox 39.0 I cannot access the website tripadvisor.com. I only get the same text screen all the time where no links work, not html. Screen shot enclosed. This problem does not occur with Chrome or Internet Explorer.

Chosen solution

Sorry Kenny. Let's break that down.

Firefox's Safe Mode disables extension, so it's worth reviewing those to see whether any could be modifying how Firefox displays pages. I mentioned how to get to that section of the Add-ons page in this post: https://support.mozilla.org/questions/1075685#answer-763481

If you aren't sure about whether your extensions might be the problem, you can disable the ones that aren't essential and see whether that makes a difference.

Or you could copy/paste a list of your extensions from the support information page. To open that, use either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Extensions heading, and you can select and copy the table below it. It will look a little messy when pasted, but don't worry, we're used to that.


cor-el mentioned a userContent.css file. That's a hand-crafted optional settings file to modify how sites appear in Firefox. Unless you created it yourself, you probably don't have it, but you can check by opening your profile (settings) folder.

To do that, start on the support information page (see above steps). In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Do you see a folder named chrome? If not, you don't have a userContent.css file.

If you do see a folder named chrome, double-click into it and see what you find there.


cor-el also mentioned the Forget About This Site feature. Sometimes Firefox stores cache entries, cookies, or site-specific preferences that are difficult to remove in other ways. Forget About This Site scrubs everything Firefox has stored about the site from history to saved passwords and bookmarks. This sometimes helps with problems that have no other explanation.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Citrix Online App Detector Plugin
  • GEPlugin
  • Google Update
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.9.149
  • 5.1.40416.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

Jhp512 5 solutions 28 answers

Helpful Reply

Hello,

Your screenshots are not appearing. Can you please resend them?

Thank you

Hello, Your screenshots are not appearing. Can you please resend them? Thank you
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

Helpful Reply

Are you accessing this site via an open HTTP connection or via a secure HTTPS connection>


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Are you accessing this site via an open HTTP connection or via a secure HTTPS connection> ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Tried reloading page, no change. Removed cookies: no change Cleared Cache: no change disabled all extensions: no change Appearance is default. tried uploading screenshot: would not upload. Where do I save it first? Accessing site via http only.

The website WORKED in safe mode on both computers. Now how do I figure out what is wrong?

Tried reloading page, no change. Removed cookies: no change Cleared Cache: no change disabled all extensions: no change Appearance is default. tried uploading screenshot: would not upload. Where do I save it first? Accessing site via http only. The website WORKED in safe mode on both computers. Now how do I figure out what is wrong?
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

Quote: The website WORKED in safe mode on both computers

Is this Firefox Safe Mode or booting Windows in Safe Mode?


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • default toolbar layout is used
  • JavaScript JIT compilers are disabled
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

If this is about Windows Safe Mode then your security software might be causing this problem.

Quote: ''The website WORKED in safe mode on both computers'' Is this Firefox Safe Mode or booting Windows in Safe Mode? ---- In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder in profile folder) *default toolbar layout is used *JavaScript JIT compilers are disabled *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected ---- If this is about Windows Safe Mode then your security software might be causing this problem.
jscher2000
  • Top 10 Contributor
8773 solutions 71727 answers

A lot of TripAdvisor content is pulled from other servers. For example:

Can your Firefox access those addresses?

For some reason, some users seem to have issues with host names containing "cdn". Not sure what causes that, but any extension that filters unwanted content would be a logical candidate.

You can review, disable, often configure and remove extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then check out the list on the right side. All extensions are optional, none come with Firefox.

A lot of TripAdvisor content is pulled from other servers. For example: * Style sheet: http://static.tacdn.com/css2/ta-cart-nav-v2278828519a.css (if this loads for you, it's normal to see a wall of text) * Images: http://media-cdn.tripadvisor.com/media/photo-s/04/2b/36/9e/hell-s-gate-national.jpg Can your Firefox access those addresses? For some reason, some users seem to have issues with host names containing "cdn". Not sure what causes that, but any extension that filters unwanted content would be a logical candidate. You can review, disable, often configure and remove extensions on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then check out the list on the right side. All extensions are optional, none come with Firefox.

Question owner

The site worked in Firefox Safe Mode. I did not do anything with Windows safe mode. Firefox displayed the two links as: 1. endless text 2. photo of giraffe and bicycle

Still... help!

The site worked in Firefox Safe Mode. I did not do anything with Windows safe mode. Firefox displayed the two links as: 1. endless text 2. photo of giraffe and bicycle Still... help!
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

The two links in the reply from jscher2000 work for me as well.

Do you have a userContent.css file in the chrome folder in the Firefox profile folder?


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

The two links in the reply from jscher2000 work for me as well. Do you have a userContent.css file in the chrome folder in the Firefox profile folder? *http://kb.mozillazine.org/userContent.css ---- You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page. Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. If you revisit a 'forgotten' website then data from that website will be saved once again.

Question owner

Not sure what you suggest I do: it's incomprehensible to me!

Not sure what you suggest I do: it's incomprehensible to me!
jscher2000
  • Top 10 Contributor
8773 solutions 71727 answers

Chosen Solution

Sorry Kenny. Let's break that down.

Firefox's Safe Mode disables extension, so it's worth reviewing those to see whether any could be modifying how Firefox displays pages. I mentioned how to get to that section of the Add-ons page in this post: https://support.mozilla.org/questions/1075685#answer-763481

If you aren't sure about whether your extensions might be the problem, you can disable the ones that aren't essential and see whether that makes a difference.

Or you could copy/paste a list of your extensions from the support information page. To open that, use either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Extensions heading, and you can select and copy the table below it. It will look a little messy when pasted, but don't worry, we're used to that.


cor-el mentioned a userContent.css file. That's a hand-crafted optional settings file to modify how sites appear in Firefox. Unless you created it yourself, you probably don't have it, but you can check by opening your profile (settings) folder.

To do that, start on the support information page (see above steps). In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Do you see a folder named chrome? If not, you don't have a userContent.css file.

If you do see a folder named chrome, double-click into it and see what you find there.


cor-el also mentioned the Forget About This Site feature. Sometimes Firefox stores cache entries, cookies, or site-specific preferences that are difficult to remove in other ways. Forget About This Site scrubs everything Firefox has stored about the site from history to saved passwords and bookmarks. This sometimes helps with problems that have no other explanation.

Sorry Kenny. Let's break that down. Firefox's Safe Mode disables extension, so it's worth reviewing those to see whether any could be modifying how Firefox displays pages. I mentioned how to get to that section of the Add-ons page in this post: https://support.mozilla.org/questions/1075685#answer-763481 If you aren't sure about whether your extensions might be the problem, you can disable the ones that aren't essential and see whether that makes a difference. Or you could copy/paste a list of your extensions from the support information page. To open that, use either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter Scroll down to the Extensions heading, and you can select and copy the table below it. It will look a little messy when pasted, but don't worry, we're used to that. ---- cor-el mentioned a userContent.css file. That's a hand-crafted optional settings file to modify how sites appear in Firefox. Unless you created it yourself, you probably don't have it, but you can check by opening your profile (settings) folder. To do that, start on the support information page (see above steps). In the ''first'' table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Do you see a folder named '''chrome'''? If not, you don't have a userContent.css file. If you do see a folder named chrome, double-click into it and see what you find there. ---- cor-el also mentioned the Forget About This Site feature. Sometimes Firefox stores cache entries, cookies, or site-specific preferences that are difficult to remove in other ways. Forget About This Site scrubs everything Firefox has stored about the site from history to saved passwords and bookmarks. This sometimes helps with problems that have no other explanation.

Question owner

Here is the screenshot. I will go over your reply bit by bit.

Here is the screenshot. I will go over your reply bit by bit.

Question owner

From troubleshooting information, extensions:

iCloud Bookmarks 1.4.14.1-signed true firefoxdav@icloud.com Privacy Badger Firefox 0.2.6 true jid1-MnnxcxisBPnSXQ@jetpack SSL Version Control 0.4.1-signed true jid1-ZM3BerwS6FsQAg@jetpack

No "Chrome" folder.

From troubleshooting information, extensions: iCloud Bookmarks 1.4.14.1-signed true firefoxdav@icloud.com Privacy Badger Firefox 0.2.6 true jid1-MnnxcxisBPnSXQ@jetpack SSL Version Control 0.4.1-signed true jid1-ZM3BerwS6FsQAg@jetpack No "Chrome" folder.

Question owner

I disabled "Privacy Badger" and the website worked! Now I changed the settings of this extension so it is always disabled for this website.

Thank you all for all your help, it looks like the problem is solved!

I disabled "Privacy Badger" and the website worked! Now I changed the settings of this extension so it is always disabled for this website. Thank you all for all your help, it looks like the problem is solved!
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

You wrote above: disabled all extensions: no change

Didn't disabling "Privacy Badger" work that time?

Note that you might have to reload web pages and bypass the cache to refresh all files in cases like this.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)
You wrote above: ''disabled all extensions: no change'' Didn't disabling "Privacy Badger" work that time? Note that you might have to reload web pages and bypass the cache to refresh all files in cases like this. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac)

Question owner

I mis-spoke: I disabled plug-ins, not extensions.

Thank you!

I mis-spoke: I disabled plug-ins, not extensions. Thank you!