Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This connection is untrusted Error code: sec_error_unknown_issuer

  • 5 replies
  • 36 have this problem
  • 4853 views
  • Last reply by ruki114

more options

Its the this connection is untrusted error, I recently installed windows 10 however my account is not connected to any others and I still cannot connect to google.com when firewall is down and disabled. however I can connect to google.cm I have tried deleting cert.db along with secmod, didnt work uninstalled multiple times and have done a refresh already. I also cannot get into yahoo or most other .com sites like yahoo. I also can't ping my laptop from my modem when I have my windows firewall up but with it down the pings go through. I honestly have no idea what's going on and I can access the same sites when I am accessing this computer which is also using firefox and win10.

Chosen solution

hi ruki114, sorry that this didn't work - this wasn't a tradtional link but should have opened a certificate installation window in your browser. alternatively you could have tried the manual steps described at https://support.microsoft.com/en-us/kb/2965142 in the section about firefox.

if you don't want to use that ms family feature anyway, please doublecheck that you have turned it off for your account: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

if this also does not work, could you tell us which anti-virus software you are using?

Read this answer in context 👍 1

All Replies (5)

more options

hi ruki114, does this happen in an account that is restricted by ms family safety settings? this would result in ms intercepting secure connections to some common sites like google, facebook, youtube and others. for this to work in firefox, you'd first have to install the certificate of ms family safety into the browser's trust store. click on this link, check the box to Trust this CA to identify web sites & confirm the change.

Modified by philipp

more options

thanks for answering philipp but the link is broken, whats the full url?

more options

Also I do not have ms family security settings enabled for my account, this is the only one in the family.

more options

Chosen Solution

hi ruki114, sorry that this didn't work - this wasn't a tradtional link but should have opened a certificate installation window in your browser. alternatively you could have tried the manual steps described at https://support.microsoft.com/en-us/kb/2965142 in the section about firefox.

if you don't want to use that ms family feature anyway, please doublecheck that you have turned it off for your account: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

if this also does not work, could you tell us which anti-virus software you are using?

more options

Thanks for the solution, it was the certificate not being seen. Did not know that firefox used a diff certificate store.