Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how to clear history without clearing active logins?

  • 3 replies
  • 8 have this problem
  • 1542 views
  • Last reply by cor-el

more options

I never used to have this problem and I have refreshed Firefox numerous times but continue to have the problem. Whenever I clear history (everything BUT the active logins), it clears my active logins. I have to clear cache and cookies quite often due to my older laptop and constant streaming on Netflix, Hulu, and TWC. Is there a way I can correct this issue?

Chosen solution

A detail like a website remembering you (log you in automatically) is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history; Always use Private Browsing mode).

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted.

You can use this button to go to the current Firefox profile folder:

Read this answer in context 👍 0

All Replies (3)

more options

Active logins usually apply to web servers that use basic authorization to login via a pop-up window. In other cases a detail like a website remembering you (log you in automatically) is stored in a cookie.

If you remove the cookies from a website then that makes the website forget about you.

You can use these steps to make a website recognize and remember you:

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.
  • Clearing Cookies will remove all specified (selected) cookies including cookies with an allow exception that you want to keep.
more options

I have this problem too!

Under Clear History I have UNCHECKED everything (see uploaded image)

logged into my Home web page, QUIT Firefox, opened Home page again and have to log in again. OK, I CHECKED ALL Under Clear History option, same result. I think  this started with upgrade to Mac OS Yosemite. This doesn't happen when using other browsers! 

Anyone have a fix??

more options

Chosen Solution

A detail like a website remembering you (log you in automatically) is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history; Always use Private Browsing mode).

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted.

You can use this button to go to the current Firefox profile folder: