Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How to set "ask where to save"

  • 9 replies
  • 5 have this problem
  • 7715 views
  • Last reply by Murtu

more options

Please give EASY instructions on how to insure that Firefox 39 will ask where to put downloads. Have tried changing settings.

THANKS in advance. LTSilver

Chosen solution

The classical way is to select Always ask me where to save files in the Options tab. To open it, click on the menu button upper right and select Options, the corresponding feature is in the General panel, section Downloads.

Did you do that?

Read this answer in context 👍 2

All Replies (9)

more options

Chosen Solution

The classical way is to select Always ask me where to save files in the Options tab. To open it, click on the menu button upper right and select Options, the corresponding feature is in the General panel, section Downloads.

Did you do that?

more options

Yes! I did. I wasn't working and after I posted my question, I changed preference and changed again back to "ALWAYS ASK ME..."

Seems to be working fine now.

THANKS!! LT

more options

Great!

To be sure it is definitely ok, you could shut down and start again your computer. There were some cases where parameter changes were not saved…

more options

Thank you. Much appreciated. LT

more options

This use to work but now it just downloads into the default Download folder. I even closed Firefox, deleted the mimeTypes.rdf file but after restarting FireFox it still does not ask.

more options

Can you check the value for browser.download.useDownloadDir in about:config?

  1. Enter about:config in the address bar
  2. Accept the warning
  3. Find the line browser.download.useDownloadDir

If the setting corresponding to always ask where to download is right, you should see false.

more options

Hi Murtu

What operating system do you use?

The OP (thread owner) was using a Mac.

Could you please start a new thread for your question since this is an older thread from July and Firefox 39?

Then you can provide more information like your operating system and installed extensions and installed plugins.

In case of crashes also please add some recent crash IDs that start with a "bp-" prefix.


You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can rename (or delete) the content-prefs.sqlite file (content-prefs.sqlite.old) in the Firefox profile folder to reset website specific data.

more options

Deleted the mimeTypes.rdf file rebooted again and it worked this time.

more options

Deleted the mimeTypes.rdf file rebooted again and it worked this time.