X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

"Secure Connection failed" after update to firefox 39

Posted

Hi, After update of firefox to version 39 i am unable to pay online bill, shopping bill etc and got this message "Secure Connection Failed

An error occurred during a connection to acs.onlinesbi.com. SSL received a weak ephemeral Diffie-Hellman key in Server Key Exchange handshake message. (Error code: ssl_error_weak_server_ephemeral_dh_key)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Report this error " Please help me how to fix this problem.Thanks.

Hi, After update of firefox to version 39 i am unable to pay online bill, shopping bill etc and got this message "Secure Connection Failed An error occurred during a connection to acs.onlinesbi.com. SSL received a weak ephemeral Diffie-Hellman key in Server Key Exchange handshake message. (Error code: ssl_error_weak_server_ephemeral_dh_key) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. Report this error " Please help me how to fix this problem.Thanks.

Chosen solution

This indicates that the site is defaulting to an obsolete encryption cipher which is vulnerable to the "Logjam" attack that was in the news earlier this year.

You can disable these old ciphers in Firefox to try to force the site to up its game. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste dhe and pause while the list is filtered

(3) Double-click the security.ssl3.dhe_rsa_aes_128_sha preference to switch it from true to false (disable Firefox from using this cipher)

(4) Double-click the security.ssl3.dhe_rsa_aes_256_sha preference to switch it from true to false (disable Firefox from using this cipher)

Then try your payment site again. Any improvement?

Read this answer in context 199

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.11
  • Facebook Video Calling Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • Shockwave Flash 18.0 r0
  • VLC media player Web Plugin 2.1.3

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

jscher2000
  • Top 10 Contributor
8320 solutions 68114 answers

Chosen Solution

This indicates that the site is defaulting to an obsolete encryption cipher which is vulnerable to the "Logjam" attack that was in the news earlier this year.

You can disable these old ciphers in Firefox to try to force the site to up its game. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste dhe and pause while the list is filtered

(3) Double-click the security.ssl3.dhe_rsa_aes_128_sha preference to switch it from true to false (disable Firefox from using this cipher)

(4) Double-click the security.ssl3.dhe_rsa_aes_256_sha preference to switch it from true to false (disable Firefox from using this cipher)

Then try your payment site again. Any improvement?

This indicates that the site is defaulting to an obsolete encryption cipher which is vulnerable to the "Logjam" attack that was in the news earlier this year. You can disable these old ciphers in Firefox to try to force the site to up its game. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''dhe''' and pause while the list is filtered (3) Double-click the '''security.ssl3.dhe_rsa_aes_128_sha''' preference to switch it from true to false (disable Firefox from using this cipher) (4) Double-click the '''security.ssl3.dhe_rsa_aes_256_sha''' preference to switch it from true to false (disable Firefox from using this cipher) Then try your payment site again. Any improvement?

Helpful Reply

Its working.Thank you very much Sir.

Its working.Thank you very much Sir.
CrazySoul 0 solutions 2 answers

I had exactly this same problem with this browser. now its solved. Thanks jscher2000.

I had exactly this same problem with this browser. now its solved. Thanks jscher2000.
Jonathan_Jaffe 0 solutions 4 answers

attempting to access https://community.landesk.com/support/docs/DOC-39460 I am running FireFox 42.0 Other people can access that site so the problem is my installation

On the above, and more than a few other sites, and I get Secure Connection Failed

I have edited about:config so that

 security.ssl3.dhe_rsa_aes_128_sha 
 security.ssl3.dhe_rsa_aes_256_sha 

are both FALSE. Restarted FireFox

No effect.

There are many security.ssl3 settings including

  security.ssl3.ecdhe_ecdsa_aes_128_sha;true

should I turn something else off?

attempting to access https://community.landesk.com/support/docs/DOC-39460 I am running FireFox 42.0 Other people can access that site so the problem is my installation On the above, and more than a few other sites, and I get Secure Connection Failed I have edited about:config so that security.ssl3.dhe_rsa_aes_128_sha security.ssl3.dhe_rsa_aes_256_sha are both FALSE. Restarted FireFox No effect. There are many security.ssl3 settings including security.ssl3.ecdhe_ecdsa_aes_128_sha;true should I turn something else off?
jscher2000
  • Top 10 Contributor
8320 solutions 68114 answers

Hi Jonathan_Jaffe, could you start a new question? Since your problem is not caused by the Logjam issue, it presumably is something else personal to your configuration.

You can start a new question at the following link. Scroll down past the suggestions to continue submitting your question: https://support.mozilla.org/questions/new/desktop/fix-problems

Please mention any untrusted connection errors you may have seen on other sites, and whether you use any security software known to intercept secure connections for filtering (e.g., Avast, BitDefender, ESET, Kaspersky).

Hi Jonathan_Jaffe, could you start a new question? Since your problem is not caused by the Logjam issue, it presumably is something else personal to your configuration. You can start a new question at the following link. Scroll down past the suggestions to continue submitting your question: https://support.mozilla.org/questions/new/desktop/fix-problems Please mention any untrusted connection errors you may have seen on other sites, and whether you use any security software known to intercept secure connections for filtering (e.g., Avast, BitDefender, ESET, Kaspersky).