Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do I hear fireworks and "When Johnny Comes Marching Home" on flutes everytime I open a new tab and how do I stop it? The 4th of July is long over.

  • 12 replies
  • 2 have this problem
  • 53 views
  • Last reply by jscher2000

more options

I hear fireworks and "When Johnny Comes Marching Home" on flutes every time I open a new tab. It is jarring, intrusive and totally unwelcome. Why is there and how do I stop it? I am using a MacBook Pro.

Modified by hardyjohnson

All Replies (12)

more options

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

By the way, what is your new tab page? That doesn't sound like a feature of Firefox's built-in new tab page...

Here's how you can check/change your new tab page setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Cmd+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If the setting is correct but Firefox ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Cmd+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

more options

You asked what is my tab page. It doesn't make a difference. When I first open Firefox it doesn't happen, but thereafter any time I open a new tab, no matter what it is, the fireworks and flutes start.

jscher2000, I tried what you said and it does stop it, but as soon as I reopen Firefox it is back. I tried the 'preferences that won't save' and didn't quite get the options that it presented. I'm using a MacBook Pro, if that makes any difference. I've run two different malware programs, both of which don't pick up anything. This is making me crazy.

more options

Just opening this thread makes that song play in my mind! But back to you...

So what is in the browser.newtab.url setting before you fix it? Does that give a clue about what might be switching it?

Do you have any security or utility software that might have a home page protection, or browser protection feature, or similar? On Windows, for example, the program Advanced SystemCare will undo your settings changes between sessions. This is to protect you from unwanted changes, but the program can't distinguish wanted from unwanted and undoes ALL changes. Not helpful.

more options

hardyjohnson said

I tried the 'preferences that won't save' and didn't quite get the options that it presented. I'm using a MacBook Pro, if that makes any difference.

You should check for a user.js file. Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show in Finder" button. This should launch a new window listing various files and folders.

Scroll down and look for user.js which is an optional settings file that Firefox uses to override your previous session settings at startup.

If you find one, rename it to something like user.old or you could delete it (assuming you did not create it yourself).

more options

Are you certain it is not a PUP, (unwanted program), that you have unknowingly installed and that it isn't listed under Add-ons/Extensions?

Most who have had this problem have found a foreign program on board. A popular one has been Cool Preview.

If you do find a foreign Extension or Add-on in your list, (if you need help to locate these sing out), then follow these steps to eradicate it:

Remove audio background sounds

more options

jscher2000 said

hardyjohnson said
I tried the 'preferences that won't save' and didn't quite get the options that it presented. I'm using a MacBook Pro, if that makes any difference.

You should check for a user.js file. Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show in Finder" button. This should launch a new window listing various files and folders.

Scroll down and look for user.js which is an optional settings file that Firefox uses to override your previous session settings at startup.

If you find one, rename it to something like user.old or you could delete it (assuming you did not create it yourself).

user.js does not show up there

more options

Dingeroo said

Are you certain it is not a PUP, (unwanted program), that you have unknowingly installed and that it isn't listed under Add-ons/Extensions? Most who have had this problem have found a foreign program on board. A popular one has been Cool Preview. If you do find a foreign Extension or Add-on in your list, (if you need help to locate these sing out), then follow these steps to eradicate it: Remove audio background sounds

I appreciate your response, but the links you provided looks like Windows only stuff and I am using MacBook Pro.

more options

At the bottom of the summary of the five steps is a link for Mac users. Apologies, I should have pointed that out. I have grabbed it for you - the steps for Mac users are set out here.

There are many reports all over the internet of this type of thing being PUP adware which piggy backs into your system on another download. It is actually common and not a new phenomenon. You might like to read some other users' experiences to give you some background.

Try browsing this thread in Mac Support, maybe too this article. Scroll down to about para 11, where it discusses how it embeds in Firefox profiles, (although not discussing the exact same adware, it is the same problem nevertheless). Take a look at this removal guide. Although for Windows users, it is extremely informative concerning the behaviour of the adware and note how the two removal procedures are virtually identical.

I feel confident that if you follow the above steps for removal for Apple Mac, that it will eradicate it for you. Please let us know how you get on for the benefit of other users.

Modified by Dingeroo

more options

A fellow sufferer mentioned the PCH Sweepstakes page as a possible original source of this problem: I am still hearing the music and fireworks even after uninstalling and reinstalling Firefox.

more options

Honestly, mate, it is a well-known adware problem. There was an outbreak in the Mac community a few years ago of this very same and exact audio-playing adware. It can be launched by any advertiser.

The installer is really sneaky and gets past everyone's anti-virus ware, even breaks Apple Mac barriers, while jauntily making its clamour. For this reason standard spyware, malware, anti-virus programs fail to remove it and deliberately designed step by step procedures or removal tools are recommended which can specifically target the audio adware.

The Mac repair tool link I have provided is recommended from this page here, discussing this specific audio malware and specifically designed to remove it. You can see the repair link for Mac's is just above Step 1.

more options

Warning: nerdy post ahead.

Following up a tip in another thread, I tested this problem in a new profile (no extensions, no history). My experiments are not definitive, just one person's experience, but here's what seems to be happening:

  • When you visit http://lotto.pch.com/ Firefox attempts to capture a thumbnail of the page for later use on the new tab page, but fails for some reason.
  • When you visit the new tab page, if the thumbnail is among the ones that constitute your top sites (zoom out by pressing Ctrl- until you can see all 15 contenders), you will see just a gray background instead of an image of the page. Firefox will often (but not every time) load the site in a hidden document, perhaps to trying again to capture the missing thumbnail image.
  • During that process, Firefox fails to mute the music, even though I think it is supposed to mute media in hidden documents.

More comments on my testing are in Bug #1183044 – [New Tab Page] Sound on pinned websites starts playing when just opening a new tab.

Using the "X" on the thumbnail to ban it from the new tab page seems like the best workaround for the moment. That's AndyTampa's tip from this post: https://support.mozilla.org/questions/1067425#answer-755288.