X
Tap here to go to the mobile version of the site.

Support Forum

how to make flash in latest updated firefox activate manually?

Posted

before the latest and greatest firefox update i was able to manually activate flash (to prevent pages from automatically loading them and bogging down memory) by having the shockwave flash addon option as 'ask to activate'.

no longer is that the case. my firefox updated automatically and load flash automatically. no matter if i have 'ask to activate' or even disable the shockwave flash addon or anything else.

i tried using flashblock but it makes loading flash unusable, when i click the button to view it, the swf plays audio of the video but does not show the video/picture. scrolling the video freezes it or makes it buggy and reloading the swf does not work.

long story short, how to make it like before where i click to manually activate the plugin per swf without the use of flashblock because it is useless/worthless.

before the latest and greatest firefox update i was able to manually activate flash (to prevent pages from automatically loading them and bogging down memory) by having the shockwave flash addon option as 'ask to activate'. no longer is that the case. my firefox updated automatically and load flash automatically. no matter if i have 'ask to activate' or even disable the shockwave flash addon or anything else. i tried using flashblock but it makes loading flash unusable, when i click the button to view it, the swf plays audio of the video but does not show the video/picture. scrolling the video freezes it or makes it buggy and reloading the swf does not work. long story short, how to make it like before where i click to manually activate the plugin per swf without the use of flashblock because it is useless/worthless.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • 5.1.40416.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it


Please give more details. When you change the setting, does it stay that way?

'''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it -------------------- Please give more details. When you change the setting, does it stay that way?
Rubin Bhandari 24 solutions 211 answers

https://www.adobe.com/products/flashplayer/distribution3.html You can get latest flash from here.Add to firefox after downloading.

https://www.adobe.com/products/flashplayer/distribution3.html You can get latest flash from here.Add to firefox after downloading.
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Hmm, the Question Details > More System Details next to your post doesn't show Shockwave Flash at all. Are you sure it's not set to "Never Activate"?

Sites may be using other techniques to play video, such as:

  • built-in HTML5 video player (for example, YouTube)
  • another plugin

For the built-in HTML5 player, there is a setting to disable autoplay. However, in Firefox 39, sites can work around this by using a script to send a play command to the script. Still, not all sites do that...

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.autoplay.enabled preference to switch it from true to false.

Hmm, the Question Details > More System Details next to your post doesn't show Shockwave Flash at all. Are you sure it's not set to "Never Activate"? Sites may be using other techniques to play video, such as: * built-in HTML5 video player (for example, YouTube) * another plugin For the built-in HTML5 player, there is a setting to disable autoplay. However, in Firefox 39, sites can work around this by using a script to send a play command to the script. Still, not all sites do that... (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media''' and pause while the list is filtered (3) Double-click the '''media.autoplay.enabled''' preference to switch it from true to false.

Question owner

FredMcD said

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Please give more details. When you change the setting, does it stay that way?

please do not advertise me flashblock. i said flashblock is WORTHLESS.

first screenshot shows example youtube video playing without video (you hear audio) despite flashblock

second screenshot shows you what happens when i click on it to see it (it froze)

third screenshot shows you what happens when i try to scroll it to unfreeze it

refreshing the page does not help and evidently flashblock (the latest and greatest does NOT block flash)

''FredMcD [[#answer-756329|said]]'' <blockquote> '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it -------------------- Please give more details. When you change the setting, does it stay that way? </blockquote> please do not advertise me flashblock. i said flashblock is WORTHLESS. first screenshot shows example youtube video playing without video (you hear audio) despite flashblock second screenshot shows you what happens when i click on it to see it (it froze) third screenshot shows you what happens when i try to scroll it to unfreeze it refreshing the page does not help and evidently flashblock (the latest and greatest does NOT block flash)

Modified by volume

Question owner

Sidharth Bhandari (Rubin) said

https://www.adobe.com/products/flashplayer/distribution3.html You can get latest flash from here.Add to firefox after downloading.

installed this and didnt work. is the current flash version Shockwave Flash 18.0.0.209? i have this disabled/never activate and flash still plays! nevermind ask to activate doesnt work.

''Sidharth Bhandari (Rubin) [[#answer-756330|said]]'' <blockquote> https://www.adobe.com/products/flashplayer/distribution3.html You can get latest flash from here.Add to firefox after downloading. </blockquote> installed this and didnt work. is the current flash version Shockwave Flash 18.0.0.209? i have this disabled/never activate and flash still plays! nevermind ask to activate doesnt work.

Question owner

jscher2000 said

Hmm, the Question Details > More System Details next to your post doesn't show Shockwave Flash at all. Are you sure it's not set to "Never Activate"? Sites may be using other techniques to play video, such as:
  • built-in HTML5 video player (for example, YouTube)
  • another plugin
For the built-in HTML5 player, there is a setting to disable autoplay. However, in Firefox 39, sites can work around this by using a script to send a play command to the script. Still, not all sites do that... (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste media and pause while the list is filtered (3) Double-click the media.autoplay.enabled preference to switch it from true to false.

this was great attempt. unfortunately it didnt work. even when i restarted firefox. i dont think its because some sites including youtube circumvented around to play/display flash. this started happening when firefox updated itself, so its the firefox browser that started this trouble.

''jscher2000 [[#answer-756338|said]]'' <blockquote> Hmm, the Question Details > More System Details next to your post doesn't show Shockwave Flash at all. Are you sure it's not set to "Never Activate"? Sites may be using other techniques to play video, such as: * built-in HTML5 video player (for example, YouTube) * another plugin For the built-in HTML5 player, there is a setting to disable autoplay. However, in Firefox 39, sites can work around this by using a script to send a play command to the script. Still, not all sites do that... (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media''' and pause while the list is filtered (3) Double-click the '''media.autoplay.enabled''' preference to switch it from true to false. </blockquote> this was great attempt. unfortunately it didnt work. even when i restarted firefox. i dont think its because some sites including youtube circumvented around to play/display flash. this started happening when firefox updated itself, so its the firefox browser that started this trouble.
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 solutions 40132 answers

Is this what you have in your screenshots? https://www.youtube.com/watch?v=j7vLnnLt-24

Uses the HTML5 Player for me - not Flash. Check the context menu to see which player is being used.

Is this what you have in your screenshots? https://www.youtube.com/watch?v=j7vLnnLt-24 Uses the HTML5 Player for me - '''not Flash'''. Check the context menu to see which player is being used.
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

If Flash is set to "Never Activate" then Flash should not be used AT ALL, PERIOD, END OF STORY. If you right-click the player you suspect of using Flash, do you get a short menu? Usually the last line of the short menu will indicate the player. For example, I created the attached screen shot on Adobe's page here: https://www.adobe.com/software/flash/about/

I personally use Ask to Activate with Flash v. 18.0.0.209, and all the previous versions for the past year or so, so Firefox 39 should be able to work with that setting for you. Actually, I'm not sure you are using Firefox 39, your post indicated Firefox 38.

If Flash is set to "Never Activate" then Flash should not be used AT ALL, PERIOD, END OF STORY. If you right-click the player you suspect of using Flash, do you get a short menu? Usually the last line of the short menu will indicate the player. For example, I created the attached screen shot on Adobe's page here: https://www.adobe.com/software/flash/about/ I personally use Ask to Activate with Flash v. 18.0.0.209, and all the previous versions for the past year or so, so Firefox 39 should be able to work with that setting for you. Actually, I'm not sure you are using Firefox 39, your post indicated Firefox 38.

Question owner

the-edmeister said

Is this what you have in your screenshots? https://www.youtube.com/watch?v=j7vLnnLt-24 Uses the HTML5 Player for me - not Flash. Check the context menu to see which player is being used.

in that case do you know how to disable html5 player or force them to be manually activate? and not with flashblock since that is a worthless extension created.

the video i used since you pulled its link is a sample video i just pulled off of youtube first thing i see. but its basically the same for every other video. prior to my previous firefox update, i have always been able to click activate flash to manually open each swf on youtube.

i just updated my firefox once more now that i notice (its the latest and greatest now) and its still the same. so this was 2 updates of firefox ago and it was fine.

''the-edmeister [[#answer-756361|said]]'' <blockquote> Is this what you have in your screenshots? https://www.youtube.com/watch?v=j7vLnnLt-24 Uses the HTML5 Player for me - '''not Flash'''. Check the context menu to see which player is being used. </blockquote> in that case do you know how to disable html5 player or force them to be manually activate? and not with flashblock since that is a worthless extension created. the video i used since you pulled its link is a sample video i just pulled off of youtube first thing i see. but its basically the same for every other video. prior to my previous firefox update, i have always been able to click activate flash to manually open each swf on youtube. i just updated my firefox once more now that i notice (its the latest and greatest now) and its still the same. so this was 2 updates of firefox ago and it was fine.

Modified by volume

Question owner

jscher2000 said

If Flash is set to "Never Activate" then Flash should not be used AT ALL, PERIOD, END OF STORY. If you right-click the player you suspect of using Flash, do you get a short menu? Usually the last line of the short menu will indicate the player. For example, I created the attached screen shot on Adobe's page here: https://www.adobe.com/software/flash/about/ I personally use Ask to Activate with Flash v. 18.0.0.209, and all the previous versions for the past year or so, so Firefox 39 should be able to work with that setting for you. Actually, I'm not sure you are using Firefox 39, your post indicated Firefox 38.

i noticed firefox had a new update so i just updated firefox (i now have the latest and greatest firefox) and it remained the same. so that means prior to firefox 38, it was fine and i was able to just simply click activate flash to manually play each single swf found on youtube or elsewhere. and i know this because i was able to do this less than a week ago until firefox prompted me saying theres a new update, i didnt exactly had a option so firefox updated to 38 (not sure if firefox released 2 updates within a week or probably it had been sitting there and when i closed my firefox browser it finally updated).

i think i suspect all this is because 2 firefox updates ago, it didnt support html5 player or anything else. firefox seems to say it will use html5 player or whatever when possible, so how do i make html5 manual or disable it when using firefox 39?

''jscher2000 [[#answer-756362|said]]'' <blockquote> If Flash is set to "Never Activate" then Flash should not be used AT ALL, PERIOD, END OF STORY. If you right-click the player you suspect of using Flash, do you get a short menu? Usually the last line of the short menu will indicate the player. For example, I created the attached screen shot on Adobe's page here: https://www.adobe.com/software/flash/about/ I personally use Ask to Activate with Flash v. 18.0.0.209, and all the previous versions for the past year or so, so Firefox 39 should be able to work with that setting for you. Actually, I'm not sure you are using Firefox 39, your post indicated Firefox 38. </blockquote> i noticed firefox had a new update so i just updated firefox (i now have the latest and greatest firefox) and it remained the same. so that means prior to firefox 38, it was fine and i was able to just simply click activate flash to manually play each single swf found on youtube or elsewhere. and i know this because i was able to do this less than a week ago until firefox prompted me saying theres a new update, i didnt exactly had a option so firefox updated to 38 (not sure if firefox released 2 updates within a week or probably it had been sitting there and when i closed my firefox browser it finally updated). i think i suspect all this is because 2 firefox updates ago, it didnt support html5 player or anything else. firefox seems to say it will use html5 player or whatever when possible, so how do i make html5 manual or disable it when using firefox 39?

Modified by volume

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Firefox does not have a click-to-play feature for HTML5 video, as far as I know. As noted earlier, you can set HTML5 video not to autoplay, but some sites work around this.

There are a range of other settings related to the HTML5 video player, such as settings to enable/disable MPEG, WEBM, and OGG media (some easy to understand, other convoluted). The best approach probably depends on what you want to do, for example, defer retrieval of media, block auto-playing of media, etc. There might not be a good solution-based setting; an add-on might be necessary.

There are two extensions to force Flash on Youtube, if that site is a particular concern:

Firefox does not have a click-to-play feature for HTML5 video, as far as I know. As noted earlier, you can set HTML5 video not to autoplay, but some sites work around this. There are a range of other settings related to the HTML5 video player, such as settings to enable/disable MPEG, WEBM, and OGG media (some easy to understand, other convoluted). The best approach probably depends on what you want to do, for example, defer retrieval of media, block auto-playing of media, etc. There might not be a good solution-based setting; an add-on might be necessary. There are two extensions to force Flash on Youtube, if that site is a particular concern: * https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ * https://addons.mozilla.org/firefox/addon/youtube-flash-player/
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 solutions 40132 answers

I use Flash Control which also controls the HTML5 Player. https://addons.mozilla.org/en-US/firefox/addon/flash-control/

I use Flash Control which also controls the HTML5 Player. https://addons.mozilla.org/en-US/firefox/addon/flash-control/

Question owner

jscher2000 said

Firefox does not have a click-to-play feature for HTML5 video, as far as I know. As noted earlier, you can set HTML5 video not to autoplay, but some sites work around this. There are a range of other settings related to the HTML5 video player, such as settings to enable/disable MPEG, WEBM, and OGG media (some easy to understand, other convoluted). The best approach probably depends on what you want to do, for example, defer retrieval of media, block auto-playing of media, etc. There might not be a good solution-based setting; an add-on might be necessary. There are two extensions to force Flash on Youtube, if that site is a particular concern:

these addons does force youtube to play flash but unfortunately they dont force youtube to manually activate flash despite my shockwave flash being ask to activate.

unfortunately i suppose it is as you had noted in your earlier post that in firefox 39, sites can work around this by using a script to send a play command to the script.

i now noted how you said 'in firefox 39', so it is mozilla firefoxs fault for causing this to happen. so in previous versions this work around does not work, does it? in that case, can you disable said scripts/have firefox reject said scripts?

''jscher2000 [[#answer-756611|said]]'' <blockquote> Firefox does not have a click-to-play feature for HTML5 video, as far as I know. As noted earlier, you can set HTML5 video not to autoplay, but some sites work around this. There are a range of other settings related to the HTML5 video player, such as settings to enable/disable MPEG, WEBM, and OGG media (some easy to understand, other convoluted). The best approach probably depends on what you want to do, for example, defer retrieval of media, block auto-playing of media, etc. There might not be a good solution-based setting; an add-on might be necessary. There are two extensions to force Flash on Youtube, if that site is a particular concern: * https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ * https://addons.mozilla.org/firefox/addon/youtube-flash-player/ </blockquote> these addons does force youtube to play flash but unfortunately they dont force youtube to manually activate flash despite my shockwave flash being ask to activate. unfortunately i suppose it is as you had noted in your earlier post that in firefox 39, sites can work around this by using a script to send a play command to the script. i now noted how you said 'in firefox 39', so it is mozilla firefoxs fault for causing this to happen. so in previous versions this work around does not work, does it? in that case, can you disable said scripts/have firefox reject said scripts?

Question owner

the-edmeister said

I use Flash Control which also controls the HTML5 Player. https://addons.mozilla.org/en-US/firefox/addon/flash-control/

this works better than that lousy flashblock addon. it would truly serve its purpose if it could only prevent flash from loading/downloading.

otherwise although the flash is not playing, it is still loading.

''the-edmeister [[#answer-756627|said]]'' <blockquote> I use Flash Control which also controls the HTML5 Player. https://addons.mozilla.org/en-US/firefox/addon/flash-control/ </blockquote> this works better than that lousy flashblock addon. it would truly serve its purpose if it could only prevent flash from loading/downloading. otherwise although the flash is not playing, it is still loading.
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

volume said

these addons does force youtube to play flash but unfortunately they dont force youtube to manually activate flash despite my shockwave flash being ask to activate.

I haven't tested those extensions so I don't know if that's just how they work. If so, they don't help you and you can ignore them.

unfortunately i suppose it is as you had noted in your earlier post that in firefox 39, sites can work around this by using a script to send a play command to the script. i now noted how you said 'in firefox 39', so it is mozilla firefoxs fault for causing this to happen. so in previous versions this work around does not work, does it? in that case, can you disable said scripts/have firefox reject said scripts?\

My comment was about HTML5 video that plays in Firefox WITHOUT USING ANY PLUGIN. The ability of sites to script around the setting to disable autoplay is not a new problem in Firefox 39: all versions of Firefox that could play HTML5 video have had this flaw. It will be fixed in a future version of Firefox.

But that has NOTHING TO DO with Flash. Flash activation should work normally on sites that use Flash. Did you confirm that using Adobe's test page?

Please, this is confusing enough without mixing up HTML5 video and Flash.

''volume [[#answer-756855|said]]'' <blockquote> these addons does force youtube to play flash but unfortunately they dont force youtube to manually activate flash despite my shockwave flash being ask to activate.</blockquote> I haven't tested those extensions so I don't know if that's just how they work. If so, they don't help you and you can ignore them. <blockquote>unfortunately i suppose it is as you had noted in your earlier post that in firefox 39, sites can work around this by using a script to send a play command to the script. i now noted how you said 'in firefox 39', so it is mozilla firefoxs fault for causing this to happen. so in previous versions this work around does not work, does it? in that case, can you disable said scripts/have firefox reject said scripts?\</blockquote> My comment was about HTML5 video that plays in Firefox WITHOUT USING ANY PLUGIN. The ability of sites to script around the setting to disable autoplay is not a new problem in Firefox 39: all versions of Firefox that could play HTML5 video have had this flaw. It will be fixed in a future version of Firefox. But that has NOTHING TO DO with Flash. Flash activation should work normally on sites that use Flash. Did you confirm that using Adobe's test page? Please, this is confusing enough without mixing up HTML5 video and Flash.

Question owner

jscher2000 said

I haven't tested those extensions so I don't know if that's just how they work. If so, they don't help you and you can ignore them.

i posted what i found when i tested those extensions for information purposes. doesnt solve the problem.

My comment was about HTML5 video that plays in Firefox WITHOUT USING ANY PLUGIN. The ability of sites to script around the setting to disable autoplay is not a new problem in Firefox 39: all versions of Firefox that could play HTML5 video have had this flaw. It will be fixed in a future version of Firefox. But that has NOTHING TO DO with Flash. Flash activation should work normally on sites that use Flash. Did you confirm that using Adobe's test page? Please, this is confusing enough without mixing up HTML5 video and Flash.

all firefox had this problem eh? really? didnt encounter this problem 1 or 2 firefoxes ago.

so it will be fixed in a future version of firefox eh? good to know its in the works. couldnt firefox just not allow html5 or something? its kind of like java when and it is a security issue, a pain in the posterior. additionally i believe html5 itself or their sites may use java so its a big potential security loophole.

''jscher2000 [[#answer-756868|said]]'' <blockquote> I haven't tested those extensions so I don't know if that's just how they work. If so, they don't help you and you can ignore them.</blockquote> i posted what i found when i tested those extensions for information purposes. doesnt solve the problem. <blockquote>My comment was about HTML5 video that plays in Firefox WITHOUT USING ANY PLUGIN. The ability of sites to script around the setting to disable autoplay is not a new problem in Firefox 39: all versions of Firefox that could play HTML5 video have had this flaw. It will be fixed in a future version of Firefox. But that has NOTHING TO DO with Flash. Flash activation should work normally on sites that use Flash. Did you confirm that using Adobe's test page? Please, this is confusing enough without mixing up HTML5 video and Flash.</blockquote> all firefox had this problem eh? really? didnt encounter this problem 1 or 2 firefoxes ago. so it will be fixed in a future version of firefox eh? good to know its in the works. couldnt firefox just not allow html5 or something? its kind of like java when and it is a security issue, a pain in the posterior. additionally i believe html5 itself or their sites may use java so its a big potential security loophole.

Modified by volume

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

volume said

couldnt firefox just not allow html5 or something? its kind of like java when and it is a security issue, a pain in the posterior. additionally i believe html5 itself or their sites may use java so its a big potential security loophole.

HTML5 video does not use Java. You can disable the Java plugin and it will make no difference.

As I said before, there are numerous preferences in Firefox that affect various details of HTML5 video. For example, you can disable decoding of MPEG media, which may block some sites from using HTML5 video. No time to research this now, please search.

''volume [[#answer-757446|said]]'' <blockquote> couldnt firefox just not allow html5 or something? its kind of like java when and it is a security issue, a pain in the posterior. additionally i believe html5 itself or their sites may use java so its a big potential security loophole. </blockquote> HTML5 video does not use Java. You can disable the Java plugin and it will make no difference. As I said before, there are numerous preferences in Firefox that affect various details of HTML5 video. For example, you can disable decoding of MPEG media, which may block some sites from using HTML5 video. No time to research this now, please search.

Question owner

well this is the best solution so far i found though its not as good as it was before when you simply can 'click to activate' flash

https://addons.mozilla.org/en-US/firefox/addon/quickjava/?src=search

use quickjava to disable javascript, java and flash while you are loading the pages you want, then when you need to look at the flash, enable QJ and refresh the specific page.

also goes good with

https://addons.mozilla.org/en-US/firefox/addon/youtube-flash-video-player/

this is also useful

https://adblockplus.org/en/

and perhaps this

https://www.google.com/settings/ads/plugin

AGAIN NOTE: none of these plugins is the complete solution but can be a solution i would say a temporary fix.

well this is the best solution so far i found though its not as good as it was before when you simply can 'click to activate' flash https://addons.mozilla.org/en-US/firefox/addon/quickjava/?src=search use quickjava to disable javascript, java and flash while you are loading the pages you want, then when you need to look at the flash, enable QJ and refresh the specific page. also goes good with https://addons.mozilla.org/en-US/firefox/addon/youtube-flash-video-player/ this is also useful https://adblockplus.org/en/ and perhaps this https://www.google.com/settings/ads/plugin AGAIN NOTE: none of these plugins is the complete solution but can be a solution i would say a temporary fix.