Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Get add-ons page is blank after installing FF/39.0,but all extensions appear.

  • 13 replies
  • 1 has this problem
  • 27 views
  • Last reply by jscher2000

more options

After installing and restarting FireFox #39.0 I found the problem as detailed in the above Question:

All Replies (13)

more options

The Get Add-ons tab actually displays a page from the Mozilla Add-ons site in a frame. If you right-click (Ctrl+click) the blank area, do you have the item This Frame on the context menu? If so, if you choose Open Frame in New Tab, are you able to load the content?

Since you do have quite a few extensions, could you run a manual update check? Above the empty frame there should be a "gear" button with a Check for Updates item. Not sure whether that would make any difference.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

jscher2000 said

The Get Add-ons tab actually displays a page from the Mozilla Add-ons site in a frame. If you right-click (Ctrl+click) the blank area, do you have the item This Frame on the context menu? If so, if you choose Open Frame in New Tab, are you able to load the content? Since you do have quite a few extensions, could you run a manual update check? Above the empty frame there should be a "gear" button with a Check for Updates item. Not sure whether that would make any difference.
more options

The (Ctrl+click) on the blank area did not bring up a context menu. I believe this may be caused by the fact that when I Click Add-ons in the Tools tab, it opens on the Get add-ons page, with a note stating “Loading” this continues until I am notified that the page has “Timed-out”. I also tried restarting in “Safe-Mode”, which did not solve or help the problem! Any more ideas? Thank you jscher. Regards, Dave

more options

Mine has this URL, followed by what looks like a list of all my add-ons (I've chopped that part off):

https://services.addons.mozilla.org/en-US/firefox/discovery/pane/39.0/WINNT/normal

Does that page load for you "stand alone" in a tab?

more options

The page as provided will not load at all?

more options

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Hmm, do you get a blank page, or time-out, or server not found?

Could you open Firefox's web console in the lower part of the tab using either

  • Cmd+Alt+k
  • Developer menu

then reload the page and look for any signs of response? I have attached a screen shot of the files loading when I hit that page.

more options

I was happy to read and review all of the available information provided to solve my problem. I restarted in “Safe-Mode” and it did not solve the problem! I also switched to the DEFAULT theme. Thank you cor-el. Regards, Dave

more options

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json file.


You can use this button to go to the current Firefox profile folder:

Modified by cor-el

more options

Hi cor-el, Sorry it has taken me so long to get back to you with my continuing problem of no Get Add-ons Page. I have tried to solve this problem using all of your suggestions. However, none have helped me so far! In addition I have made it worse as I thought that I would try and just refresh my Firefox and when I did not only did it not help with the Add-ons, it also removed all of my Extensions! Therefore right now my Firefox has become useless to me. I am considering just deleting it and using some other browser.

more options

There isn't a "one-click" way to undo a Refresh, but there is a multi-step procedure that usually gets the job done:

Overview

These are the steps detailed below:

  1. Create a new Firefox profile
  2. Remove everything from that new profile folder
  3. Copy in everything from the old profile folder

Create a new Firefox profile

Quit Firefox if it's running. Start up in the Profile Manager using the method in this article: Profile Manager - Create, remove, or switch Firefox profiles.

Notes:

  • Do not delete anything here!
  • Any time you want to switch profiles, quit Firefox and return to this dialog.

Click the Create Profile button, assign a name like OldSettings, and skip the option to change the folder location. Then select that new profile in the dialog and start Firefox.

Open the New Profile folder in Finder

Firefox in the new profile should look like a factory fresh installation. Open the Troubleshooting Information page using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table, click the "Show in Finder" button. Firefox will launch an Finder window showing the contents of your brand new profile folder.

Leaving that folder open, switch back to Firefox, and Quit/Exit. When Firefox closes, the new profile folder should be front and center, or you can activate it using the Task bar (?? or Mac equivalent).

Copy Old Data in Place of New

In that new profile folder, select all the contents and delete. Make sure you don't delete from your old folder.

Leaving that window open, open or switch over to your Old Firefox Data folder. Drill down into your old profile folder. At this level you should see a folder named bookmarkbackups among other things.

Select everything and Copy (either right-click > Copy or Command+c).

Switch to the empty new profile folder in other window and Paste (either right-click > Paste or Command+v). This may take a minute since some of the files are large.

Start Firefox

Firefox should start up in that new profile with the resurrected old profile data. Success?

more options

Still wondering why you can't load: https://services.addons.mozilla.org/en-US/firefox/discovery/pane/39.0/WINNT/normal

Does it time out, or give you a specific error message, or show a blank page, etc.