Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot play mp4 files

  • 5 replies
  • 2 have this problem
  • 16 views
  • Last reply by FredMcD

more options

On Windows Vista, firefox 38.0.5 cannot play mp4 files. Both MPC-HC and Windows Media Player can play mp4 files. I have ffdshow installed.

These are enabled:

   media.windows-media-foundation.enabled
   media.directshow.enabled

Results from https://www.youtube.com/html5 show:

Disabled: H.264, MSE & H.264, MSE & WebM VP9

Enabled: HTMLVideoElement, Media Source Extensions, WebM VP8

Youtube videos are also locked at 360p using the html5 player.

OGG / WebM files play fine.

Modified by chuck1899

All Replies (5)

more options

Can anyone help?

more options

You can check these media prefs on the about:config page:

  • media.windows-media-foundation.enabled
  • media.directshow.enabled
more options

They are both enabled.

Refresh Firefox - reset add-ons and settings Refreshing Firefox didn't seem to do anything either.

Modified by chuck1899

more options

It's been a month and even with Firefox 40.0.3 it still doesn't work.

Why?

more options

Sometimes, messages get lost from inactivity. Sorry.

check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also: