X
Tap here to go to the mobile version of the site.

Support Forum

Youtube displays error but still plays.

Posted

I recently updated to the latest version of Firefox on Windows 7 and I'm running into a slight annoyance with Youtube. At first, videos were only loading sometimes, but I updated my plugins and that took care of the problem. But now, whenever I load a video (it happens more frequently with embedded ones), I get the "An error occurred. Please try again later." error and then the video plays. I have cleared my cache and cookies, I've ensured that everything is updated, and I've tried using Firefox in Safe Mode. Nothing makes a difference. This is only a minor issue because, like I said, the video still plays after displaying the error...but I have to admit that it is a bit annoying. And I'd also like to make sure there isn't some bigger problem at play here. I've tried researching this, but all I can find are people who run into issues with videos not playing at all. Any suggestions?

I recently updated to the latest version of Firefox on Windows 7 and I'm running into a slight annoyance with Youtube. At first, videos were only loading sometimes, but I updated my plugins and that took care of the problem. But now, whenever I load a video (it happens more frequently with embedded ones), I get the "An error occurred. Please try again later." error and then the video plays. I have cleared my cache and cookies, I've ensured that everything is updated, and I've tried using Firefox in Safe Mode. Nothing makes a difference. This is only a minor issue because, like I said, the video still plays after displaying the error...but I have to admit that it is a bit annoying. And I'd also like to make sure there isn't some bigger problem at play here. I've tried researching this, but all I can find are people who run into issues with videos not playing at all. Any suggestions?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.11
  • Amazon MP3 Downloader Plugin 1.0.17
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Coupons, Inc. Coupon Printer Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • PlayStation(R)Network Downloader Check Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • 5.1.40416.0
  • Square Enix Secure Launcher
  • Unity Player 4.3.7f1
  • Windows Activation Technologies Plugin for Mozilla
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add to Amazon Wish List Button 1.10.1-signed (amznUWL2@amazon.com)
  • Classic Theme Restorer 1.3.4 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Classic Toolbar Buttons 1.4.8 (CSTBB@NArisT2_Noia4dev)
  • Classicish Add-on Manager 0.8.5.1-signed (classicishaddonmanager@dagger2-addons.mozilla.org)
  • Download Status Bar 12.3.0.1-signed ({6c28e999-e900-4635-a39d-b1ec90ba0c0f})
  • Element Hiding Helper for Adblock Plus 1.3.2.1-signed (elemhidehelper@adblockplus.org)
  • Flash and Video Download 1.73 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Flash Video Downloader - YouTube HD Downloader [4K] 7.3.1.1-signed (artur.dubovoy@gmail.com)
  • Ghostery 5.4.5.1-signed (firefox@ghostery.com)
  • Greasemonkey 3.2 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Honey 2.0.5.3 (jid1-93CWPmRbVPjRQA@jetpack)
  • Menu Editor 1.2.7 ({EDA7B1D7-F793-4e03-B074-E6F303317FB0})
  • NoScript 2.6.9.27 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Old Default Image Style 3.0.6.1-signed (olddefaultimagestyle@dagger2-addons.mozilla.org)
  • Old Google Image Search Beta4.rev53.1.1-signed (jid0-hVK3JChToUWBtJHMEmFM9ELeInk@jetpack)
  • RightToClick 2.9.5.1-signed ({cd617375-6743-4ee8-bac4-fbf10f35729e})
  • Saved Password Editor 2.9.1-signed (savedpasswordeditor@daniel.dawson)
  • Search By Image (by Google) 1.1.2.1-signed ({ce7e73df-6a44-4028-8079-5927a588c948})
  • Session Manager 0.8.1.6.1-signed ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Status-4-Evar 2015.02.06.23.1-signed (status4evar@caligonstudios.com)
  • Stylish 2.0.2.1-signed ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • User Agent Switcher 0.7.3.1-signed ({e968fc70-8f95-4ab9-9e79-304de2a71ee1})
  • Web Developer 1.2.5.1-signed ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Adobe Acrobat - Create PDF 1.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Download Statusbar 0.9.10.1-signed ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}) (Inactive)
  • F.B. Purity - Cleans Up Facebook 9.6.0 (fbp@fbpurity.com) (Inactive)
  • OPIE 5.0.2.1-signed (OPIE@guid.customsoftwareconsult.com) (Inactive)
  • Reddit Enhancement Suite 4.5.4.1-signed (jid1-xUfzOsOFlzSOXg@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 550 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x1244
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 089c196e
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 1800 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 4-8-2015
  • driverDate2:
  • driverVersion: 9.18.13.5012
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 550 Ti Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
orvi 3 solutions 47 answers

Youtube's support: https://support.google.com/youtube/an.../3037019?hl=en suggests these steps.

More troubleshooting steps include:

Have you tried changing your DNS to 8.8.8.8, Google's public dns? It is also possible to disable Shockwave Flash player and use the HTML5 player in the meantime. (In about:addons change the plugin to "Always Ask") Please try to adjust the quality of the video as well. Clear the cache and cookies Right click on the player and select "Global Settings" and go to Storage and delete. Another way to try this is to open a private window and open the same youtube url. Did this help?

In order to investigate this issue further, please let me know if there are any steps that are confusing or need more help

Youtube's support: https://support.google.com/youtube/an.../3037019?hl=en suggests these steps. More troubleshooting steps include: Have you tried changing your DNS to 8.8.8.8, Google's public dns? It is also possible to disable Shockwave Flash player and use the HTML5 player in the meantime. (In about:addons change the plugin to "Always Ask") Please try to adjust the quality of the video as well. Clear the cache and cookies Right click on the player and select "Global Settings" and go to Storage and delete. Another way to try this is to open a private window and open the same youtube url. Did this help? In order to investigate this issue further, please let me know if there are any steps that are confusing or need more help
FredMcD
  • Top 10 Contributor
4248 solutions 59413 answers

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Question owner

Thank you both for the responses. Unfortunately, none of these made a difference. I tried all of those options from Youtube's support, but nothing changed. As for Fred's suggestions...I have already updated to the latest drivers and I already had Protected Mode and hardware acceleration turned off.

Thank you both for the responses. Unfortunately, none of these made a difference. I tried all of those options from Youtube's support, but nothing changed. As for Fred's suggestions...I have already updated to the latest drivers and I already had Protected Mode and hardware acceleration turned off.

Question owner

For what it's worth...I updated to 38.1.0 ESR and the problem has become less common. I just tested with a handful of videos and only half of them displayed the error (it had gotten to the point where it was happening with every video) and when it did happen, the message came and went so quickly that I almost didn't notice it. So...still not ideal, but at least it's an improvement.

EDIT: Nevermind, it's back to how it was. I guess it was just a fluke...

For what it's worth...I updated to 38.1.0 ESR and the problem has become less common. I just tested with a handful of videos and only half of them displayed the error (it had gotten to the point where it was happening with every video) and when it did happen, the message came and went so quickly that I almost didn't notice it. So...still not ideal, but at least it's an improvement. EDIT: Nevermind, it's back to how it was. I guess it was just a fluke...

Modified by ZombieToast

jscher2000
  • Top 10 Contributor
8695 solutions 71079 answers

Does this happen in Firefox's Safe Mode? Just wondering whether any of your extensions might be blocking pre-roll adverts and causing this brief glitch, or doing some kind of rewrite on the player (some video recorders might not support the default player and may replace it).

By the way, you can confirm whether YouTube is serving the HTML5 player or the Flash player by right-clicking the player and checking the last item on the short context menu. If you get a long context menu (Firefox's default menu) in front of the short context menu, you can tap the Alt key to clear it so you can read the short menu.

Does this happen in Firefox's Safe Mode? Just wondering whether any of your extensions might be blocking pre-roll adverts and causing this brief glitch, or doing some kind of rewrite on the player (some video recorders might not support the default player and may replace it). By the way, you can confirm whether YouTube is serving the HTML5 player or the Flash player by right-clicking the player and checking the last item on the short context menu. If you get a long context menu (Firefox's default menu) in front of the short context menu, you can tap the Alt key to clear it so you can read the short menu.

Question owner

It wasn't happening in Safe Mode last night, but I am using Safe Mode right now and it is still happening. It doesn't seem to happen when I switch to a new profile, however. According to the info page on Youtube, the HTML5 player is enabled. I have to leave for a doctor appointment right now, but when I get home, I will try testing a new profile with all of the same add-ons/extensions as my default profile and see if that still causes issues. Maybe it will help me narrow things down a bit.

It wasn't happening in Safe Mode last night, but I am using Safe Mode right now and it is still happening. It doesn't seem to happen when I switch to a new profile, however. According to the info page on Youtube, the HTML5 player is enabled. I have to leave for a doctor appointment right now, but when I get home, I will try testing a new profile with all of the same add-ons/extensions as my default profile and see if that still causes issues. Maybe it will help me narrow things down a bit.

Question owner

After creating another profile and enabling all of my extensions, I wasn't having any issues, so I started going through all of the other files, one by one. When I got to the prefs.js, my problem was finally replicated. Just to be sure, I reverted that file back to the default and copied every other file from my profile over to the test profile. Everything was fine again. Then I copied my prefs.js file to the test profile and the Youtube error came back. So, it would seem that one of my preferences is the culprit here. The only problem is that I don't know if it's a preference tied to one of my extensions or to the browser itself. So...it looks like I might have to go through some of my "user set" preferences and play around with those. I'll start by searching for anything in about:config that mentions Youtube. If you might perhaps have a better suggestion, I'd love to hear it!

EDIT: No luck with that so far. Resetting all preferences mentioning "Youtube" didn't change anything. I did manage to find out that I had some remnants of an unwanted toolbar I removed a while back (Conduit), but removing everything related to that unfortunately had no impact.

After creating another profile and enabling all of my extensions, I wasn't having any issues, so I started going through all of the other files, one by one. When I got to the prefs.js, my problem was finally replicated. Just to be sure, I reverted that file back to the default and copied every other file from my profile over to the test profile. Everything was fine again. Then I copied my prefs.js file to the test profile and the Youtube error came back. So, it would seem that one of my preferences is the culprit here. The only problem is that I don't know if it's a preference tied to one of my extensions or to the browser itself. So...it looks like I might have to go through some of my "user set" preferences and play around with those. I'll start by searching for anything in about:config that mentions Youtube. If you might perhaps have a better suggestion, I'd love to hear it! EDIT: No luck with that so far. Resetting all preferences mentioning "Youtube" didn't change anything. I did manage to find out that I had some remnants of an unwanted toolbar I removed a while back (Conduit), but removing everything related to that unfortunately had no impact.

Modified by ZombieToast

jscher2000
  • Top 10 Contributor
8695 solutions 71079 answers

I would be especially skeptical of customized preferences starting with network.http since those may make low level changes in how Firefox interacts with websites.

I would be especially skeptical of customized preferences starting with network.http since those may make low level changes in how Firefox interacts with websites.

Question owner

I know it has been over a month, but I thought I would report back to say that I have finally isolated the problem. To be honest, I have mostly been ignoring it because I've been too busy and tired, but I was able to spend a couple of hours going through my preferences and I managed to narrow it down to media.windows-media-foundation.enabled. Once I set this to false, the problem immediately went away.

Sadly, disabling it also means that I'm forced to use the HTML5 player, which normally wouldn't be an issue, but YouTube forces me to always view videos at the lowest quality level. I admittedly don't know why, but disabling media.mediasource.enabled seems to at least cause Youtube to play videos at 360p when available (instead of 144p). I'd prefer if it would play at 720p or at least 480p, but at least it's something. And if I ever need to, I can re-enable the "foundation" and it will force Youtube videos to play in Flash, albeit with the error message.

I know it has been over a month, but I thought I would report back to say that I have finally isolated the problem. To be honest, I have mostly been ignoring it because I've been too busy and tired, but I was able to spend a couple of hours going through my preferences and I managed to narrow it down to '''media.windows-media-foundation.enabled'''. Once I set this to '''false''', the problem immediately went away. Sadly, disabling it also means that I'm forced to use the HTML5 player, which normally wouldn't be an issue, but YouTube forces me to always view videos at the lowest quality level. I admittedly don't know why, but disabling '''media.mediasource.enabled''' seems to at least cause Youtube to play videos at 360p when available (instead of 144p). I'd prefer if it would play at 720p or at least 480p, but at least it's something. And if I ever need to, I can re-enable the "foundation" and it will force Youtube videos to play in Flash, albeit with the error message.
jscher2000
  • Top 10 Contributor
8695 solutions 71079 answers

Hi ZombieToast, thank you for reporting back. When the MediaSource extensions are enabled, Media Foundation is enabled (and VP9 is disabled, which is the default configuration), usually YouTube will serve you MP4 in the HTML5 player. It sounds like that was mostly working except for the reloading.

As a short run workaround, either of these extensions will force Flash on YouTube:

However, that doesn't seem to affect embedded videos.

Hi ZombieToast, thank you for reporting back. When the MediaSource extensions are enabled, Media Foundation is enabled (and VP9 is disabled, which is the default configuration), usually YouTube will serve you MP4 in the HTML5 player. It sounds like that was mostly working except for the reloading. As a short run workaround, either of these extensions will force Flash on YouTube: * https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ * https://addons.mozilla.org/firefox/addon/youtube-flash-player/ However, that doesn't seem to affect embedded videos.