Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

IDM CC is incompatible with firefox 38.0.5.

more options

IDM CC is incompatible with firefox 38.0.5. now how can I solve this problem?

All Replies (1)

more options

Try installing the latest version if that extension. http://getidmcc.com/

http://getidmcc.com/#thanks A posting by Ayesh a month ago indicates that extension had to be updated for Firefox 38.0.1 .

Beyond that, look for a forum that provides support for IDM CC.