X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

ADOBE FLASH - Update error.

Posted

I am running Win7Pro, Firefox 38.0.5 and Adobe Flash 18 NPAPI.

Firefox will not run Adobe Flash content. Please advise how to fix. I have attempted to update adobe several time to no avail.

I am running Win7Pro, Firefox 38.0.5 and Adobe Flash 18 NPAPI. Firefox will not run Adobe Flash content. Please advise how to fix. I have attempted to update adobe several time to no avail.

Chosen solution

In case the problem is that the plugin is not activated, could you check the Add-ons page? Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" toward the bottom on a gray background and if you find it, change from "Never Activate" to "Ask to Activate".

(With that setting, when you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. If you do not need Flash to run on the site, simply ignore the notification.)

If Shockwave Flash is not listed on the Add-ons page:

Check for the Physical Presence of the Plugin DLL

On 64-bit Windows 7 that is here:

C:\Windows\SysWOW64\Macromed\Flash

and the file would be named NPSWF32_18_0_0_160.dll (unless there is a newer version with something different instead of 160).

If the file is there... and exiting and starting Firefox back up does not discover it...

One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there?

If Firefox is set to scan but still does not find Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is "Shockwave Flash" finally there?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.7.20033
  • Foxit PhantomPDF Plug-In For Firefox and Netscape
  • Google Update
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • iTunes Detector Plug-in

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Clearly 10.2.1.7.1-signed (readable@evernote.com)
  • Dictionary Extension 3.0.12.1.1-signed (jid0-raWjElI57dRa4jx9CCiYm5qZUQU@jetpack)
  • Evernote Web Clipper 6.0.15.1-signed ({E0B8C461-F8FB-49b4-8373-FE32E9252800})
  • Ghostery 5.4.5.1-signed (firefox@ghostery.com)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • McAfee WebAdvisor 4.0.0 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • NoScript 2.6.9.27 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • WorldIP 3.0.9.1-signed ({f36c6cd1-da73-491d-b290-8fc9115bfa55})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0102
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 201b8086
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 1-29-2014
  • driverDate2:
  • driverVersion: 9.17.10.3347
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8315 solutions 68040 answers

What is the error you're getting?

Adobe has an alternate download page if you want to try it. Select an installer for "plugin-based browsers" to update Firefox:

https://www.adobe.com/products/flashplayer/distribution3.html

What is the error you're getting? Adobe has an alternate download page if you want to try it. Select an installer for "plugin-based browsers" to update Firefox: https://www.adobe.com/products/flashplayer/distribution3.html

Question owner

I just get the You need to upgrade your Flash Player with a link to Adobe. I think I have already gone to the dist which is why I have Flash 18 NPAPI. I will look again.

I just get the You need to upgrade your Flash Player with a link to Adobe. I think I have already gone to the dist which is why I have Flash 18 NPAPI. I will look again.
jscher2000
  • Top 10 Contributor
8315 solutions 68040 answers

Chosen Solution

In case the problem is that the plugin is not activated, could you check the Add-ons page? Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" toward the bottom on a gray background and if you find it, change from "Never Activate" to "Ask to Activate".

(With that setting, when you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. If you do not need Flash to run on the site, simply ignore the notification.)

If Shockwave Flash is not listed on the Add-ons page:

Check for the Physical Presence of the Plugin DLL

On 64-bit Windows 7 that is here:

C:\Windows\SysWOW64\Macromed\Flash

and the file would be named NPSWF32_18_0_0_160.dll (unless there is a newer version with something different instead of 160).

If the file is there... and exiting and starting Firefox back up does not discover it...

One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there?

If Firefox is set to scan but still does not find Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is "Shockwave Flash" finally there?

In case the problem is that the plugin is not activated, could you check the Add-ons page? Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Look for "Shockwave Flash" toward the bottom on a gray background and if you find it, change from "Never Activate" to "Ask to Activate". ''(With that setting, when you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. If you do not need Flash to run on the site, simply ignore the notification.)'' <u>If Shockwave Flash is not listed on the Add-ons page:</u> '''Check for the Physical Presence of the Plugin DLL''' On 64-bit Windows 7 that is here: C:\Windows\SysWOW64\Macromed\Flash and the file would be named '''NPSWF32_18_0_0_160.dll''' (unless there is a newer version with something different instead of 160). ''If the file is there... and exiting and starting Firefox back up does not discover it...'' One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities: '''Confirm that Firefox is scanning the registry for plugins''' Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that: (1) In a new tab, type or paste <strong>about:config</strong> in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste <strong>scan</strong> and pause while the list is filtered (3) If <strong>plugin.scan.plid.all</strong> is not set to its default value of true, double-click it to toggle it back to the default. If you changed this setting, exit and restart Firefox to trigger another scan. If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there? ''If Firefox is set to scan but still does not find Flash and list it on the Add-ons page...'' '''Remove Firefox's plugin registry file''' Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins. Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * Help menu > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * File menu > Exit Pause while Firefox finishes its cleanup, then rename '''pluginreg.dat''' to something like pluginreg.old Start Firefox back up again. (If you want to restore your previous non-private session, use History &gt; Restore Previous Session.) When you return to the Add-ons page, is "Shockwave Flash" finally there?
spaceda 0 solutions 5 answers

hi after ff update to 42 adobe flash stopped working. none of solution found in internet worked, but with my quite interesting IT background I was able to find solution - remember it is just for firefox. I have win7 64bit but it should not be a problem to go with this solution on other win versions. Important is firefox. My problem was I couldnt get shockwave flash plugin to be recognized & loaded by firefox even it was installed in system properly.


1. Exit Firefox. If you have just installed latest version of flash version you dont need to uninstall it. Just remember to use latest OFFICIAL version. I was using also adobe lab flash version (v20) but it was freezing some websites... If you have old version you can uninstall it using official adobe uninstaller. 2. after installation in win 7 64bits there is a main folder accessible via two different paths - one is for w32 apps and other for 64bit apps in win64bit env, File you need is :

c:\Windows\SysWOW64\Macromed\Flash\NPSWF32_19_0_0_245.dll also available in linked directory seen by windows apps:

c:\Windows\SysWOW64\Macromed\Flash\NPSWF32_19_0_0_245.dll

3. if you have located the file simply copy it to YOUR USER mozilla data directory :(in win7)

c:\Documents and Settings\<YOUR USER NAME>\AppData\Roaming\Mozilla\plugins\

as two separate files: NPSWF32_19_0_0_245.dll NPSWF64_19_0_0_245.dll

4. start Firefox, go to addons->plugins. You should now see shocwave flash plugin with following details: Shockwave Flash 19.0 r0 NPSWF32_19_0_0_245.dll, NPSWF64_19_0_0_245.dll

5. VERY IMPORTANT: uncheck flash protected mode.close addon window. restart firefox.

6 DONE.

hi after ff update to 42 adobe flash stopped working. none of solution found in internet worked, but with my quite interesting IT background I was able to find solution - remember it is just for firefox. I have win7 64bit but it should not be a problem to go with this solution on other win versions. Important is firefox. My problem was I couldnt get shockwave flash plugin to be recognized & loaded by firefox even it was installed in system properly. 1. Exit Firefox. If you have just installed latest version of flash version you dont need to uninstall it. Just remember to use latest OFFICIAL version. I was using also adobe lab flash version (v20) but it was freezing some websites... If you have old version you can uninstall it using official adobe uninstaller. 2. after installation in win 7 64bits there is a main folder accessible via two different paths - one is for w32 apps and other for 64bit apps in win64bit env, File you need is : c:\Windows\SysWOW64\Macromed\Flash\NPSWF32_19_0_0_245.dll also available in linked directory seen by windows apps: c:\Windows\SysWOW64\Macromed\Flash\NPSWF32_19_0_0_245.dll 3. if you have located the file simply copy it to YOUR USER mozilla data directory :(in win7) c:\Documents and Settings\<YOUR USER NAME>\AppData\Roaming\Mozilla\plugins\ as two separate files: NPSWF32_19_0_0_245.dll NPSWF64_19_0_0_245.dll 4. start Firefox, go to addons->plugins. You should now see shocwave flash plugin with following details: Shockwave Flash 19.0 r0 NPSWF32_19_0_0_245.dll, NPSWF64_19_0_0_245.dll 5. VERY IMPORTANT: uncheck flash protected mode.close addon window. restart firefox. 6 DONE.
jscher2000
  • Top 10 Contributor
8315 solutions 68040 answers

Hi spaceda, if possible, it is better to fix Firefox's built-in feature of discovering the official folder because otherwise you will need to repeat your solution every time Adobe issues an update. Which is many times a year...

Hi spaceda, if possible, it is better to fix Firefox's built-in feature of discovering the official folder because otherwise you will need to repeat your solution every time Adobe issues an update. Which is many times a year...
spaceda 0 solutions 5 answers

Sure it is better. Agree. I think about it as temporary workaround - it is much better Mozilla fixes problem and maintains the fix. I just cant imagine it can stay for a longer time - but it is there for some time now..

regs

Sure it is better. Agree. I think about it as temporary workaround - it is much better Mozilla fixes problem and maintains the fix. I just cant imagine it can stay for a longer time - but it is there for some time now.. regs
jscher2000
  • Top 10 Contributor
8315 solutions 68040 answers

Hi spaceda, did you try the "Solution" in this thread to see whether that works on your Firefox?

Hi spaceda, did you try the "Solution" in this thread to see whether that works on your Firefox?
spaceda 0 solutions 5 answers

hi it did not worked. I had also tried with new profile. Same story - no flash in plugin

hi it did not worked. I had also tried with new profile. Same story - no flash in plugin
cor-el
  • Top 10 Contributor
  • Moderator
17087 solutions 154328 answers

Are you using a 32 bit Firefox version or a 64 bit version?

We can't see your user agent (WOW64 or Win64) since you posted in an existing thread.

Note that Firefox looks for registry keys to find plugins, so make sure that those keys are present. I do not know the exact keys for 64 bit Windows.

  • HKLM\Software\MozillaPlugins\@adobe.com/FlashPlayer
Are you using a 32 bit Firefox version or a 64 bit version? We can't see your user agent (WOW64 or Win64) since you posted in an existing thread. Note that Firefox looks for registry keys to find plugins, so make sure that those keys are present. I do not know the exact keys for 64 bit Windows. *HKLM\Software\MozillaPlugins\@adobe.com/FlashPlayer

Modified by cor-el