Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Saving Pictures is defaulting to JPEG instead of JPG

  • 20 replies
  • 4 have this problem
  • 826 views
  • Last reply by jscher2000

more options

When we click to "Save Image As..." option, the default "File As Type" setting used to be blank and would permit us to save graphics as JPGs. Now, for some reason, the default "File As Type" setting is set to JPEG. This is very inconvenient because we have to select the "All Files" option so that we can see the list of files we have already saved in order to keep our picture-numbering sequence in order for our operations. The other problem is that we can't use JPEGs because all of our web pages and print pages we publish are linked to files that are JPG, so if we convert to JPEG, we would have to entirely re-do all of our thousands of page templates.

We are using Firefox version 35.0.5. We have tried updating Firefox via their website. Didn't work. Then we tried uninstalling and then installing a fresh version, still same problem. Also, the problem is only happening on 2 systems that we have and not on the other 2.

Please help!

Chosen solution

cor-el is suggesting using RegEdit.exe. You can type or paste regedit.exe in the Windows Run dialog (or on Windows 7, the Start menu search box) and press Enter to run it. Usually you would get a UAC prompt to approve running the program.

RegEdit lists five different "hives" or top level sections in the left pane. If you expand the top one, HKEY_CLASSES_ROOT, then you can drill down to

HKEY_CLASSES_ROOT > MIME > Database > Content Type

In that section you should fine image/jpeg and then you can click that and view the assigned file extension on the right. I have attached a screen shot from Windows 7 for reference.

Does the problem system have .jpg or .jpeg?

Read this answer in context 👍 0

All Replies (20)

more options

I'm not sure, but I suspect there is an erroneous entry in one of Firefox's settings files. Unfortunately, the file is very hard to edit, so we generally suggest renaming it and letting Firefox generate a new one. After doing that, you may need to re-setup some application preferences, such as your preferred PDF viewer. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again and it should extract default application settings from the registry. Do JPEGs have the expected .jpg extension now?

more options

No, this did not work. Please help.

more options

If you right-click my user picture next to my post and choose Save Image As, what file type filter is displayed? I have attached a composite screen shot for comparison.

more options

Hi, it does save as a JPG. But the problem is that it is saving as JPEG in Firefox.

more options

mozilladude55 said

Hi, it does save as a JPG. But the problem is that it is saving as JPEG in Firefox.

I don't understand. You mean Firefox shows the .jpg filter, but when you save the file, it adds a .jpeg extension onto it?

If you copy your current mimeTypes.rdf file to a safe location such as your Documents folder, rename it with a .txt extension, and view it in an editor, you should be able to search for image/jpeg in the file. Some of the entries may list one or more file extensions. For example:

 <RDF:Description RDF:about="urn:mimetype:image/jpeg"
                  NC:fileExtensions="jpg"
                  NC:description="JPEG Image"
                  NC:value="image/jpeg"
                  NC:editable="true">
   <NC:handlerProp RDF:resource="urn:mimetype:handler:image/jpeg"/>
 </RDF:Description>

Do you find any that list "jpeg" as a file extension instead of "jpg"?

more options

Hi, the test was saved as a JPG in Outlook b/c that's where your response came to. I will have my fellow employee test this from their browser instead. I didn't realize that's what you wanted us to do.

Thanks!

more options

Ok, my fellow employee did indeed get save as JPEG after this above as well. What should we try next?

more options

Could your fellow employee look at the file as described in this post: https://support.mozilla.org/questions/1067644#answer-747178

The steps to find the file were in this post: https://support.mozilla.org/questions/1067644#answer-742437

more options

I saved the mimes file as a txt and opened in Notepad. I searched for JPEG and JPG and neither one is located in this file. What's the next step you think?

more options

I think I need to test in a clean profile, which means closing 20+ windows so I can't do it right now. What I want to see is: if I type or paste image in the search box on this tab:

"3-bar" menu button (or Tools menu) > Options > Applications

Is image/jpg or image/jpeg listed? And if so, does changing the handling to something different* add it to the mimeTypes.rdf file. Otherwise, I'm not sure how mine got in there.

* (not Firefox, because that can cause an infinite loop)

more options

I just tried that on my machine (without disturbing my employee) and image/jpg or JPEG does NOT come up on that list. I also read that CANNOT add an item to the list b/c it is very limited in action.

more options

We probably need to check on the problem system. After renaming mimeTypes.rdf, you would expect not to have image/jpeg or image/jpg unless it was extracted from the Windows registry. Perhaps we will need to manually hack the mimeTypes,rdf file if the problem keeps returning there.

more options

I did place the Mimes file from the problem system on the desktop of my system when I did that search. Not sure what you mean by hacking the Mimes file....

more options

If you search in the file for jpeg where does it show up?

more options

It doesn't. I tried searching for jpg and jpeg and neither one is located in this file. We did try re-installing Firefox additionally. No luck.

more options

You can Inspect the MIME database with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F.

Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately. You can export key(s) in the registry editor before making changes.

You can check specific file extension keys (e.g. .jpg) in the registry with the registry editor.

  • HKEY_CLASSES_ROOT\.xxx

You can check the linked MIME type in the MIME Database registry key.

  • HKEY_CLASSES_ROOT\MIME\Database\Content Type\
more options

Ok, now I'm completely lost on what to do. I appreciate the effort, I really do, but this is way over my head w/out specific detailed instructions.

more options

Chosen Solution

cor-el is suggesting using RegEdit.exe. You can type or paste regedit.exe in the Windows Run dialog (or on Windows 7, the Start menu search box) and press Enter to run it. Usually you would get a UAC prompt to approve running the program.

RegEdit lists five different "hives" or top level sections in the left pane. If you expand the top one, HKEY_CLASSES_ROOT, then you can drill down to

HKEY_CLASSES_ROOT > MIME > Database > Content Type

In that section you should fine image/jpeg and then you can click that and view the assigned file extension on the right. I have attached a screen shot from Windows 7 for reference.

Does the problem system have .jpg or .jpeg?

more options

Ok, that saved the day!! I went through your above instructions, and anticipated your next move. I manually changed the name of the default JPEG extension from .jpeg to .jpg.

Actually I also just found out that IE and Chrome work fine. And, Firefox looks at certain sites differently than others is why the default setting changes. Very surprised that JPEGs and JPEs even still exist today.

more options

Great news. I wonder what app changed it to .jpeg? Must be something uncommon.