Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Upgrading to yosemite, Firefox launches fine, works as expected. After a while its menus are responsive but does not load a single page anymore.

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by sergedg

more options

Firefox launches fine. Initially everything works. But after a while (ca. an hour) everything works (menus, settings, ...) except opening websites (spinning wheel). When you quit firefox, the windows close but the application is unresponsive.

I have the same behaviour when I only start the application, do not open a single site and leave firefox running: the same thing happens

I've tried removing all addons, did a refresh and a reinstall. Nothing works.

Aside from Firefox I do not have any side-effects from upgrading to yosemite.

Firefox launches fine. Initially everything works. But after a while (ca. an hour) everything works (menus, settings, ...) except opening websites (spinning wheel). When you quit firefox, the windows close but the application is unresponsive. I have the same behaviour when I only start the application, do not open a single site and leave firefox running: the same thing happens I've tried removing all addons, did a refresh and a reinstall. Nothing works. Aside from Firefox I do not have any side-effects from upgrading to yosemite.

All Replies (2)

more options

Try to disable hardware acceleration by starting Firefox in Safe Mode:

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Thanks for your response! I've tried your suggestion, but behaviour is the same. I also tried trashing firefox in "application support", again no change.