X
Tap here to go to the mobile version of the site.

Support Forum

Just recently my minamize, max, close button started dissapearing randomly.. how do I get them back permenatly? Thank-you

Posted

Mac User: I've always used Firefox and never had this issue until recently. Missing close, min and max buttons in upper left corner of web browser... They seem to disappearing randomly. All I can find is old info online on how to fix..

Mac User: I've always used Firefox and never had this issue until recently. Missing close, min and max buttons in upper left corner of web browser... They seem to disappearing randomly. All I can find is old info online on how to fix..

Additional System Details

Installed Plug-ins

  • Coupons Inc., Coupon Printing FireFox Plugin
  • Version 5.38.6.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • Trovi Search Plugin 1_0_0
  • Widevine Media Optimizer 6.0.0.12757
  • iPhoto6

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/Darwin/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x9488
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 4670 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Zydnar 0 solutions 4 answers

KC81 said

Mac User: I've always used Firefox and never had this issue until recently. Missing close, min and max buttons in upper left corner of web browser... They seem to disappearing randomly. All I can find is old info online on how to fix..

Could you attach some screenshots (extensions or interface modifications can cause this problem, I had the same).

''KC81 [[#question-1067565|said]]'' <blockquote> Mac User: I've always used Firefox and never had this issue until recently. Missing close, min and max buttons in upper left corner of web browser... They seem to disappearing randomly. All I can find is old info online on how to fix.. </blockquote> Could you attach some screenshots (extensions or interface modifications can cause this problem, I had the same).

Modified by Zydnar

cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157890 answers

Are you running Firefox in (permanent) Private Browsing mode (never remember history)? You could be experiencing bug 1166066 that happens when you are running Firefox in Private Browsing mode and you open links in a new window.

Possible workarounds:

(1) use Options/Preferences > General: "Open new windows in a new tab instead"
(2) Shift+click links to open in a new window with the standard features or use the right-click context menu.

You can modify dom.disable_window_open_feature prefs and change their value to true to prevent a website from disabling toolbars and scroll bars in a pop-up window


Bug 1166066 - Firefox 38 regression: link in private window with target="_blank" opens window with no tabs/toolbars/menus

Are you running Firefox in (permanent) Private Browsing mode (never remember history)? You could be experiencing bug 1166066 that happens when you are running Firefox in Private Browsing mode and you open links in a new window. Possible workarounds: (1) use Options/Preferences > General: "Open new windows in a new tab instead" (2) Shift+click links to open in a new window with the standard features or use the right-click context menu. You can modify dom.disable_window_open_feature prefs and change their value to true to prevent a website from disabling toolbars and scroll bars in a pop-up window *http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features ---- Bug 1166066 - Firefox 38 regression: link in private window with target="_blank" opens window with no tabs/toolbars/menus
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

A couple other Mac users reported this problem earlier this week, but we didn't figure out the source of the problem in those threads:

There must be some commonality among users with this problem but... what the heck is it?


By the way, your More System Details link shows you have a plugin named "Trovi Search Plugin". Most people consider Trovi to be intrusive unwanted software, so you may want to go through your add-ons and remove anything you don't recognize. You can open the Add-ons page using either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that all extensions are optional; none ship with Firefox.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

A couple other Mac users reported this problem earlier this week, but we didn't figure out the source of the problem in those threads: * [https://support.mozilla.org/questions/1067293 Website pop up windows no longer have upper left buttons to close them with] * [https://support.mozilla.org/questions/1067440 My browser buttons (red/yellow/green) at the top of the browser keep disappearing] There must be some commonality among users with this problem but... what the heck is it? ---- By the way, your More System Details link shows you have a plugin named "Trovi Search Plugin". Most people consider Trovi to be intrusive unwanted software, so you may want to go through your add-ons and remove anything you don't recognize. You can open the Add-ons page using either: * Command+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click '''Plugins'''. Set nonessential and unrecognized plugins to "Never Activate". In the left column, click '''Extensions'''. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. ''Bear in mind that all extensions are optional; none ship with Firefox.'' Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Possibly related: last month, some Mac users reported that the 3 buttons would disappear if you full-screened a video and then exited full screen for the video. A suggested workaround for that was to display the title bar, which is hidden by default.

Do you want to try that for a few hours and see whether it makes any difference? To display the title bar on each window, you need to click a button at the lower left of the Customize tab. See: Customize Firefox controls, buttons and toolbars.

Possibly related: last month, some Mac users reported that the 3 buttons would disappear if you full-screened a video and then exited full screen for the video. A suggested workaround for that was to display the title bar, which is hidden by default. Do you want to try that for a few hours and see whether it makes any difference? To display the title bar on each window, you need to click a button at the lower left of the Customize tab. See: [[Customize Firefox controls, buttons and toolbars]].