Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My browser buttons (red/yellow/green) at the top of the browser keep disappearing.

  • 8 replies
  • 14 have this problem
  • 5345 views
  • Last reply by VerizonSucks

more options

The control buttons on the top left of my browser keep disappearing!!!! They leave me with no other way that I know of to close or minimize the page but to quit firefox. That is not the problem unless I just want to look at other work on my screen but not quit firefox altogether but just toggle it up and down when needed. I am extremely frustrated by this!!!! This is not in any way convenient for using the internet and my other applications which do not require a browser to be opened.

Attached screenshots

Chosen solution

Possibly related: last month, some Mac users reported that the 3 buttons would disappear if you full-screened a video and then exited full screen for the video. A suggested workaround for that was to display the title bar, which is hidden by default.

Do you want to try that for a few hours and see whether it makes any difference? To display the title bar on each window, you need to click a button at the lower left of the Customize tab. See: Customize Firefox controls, buttons and toolbars.

Read this answer in context 👍 0

All Replies (8)

more options

Another Mac user mentioned this yesterday, but I don't think we have gotten to the bottom of it. As a temporary workaround, you can close the current tab using Command+w. I realize that doesn't help with docking the window...


Does this problem seem to occur in pop-up windows, or can it happen in any window? The reason I mention pop-up windows is there is a bug in Firefox 38 with the following combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link which launches the link in a new window (because the site coded the link with target="_blank")

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug:

(1) Use tabbed browsing (this is a checkbox under Preferences > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.

For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.

more options

I've had this problem occasionally as well starting in firefox 38. Usually, making the window really small and then making it really big makes the buttons reappear.

more options

neither of these answers solve my problem.. It "doesn't happen in any window" they just are there one minute and the next time you look they are gone!! Resizing the window doesn't work either. All I get is a smaller window with no buttons and then a big window with no buttons. I've gone so small with the window that all that is left is the first tab and then so big that the cursor is off the screen and still no buttons. The only way I have been able to get them back is to force quit firefox and the restart it. And then it all starts again.

more options

Chosen Solution

Possibly related: last month, some Mac users reported that the 3 buttons would disappear if you full-screened a video and then exited full screen for the video. A suggested workaround for that was to display the title bar, which is hidden by default.

Do you want to try that for a few hours and see whether it makes any difference? To display the title bar on each window, you need to click a button at the lower left of the Customize tab. See: Customize Firefox controls, buttons and toolbars.

more options

Thanks I will give it a try and see how it goes.

more options

Well it has been since yesterday and the problem has not re-appeared. Hopefully it has been circumvented. Thank you!!


Problem has ceased!!

more options

Having this problem in V39.0 on my Macintosh. It is intermittent, this last time I did have a video in one of the tabs in the problem window.

I was unable to play the embedded video, so made it full screen in order to access the "watch it on youtube" button, then it opened another tab, where it still would not play properly, so I used the "Youtube video and audio downloader" AddOn to download the video, then closed the tab(s).

After a while I noticed the buttons are missing. That window has about half a dozen tabs open.

more options

This problem has an newer thread as well:

https://support.mozilla.org/en-US/questions/1067440#answer-752023

Modified by VerizonSucks