Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not saving form history

  • 9 replies
  • 2 have this problem
  • 112 views
  • Last reply by cor-el

more options

Firefox not saving from history for this site.

https://www.asdapriceguarantee.co.uk/#info

The company has recently changed around and this form is on a different page. Before the change around the form was remembered and I only had to press the first letter or number of my name, address, emall etc and the full line was offered to me by FF and when clicked on the fields auto filled.

I have filled this form in 3 or 4 times now and no autofill is available. I also deleted the cookies for this when it did not work the first time. I use this form every week so this is very inconvenient. Other forms autofill so please do not ask me to check my settings. Passwords and user name are remembered so this is a problem for ASDA and Mozilla to sort out.

I am using Windows 7 on my main computer a Toshiba Laptop (2 years old). The problem also exists on my old computer a desktop using widows XP. I suppose it would as I am using sync with FF 38.05 on both devices.

All Replies (9)

more options

What form are you talking about?

Do you have to be logged on to see this form?

You can check the form and its input fields in the Inspector via Inspect Element in the right-click context menu. If Firefox isn't saving form data then there might be an autocomplete=off attribute present.

more options

cor-el said

What form are you talking about? Do you have to be logged on to see this form? You can check the form and its input fields in the Inspector via Inspect Element in the right-click context menu. If Firefox isn't saving form data then there might be an autocomplete=off attribute present.
more options

Where in the "inspect element" should I look. There are so many sections. What exactly am I looking for and how should I change it. Will my changes be saved permanently so autofill is available every time? That seems doubtful. Surely only the website owner would be able to permanently change the form attributes?

I don't have to sign in to use the form. It is the ASDA (UK subsidiary of Wallmart) supermarket site and the form it's self is one of the pages within this site. By filling in the form you can obtain a voucher.

As I stated when i posted the question i have no problems generally with autofill for sign ins and form filling . The ASDA site has changed recently and this problem coincides with this. Surely, therefore, it is between ASDA and FF somewhere, where the problem lies. Not for the user to fiddle round with settings.

more options

my problem isn't solved I don't know where you got that idea!

more options

Can you attach a screenshot that shows the Inspector window when you click Inspect Element while right-clicking one of these input fields?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options

Please see snips provided by the Windows 7 "snipping tool".

I cannot provide a screenshot from the PRTSC tool as it does not appear to work at all. The PRTSC key is also the "END" key and what ever i press with it shift, cap locks,ctrl, all that happens is that it takes me to the end of the page.

if i use the "start menu" and search for print screen then i click on it it seems to do something , it reacts but nothing is pasted into the Paint accessory.

So please look at the snips. thanks,

more options

I have a similar problem. A site I use for grocery store surveys (you get bonus gasoline points for doing the surveys) had previously stored my form data but stopped doing so several months ago. I just checked it using the Page Inspector tool and did find an "autocomplete off" attribute. So is there a way for me to turn this back on for this site? Or is this something the grocery store company did on their end?

(Other sites still do have my stored form data, so I know it's not turned off everywhere in Firefox. I had already checked that and had turned it off and back on a couple of times in case it was a glitch. So it's turned off for this one site. I also pulled it up in IE just now and used the IE tools and found the same "autocomplete off" attribute there.)

So can I fix it? (Or do I complain to the grocery store company on my next survey? lol)

Thank you.

more options

I think it is the stores concerned.

more options

You can always try to use the Inspector (right-click this field and choose Inspect Element) to remove this autocomplete attribute to see if that makes Firefox save this form data.