Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can I force a link to open in a non-active tab, instead of changing to that tab?

  • 2 replies
  • 1 has this problem
  • 280 views
  • Last reply by newalsace2

more options

For example, if you right click on a link and select the "open in a new tab" option, the new tab opens, but is not active. If you click on a normal link that would open in a new tab, Firefox goes to that tab and makes it "active".

For example, if you right click on a link and select the "open in a new tab" option, the new tab opens, but is not active. If you click on a normal link that would open in a new tab, Firefox goes to that tab and makes it "active".

Chosen solution

Maybe... Give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste tabs and pause while the list is filtered

(3) Double-click the browser.tabs.loadDivertedInBackground preference to switch it from the default value of false to true -- the line should turn bold


Since there are a number of similar-sounding preferences, here is my understanding of when they apply:

  • browser.tabs.loadInBackground => when you open a regular link in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = true, do not make the new tab active
    • In the Options dialog/page, this is controlled by the "When I open a link in a new tab, switch to it immediately" setting.
  • browser.tabs.loadDivertedInBackground => when you divert a script-generated new window to a new tab using Ctrl+click, or when a page uses the target attribute to launch a link in a new window and you divert it to a new tab
    • default = false, make the new tab active
  • browser.tabs.loadBookmarksInBackground => when you load a bookmark in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = false, make the new tab active
Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Maybe... Give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste tabs and pause while the list is filtered

(3) Double-click the browser.tabs.loadDivertedInBackground preference to switch it from the default value of false to true -- the line should turn bold


Since there are a number of similar-sounding preferences, here is my understanding of when they apply:

  • browser.tabs.loadInBackground => when you open a regular link in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = true, do not make the new tab active
    • In the Options dialog/page, this is controlled by the "When I open a link in a new tab, switch to it immediately" setting.
  • browser.tabs.loadDivertedInBackground => when you divert a script-generated new window to a new tab using Ctrl+click, or when a page uses the target attribute to launch a link in a new window and you divert it to a new tab
    • default = false, make the new tab active
  • browser.tabs.loadBookmarksInBackground => when you load a bookmark in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = false, make the new tab active
more options

newalsace2 said

For example, if you right click on a link and select the "open in a new tab" option, the new tab opens, but is not active. If you click on a normal link that would open in a new tab, Firefox goes to that tab and makes it "active".

The browser.tabs.loadDivertedInBackground worked out well, THANKS