Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

E-mail carrier comes up in new tab instead of home page

  • 6 replies
  • 1 has this problem
  • 40 views
  • Last reply by Cormorant

more options

Recently I have encountered a change when I open a new tab. Instead of the home page (as was previously the case) I get my e-mail carrier (mail.com) blank page with a pictorial history of recent web sites visited. The tab instruction in Windows is to open new tabs with the home page and there is no problem doing this when using Internet Explorer. Mozilla comments section says to click on a gear icon at the upper right of the screen. There is no such icon on my screen. How do I fix this? Thanks.

Chosen solution

By the way... in case you meant a separate new window (Ctrl+n) instead of a new tab in the same window (Ctrl+t), that should follow your home page setting. No need to go into about:config for that. See:

Add-ons can similarly override that setting, so see my comments on that in the earlier reply if Firefox is ignoring your home page when opening a new window.

Read this answer in context 👍 0

All Replies (6)

more options

Firefox doesn't know about the setting in Windows, but here's how you can change your new tab page using a hidden setting in Firefox:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

more options

Chosen Solution

By the way... in case you meant a separate new window (Ctrl+n) instead of a new tab in the same window (Ctrl+t), that should follow your home page setting. No need to go into about:config for that. See:

Add-ons can similarly override that setting, so see my comments on that in the earlier reply if Firefox is ignoring your home page when opening a new window.

more options

jscher's much appreciated response to my original query in June fixed the problem regarding what was brought up in a new tab. However, recently the same problem has returned and this time the Firefox about:config does not correct it. The page I want in a new tab is www.yahoo.com and that is already sitting in the browser.newtab.url. The system is overriding or ignoring it. I looked in "Extensions" in "Add-ons Manager" and found only 3 items (all disabled): Trend Micro BEP Firefox Ext.; Trend Micro Osprey Firefox Ext.; and Real Player Browser Record Plugin. Any idea what might be the problem this time? Regarding the about:config new tab why are there so many entries pertaining to browser new tabs? Many thanks for your help.

more options

Hi mcassady, it changed this week! Firefox 41 no longer uses the browser.newtab.url setting in about:config because it was constantly attacked by malware. Starting in Firefox 41, you need an add-on to change the new tab page.

Here are some options (I learn of more all the time):

  • If you already use the Classic Theme Restorer extension: There is an option somewhere (!) in its extensive settings dialogs to select a different new tab page.

Please only use one of these methods at a time, otherwise there may be conflicts and dysfunctionality.

Setting up New Tab Override

After installing this extension, you need to use its Options page to set the desired new tab page (instead of using about:config).

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, find New Tab Override and click its Options button. (See first screen shot attached.)

Depending on the height of your screen, you may need to scroll down to enter the desired address into the form. (See second screen shot attached.) For example:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Then tab or click away from that form field and you can test using Ctrl+t.

Success?

Once you have it set the way you want, you can close the Add-ons page (or use the Back button to return to the Extensions list from that Options page).

more options

Many thanks again jscher. The Mozilla add-ons new tab link fixed it.

more options

Many thanks again jscher. The Mozilla add-ons new tab link fixed it.