X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 38 display white text in native PDF viewer

Posted

Since Firefox 38 (not sure, might be also since 37) the native Firefox PDF Viewer pdfjs display only white text in all PDF files I open. I checked in about:config and I have the same default settings there like a colleague who has it working fine.

If I set pdfjs.disableFontFace to true it works on some PDF files but for example not on files which I generate with FPDF (nothing changed on the generation code). The font used in FPDF is Arial, so no problem there.

Any ideas?

Since Firefox 38 (not sure, might be also since 37) the native Firefox PDF Viewer pdfjs display only white text in all PDF files I open. I checked in about:config and I have the same default settings there like a colleague who has it working fine. If I set pdfjs.disableFontFace to true it works on some PDF files but for example not on files which I generate with FPDF (nothing changed on the generation code). The font used in FPDF is Arial, so no problem there. Any ideas?

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Disconnect 3.15.3.1-signed (2.0@disconnect.me)
  • Firebug 2.0.10 (firebug@software.joehewitt.com)
  • Old Location Bar 2.2.1-signed ({3205B348-523A-4fac-9BC4-9939CBF583B0})
  • Override User Agent 0.4.2.1-signed (jid0-loPSVTXuna1tvV6VUDn8H8FeQYE@jetpack)
  • Self-Destructing Cookies 0.4.7.1-signed (jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack)
  • The Addon Bar (restored) 3.2.1-signed (the-addon-bar@GeekInTraining-GiT)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (Inactive)
  • Nagios Checker 0.16.1-signed ({123b2220-59cb-11db-b0de-0800200c9a66}) (Inactive)
  • Tamper Data 11.0.1.1-signed ({9c51bd27-6ed8-4000-a2bf-36cb95c0c947}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 5400 Series
  • adapterDescription2:
  • adapterDeviceID: 0x68e1
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 3000174b
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 11-20-2014
  • driverDate2:
  • driverVersion: 14.501.1003.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 5400 Series Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Question owner

Hello,

I tried Safe Mode and I also disabled all Plugins but to no avail, PDFs are still rendered in white text.

I attached a picture of the problem. On the left is the PDF marked with CTRL+A while being out of focus. On the right is the same pdf without marked text.

Hello, I tried Safe Mode and I also disabled all Plugins but to no avail, PDFs are still rendered in white text. I attached a picture of the problem. On the left is the PDF marked with CTRL+A while being out of focus. On the right is the same pdf without marked text.
guigs 1072 solutions 11697 answers

Aoshi, I can see the screenshot of the issue, however in order to move forward we will need this information to file an issue in bugzilla.

  • Troubleshooting information: about configuration,
  • screenshots (what you have attached in your current post)
  • and test pdf (generated by FPDF)

This is the bug template: https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox&compon... Be sure to include the attachements in there as well, please post back with the bug I am happy to add any more information and add the subject matter experts to the cc list :-)

Aoshi, I can see the screenshot of the issue, however in order to move forward we will need this information to file an issue in bugzilla. * Troubleshooting information: about configuration, * screenshots (what you have attached in your current post) * and test pdf (generated by FPDF) This is the bug template: [https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox&component=PDF%20Viewer] Be sure to include the attachements in there as well, please post back with the bug I am happy to add any more information and add the subject matter experts to the cc list :-)
jscher2000
  • Top 10 Contributor
8690 solutions 71040 answers

It's normal for the selectable text layer to use transparent color so as to avoid obscuring the background canvas (not selectable), which should match the original document. I don't think there's any way to know whether the text is white on the background canvas or completely missing.

The pdf.js issues list for the query text missing yields quite a few open items, some of which seem to be be sensitive to the graphics card driver software: https://github.com/mozilla/pdf.js/issues?q=is%3Aissue+is%3Aopen+text+missing

It's normal for the selectable text layer to use transparent color so as to avoid obscuring the background canvas (not selectable), which should match the original document. I don't think there's any way to know whether the text is white on the background canvas or completely missing. The pdf.js issues list for the query ''text missing'' yields quite a few open items, some of which seem to be be sensitive to the graphics card driver software: https://github.com/mozilla/pdf.js/issues?q=is%3Aissue+is%3Aopen+text+missing